RoPieee LCD Beta stuff - tell it like it is

The web interface looks the same as before installing the display:

The touch interface does not react in any corner.

I would reflash the image and start again waiting for the system to restart itself each time

Mine took upwards of 10 mins to get to a display. It should look like this

Reflashing as we speak …

I know it’s hard but just be patient while it pulls all the updates and whatnot in over the net…it can take a while depending on the speed of connections etc

The text display will work on all booots but the graphic one needs the build that is running to enable it…if the web interface doesn’t show the rotate and zone fields then it’s not seen the display connected

Using RPi 3 and 16 GB Class 10 EMTEC SD card.

That should be fine I have 3 setups all off the same build so you should get there

Booting … fingers crossed :grinning:

Web interface has not changed.
The screen remained black during the whole boot process. :disappointed_relieved:
The RoPieee is not detected by Roon.
I had the Meridian Explorer² connected during booting, maybe that is not the best option.

No that does not make a difference. The web interface suggested that it did not detect the touchscreen during the installation process.

just to be sure: this is the official Raspberry PI Foundation display right?

Yes, official Raspberry Pi Foundation display puchased from The Pi Hut.
Just verified the connections and downloaded the image again.
Re-flashing now with Etcher.

Booting again, display is working, fingers crossed.

Display shows: “Connection Failure”.
RoPieee is detected by Roon.
I can play local music and Tidal music.
During first boot I saw one FAILED in red flashing by.
No reaction from the display on touch.
Web interface does not show display detected.

I sent feedback playing Coldplay - Kaleidoscope EP - Tidal Masters.

I have exactly the same issue.

The Image had no git included and the command expr was missing.

No idea what is going on. Thought is was the image.

Web interface has detected the display now:

But still no reaction to touch.

Have you approved the extension in the settings for roon core. You need to do this before it will work and then in the web interface you need to set the name of the endpoint you want to control.


Bingo !!! :thumbsup::thumbsup::thumbsup:
Thanks Simon.

btw Nice job Harry !!!


First of all, @spockfish , this is fabulous. My monitor and Pi3 arrived today, and it looks awesome. Thank you.

I wonder whether it would be possible in the release version to allow hyphens or spaces? No big deal ultimately, but for those that have multiple endpoints in one room, it would nice to avoid CamelCase for those not used to it (my family).

Also, unsure whether this is a problem or not, but my unit doesn’t show up as an endpoint in Roon (with USB selected but with no HAT selected). This doesn’t matter in my case (I’ve separated the monitor and digi functions), but wondered if this is as designed. Running 4.9.36-1-SPCKFSH.

If there is a hat it will show up, likewise if there is a USB DAC connected and powered up if it’s a big one it should also show up, and if you have more than one USB DAC they too should show up assuming you have added them in the audio settings of roon.

Do you mean as an endpoint in the audio settings of Roon or the signal path?

Mnes shows up like this.