RoPieeeXL-NG: another beta round

As promised, here’s the first beta of the new RoPieeeXL, based on the new RoPieee which just got released last week.

Some simple rules to make everyone lives (but especially mine :wink: ) easier:

  • Don’t use this if you want stable. Stuff will break. That’s a promise :wink:
  • If you think that this is the thread to share your feature requests… don’t. PLEASE don’t. This is purely about RoPieeeXL as it currently is, but based on a new foundation.

But if you’d like to help testing and find it fun to do so: you’re welcome to join!

2 things you will notice immediately:

  • HQP is missing. I’ve got it already working in the lab, but it will land in one of the next beta updates.
  • Librespot is missing, see HQP.
  • Bluetooth is missing. And I intent to keep it like that :wink: The bluetooth feature feels like a mistake from my side: it’s a huge pain to maintain and it’s bizarrely complex for what it needs to offer. So I know this is selfish, but it’s no fun in keeping it work. Unless someone sends me a DAC named after a little boy from a famous british hifi manufacturer … this is gone :wink:

So what do you need? An image either for the Pi 3 family:

And for the Pi 4:

In general I would expect this to take less time then beta testing ‘regular’, as this work is based on that.

Enjoy and let me know how things are going.



Alright! Let’s go! Excited to get started later today. Thanks Harry! (This was much sooner than I was expecting)

Good decision on the BT. I played with a “bt gateway” a while back and decided a phone works significantly better. Raspberry Pis and BT audio just seems half baked.

While I don’t use XL I wish everyone smooth sailing through this beta.

(I still need to find time to get my “Ropieee beta” on the stable path)

I will be happy to be on board as soon as HQP is available

1 Like

Losing Bluetooth for me is like “Bluetooth was a thing?” :slight_smile:

I will wait for the HQP release since I use that a lot.

Install went really well (and quickly!) on a RPi3, no issues.
Immediate observation is that Librespot isn’t working yet (which I am sure you are aware of!)
The options for Initial Volume, Normalisation and Account Username/Password are missing.

Hi Harry,

the hat is detected initially, but in Roon there is only the Shairport device, and that does not play, no Roon Bridge device.


The audio device (the HAT) is not initialised, hence no audio device, hence no output/visibility in Roon.

I’ve got no idea why, as the driver is properly configured. Can you check the physical connections?

One other thing (that might be related): I see quite a few ‘undervoltage’ messages. Do you use an official power supply?


Yeah. I wasn’t clear enough: next to HQP also Librespot is missing. But that one also works in my dev environment, so coming soon.

Many thanks Harry.

Will beta updates be OTA or SD flash?


In general I’ll leave a note here saying what has changed.

  1. It’s mounted on gpio, so connections cannot be the problem, using the hat like before.
  2. Power: You’re right, used a power bank, saw these undervoltage messages before, but it works with the old version. Now attached a 2.1 A PS (it’s a pi3), same result (see feedback). Also tried another one with 2.4 A.

252f5c776acc2e4e 2.1 A
9ca0c7356d1af6e0 2.4 A

same with me

So, I kept thinking it was stuck at “running rescue scripts”. First at stage 6, then at stage 10. Several minutes each. But it made it through…

so far works great as a Roon bridge as expected, but my other use case is LibreSpot, so I’m not really stretching its muscles yet. I’ll try to get to trying it on UPNP later.

So far so good!

1 Like

Just about to put on my Pi2AES. I’ve never had XL on that one before, but my kids always want to put Spotify on the main system, so let’s give it a shot (when you’re ready for LibreSpot, of course)!


I’ve pushed out an update with the following changes;

  • fix output for the Hifiberry DAC2HD (@nickpi)
  • support for Librespot
  • disable USB output option when USB is deselected

Next thing first is some UI stuff: in the current RoPieee there’s an indication if no hardware mixer is available for a specific HAT. For now I disabled that, because in the past I got a lot of questions about that message asking ‘if something was wrong with their setup’. Which isn’t of course, except that you can’t select hardware volume control and you need to do with software volume control.

So I need to think about a solution in which the UI informs users about the absence of hardware volume control, without users thinking that this is some kind of error.

Anyways, enjoy!

Thanks Harry.

All I can confirm at this point is that pi4->SMSL M500 and Pi2AES → Yggdrasil work great for hours as Roon Bridge. Will update and let you know about LibreSpot.

1 Like

Hi Harry,
no, still not found. Unfortunally, since you disabled ssh, I don’t see anything.
It’s shure not a hardware problem, since it worked with the stable version.


Hmmm… I’ll switch back to the previous kernel. Clearly a case of ‘too soon, too early’.

Same issue as NickPi, RoPieeeXL-NG: another beta round - #18 by Nickpi

Just an FYI as Harry is already aware.