Seeing no audio zones to select, 1.8

Everything was working fine last night after updating to 1.8, but this morning I’m unable to select any of my devices (RooopieXLs, PC audio, phone). They all appear in the settings and I can configure them. Able to stream spotify connect to RoopieXL without issue. Just not appearing in the audio zone to select, perhaps just a UI glitch?

I’ve tried rebooting my core, and disconnecting/reconnecting. I temporarily got 2 Of my 3 Roopies to show up, but they have since disappeared again. Works fine when selectable.

2 Likes

Same here, Phantoms work fine, pc speakers also, but Avantgarde Acoustics Zero-xd’s are not recognized by Roon. Turning on/off, reconnect etc. does not work. Assistence is helpful.

1 Like

Same here, worked fine yesterday. Woke up this morning with no available audio zones.
I can reproduce this on the Mac Roon app and Android.

Try to restart your core. And we are going to look into this one

1 Like

I tried that initially. 2 of my 4 devices showed up after that. They disappeared again after trying to make an adjustment to device settings.

Same here… restarting ROCK bought the audio devices back.

I had similar issue here. Yesterday all my zones were available and working. Then this morning the zones that were direct wired to the same Mac Mini server that my Roon Core resides on would not show up in the available zones to play from. However if I went to Setup->Audio the zone was there (Mytek Brooklyn) and enable. Note that other zones, not on the same server as the Core are available for selection to play music. So I tried to disable the zone and re-enable it. Still shows as enabled but not selectable for music playing. After restarting my Core all went back to normal.

I had turned off the Mytek Brooklyn in the evening so it would normally disappear as expected. But after powering it back up, it only appears in the Setup section and not the list of zones to pipe music to.

Of course me and most others tried that. I have Roon on my tablet and cell too. On the cell I can see all audio’s when i click ‘settings’. Then there appears a horizontal tab with ‘general’ ‘data’, ‘services’ etc. scrolling leads to ‘audio’ and there the zero’s appear. However, on my windows pc this bar is absent. After activating the zero’s on the cell I now see them on the pc as well.
Hence Roon support: how do I get the horizontal tabs in settings?

Same for me since 1.8 upgrade. no amount of restarts help. Chord Mojo attached to my MacBook Pro. It is enabled in the audio settings on the Mac, but does not show up when I select audio zone.

What if you restart the audio device ?

Restarting the audio device made no difference. Could see it in audio settings on the Roon client on the MacBook but couldn’t select it as an output device in Roon.

Just a moment… just a moment… Something I have done has got it working again - I rebooted both core machine and the laptop and its working now!

Same for me.

I don’t see:
Sonos Bean (visible and usable via direct AirPlay on all devices; not visible in Roon settings)
RoopieXL via Airplay (as above; Roon version is visible and I can play there; not visible in Roon settings)
Macbook Pro speakers (usage in MacOS; visible in Roon settings)
Sonata Hd Pro connected to Macbook (also usable when using directly from MacOS; visible in Roon settings)

My core is running on Synology. Sonos & Roopie are on the network connected via WiFi and Macbook is connected via ethernet. Rebooting Synology did nothing. All devices were visible & working on 1.7.

FYI, I created a separate but similar issue related to zone.

I’ve since done some poking around in the logs and find multiple entries like the following.

02/10 15:11:14 Debug: NotifyCorruptZoneDatabases Exception LevelDb.Exception: IO error: lock /roon/data/RoonServer/Database/Core/4fd4e0fc871d438485e75cccc619322d/transport/zone_16011368f99d8eb92075973da43e0eaec37c.db/LOCK: already held by process
   at LevelDb.Database._CheckError(IntPtr err)
   at LevelDb.Database..ctor(String path)
   at Sooloos.Broker.Transport.ZoneDb..ctor(String dbpath)
   at Sooloos.Broker.Transport.Zone..ctor(State state, Module module, Sooid zoneid, IEnumerable`1 endpoints)
02/10 15:11:14 Error: [transport] emptying out corrupt zone database 22:1:9df96813-b98e-7520-973d-a43e0eaec37c
02/10 15:11:14 Critical: scx: in OnExit: System.NullReferenceException: Object reference not set to an instance of an object.
   at Sooloos.Broker.Transport.Zone._CancelPendingSleep()
   at Sooloos.Broker.Transport.Zone._StopWithoutTouchingDatabases()
   at Sooloos.Broker.Transport.Module.NotifyCorruptZoneDatabases(IZone zone, Exception e)
   at Sooloos.Broker.Transport.Zone..ctor(State state, Module module, Sooid zoneid, IEnumerable`1 endpoints)
   at Sooloos.Broker.Transport.Module.ev_threadexit()
   at Sooloos.SynchronizationContextThread.OnExit()
2 Likes

Just got home. Some devices were showing again. Rebooted the Core, and devices. Nothing is showing anymore.

1 Like

Similar story here. Run RoonBridge on Ubuntu and have a half-dozen Chromecasts around the house. Core runs on Windows10 with i7. Updated to 1.8 and now I can only use two Chromecasts and two others are unselectable. The Bridge has droppped out completed. I rebuilt it again downloading fresh from downloads page, but no luck getting it to show in the Audio settings. Looking at the Bridge logs, it looks like it’s operating fine.

So far only the machine with Core running will play audio. UGh.

I just started having the same issue. My B&W Formation Wedge and Oppo are not listed in the audio zone list (using MacBook, IPAD, Windows, and Android), but are enabled under settings>Audio. Spotify can find them and I can find them with Bluetooth.

Similar to others.

I have 2 zones on wired network. When I Log on Roon 1.8, one Zone shows, the other never shows unless I tap couple. The second zone only then shows and I get audio over both zones. If I uncouple, both zones disappear and I must log off and then log on again to repeat the process.

So I can use Roon only if both zones are working. Attempting to use only one and both disappear and will not return . This problem was not present with 1.7.

2 Likes

nope after all. I get a different list of available zones each time I restart the Roon client

My zones came back last night, put the queues were wiped clean .

I have the same problem, though partially. Core is on a Mac Mini, and I have a variety of pi devices plus a couple of Airplay ones. Two of the pi endpoints can be selected and all of the Airplay ones. I can see the “missing” pi endpoint in Settings, can enable and disable it, but cannot select it. Bizarrely, I can group it with one of the other pi endpoints just fine. It just doesn’t show up in the zone selector.
Have rebooted the pi, etc. Nothing. It’s odd!