Setting up Roon with Mac Mini

Core Machine (Operating system/System info/Roon build number)

Mac Mini 2011 i5 2.3 Ghz,8 gig Ram, SSD drive Running High Sierra
Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Wi-Fi via Netgear Nighthawk R-7000 router

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

USB out of Mac to Emotiva DAC/Preamp Also can run via wifi from Mac to Auralic Aries Mini then out via USB to DAC/Preamp Not sure which would give best audio quality. Only using Tidal as a music source, nothing else.

Description Of Issue

I have fresh installs of both Roon and Roon Server installed on Mac mini. Using my iPad as a remote device. Having issues finding the core. I’m leaving the mac on 24/7. If I get the remote to recognize the core, and turning on the DAC/Preamp I have to get into the mac to turn on USB output everytime. Just wanting to know the best way to hook it all up.

1 Like

Welcome to the forum, @Bob_Collins.

You don’t need to run both Roon and Roon Server on the same machine. If you’re use the Mac Mini headless use Roon Server. Otherwise, just run Roon.

Fix this and you should be good to go.

Be aware, if you just run Roon Server then you’ll need another device to act as Roon Remote.

If I’m using roon server and there is no GUI, how do I tell it to accept remote connection?

I’m using my iPad as the remote.

You won’t be prompted to accept the connection, it works automatically.

Hi @Bob_Collins,

I would use just regular Roon on your Mac and not both Roon + RoonServer as to simplify things a bit and exit out of RoonServer.

Once you have Roon installed, I would double check that it is added to your Mac firewall by using these instructions alongside with exceptions for RAATServer.

You won’t be prompted for Remote Connections via RoonServer, this option is only available on the “All-in-one” version of Roon (regular Roon install).

When you are presented with the “Choose your Core” screen via the iPad, you will want to select the regular Roon (All in one) and not RoonServer.

Also, since you are using a Nighthawk router, I would ensure that you disable Enable Smart Connect in the router settings (As mentioned in our Networking Best Practices) as we have seen this setting sometimes interfere with remote connectivity.

Thanks Noris,

Those suggestions really helped! I have a couple more questions if you don’t mind.
I currently have the Audio output section on my Mac mini set at 2 ch 24 bit 192khz. Is this ok, or is it better to have this set differently and use the up-conversion settings in Roon instead?

Is there a setting on the Mac that will keep me from having to switch the audio to USB everytime I turn on my DAC/Preamp that it’s hooked up to.


In the device setup you want to enable Exclusive mode. This will let roon take care of the output and give you bit perfect. Then depending on your dac, you can either leave upsampling alone or play around with roon’s setting.

Also you might want to set the volume to fixed if controlling from amp.

Hi @Bob_Collins,

We don’t have your setup in-house to verify the best kind of way to configure it but what I can mention are the following points:

  • You will want to not use “System Output” when communicating with the DAC endpoint, but rather the native driver. You can enable and select the native drivers for the DAC in Roon Settings -> Audio Tab. More information on how to switch zones can be found in our Zone Guide KB

  • If you are using a driver that supports exclusive mode, I would go ahead and enabled this as @iamoneagain suggests. You can enable exclusive mode in the Device Setup tab and this can be accessed by right-clicking the zone name in the bottom right -> Device Setup. As I mentioned, not all types of drivers support this feature.

  • You can play around with up-sampling and see how you like it. Some users prefer to upsample everything to the maximum bitrate or keep the native. To configure up-sampling, you can use the DSP Engine.

As for the primary issue here of Roon Remotes having issues finding the Core, has configuring Roon to a single “All-in-one” install helped with this regard?

My Mac Mini is connected via USB to an integrated amp. As long as the amp is turned on and its source selection is set to “USB” (actually, “USB-B” in my case), then the Mini-to-Amp endpoint shows up for selection in the Roon “Zones” list. In that case I don’t need to do anything on the Mac side to tell it to use USB.

Now, if the amp’s source selection is set to something else (like coax), then Roon won’t even see the Mini-to-Amp USB-connected endpoint in the Zones list. That’s how my gear works, anyway.

I have the Mac in Exclusive mode now and I’m no longer using System Output.
But as you can see in the picture, Roon seems to be truncating everything down to 16 bit. Also, I can’t see to get any upsampling above 48khz. Any more advice to get the best performance out of my setup?

Doesn’t look like it’s connected to an external dac? And for MQA I don’t see you having roon doing the first unfold, unless that’s by choice.

Have you used your Mac’s AudioMidiSetup application to check the “Format” options for your amp (or other connected sound-output device)? My amp’s options go up to “2 ch 32-bit Integer 384.0 kHz”. The displayed Format options should depend on your amp’s (or other device’s) capabilities.

To take advantage of upsampling to those levels in Roon, you’d go into “DSP” setup for your endpoint/zone, then set “Sample Rate Conversion” . If I set mine to “Max PCM Rate (Power of Two)”, here’s the signal path display:

I’m responding to both iamoneagin and Tom. I’m outputting via USB from the Mac to my Emotiva Preamp w/ built in DAC. As for MQA, I’m not sure what the best setting for Roon is?

I have played with the AudioMidi settings, but again I’m not sure what is best. I will check the “Format” to see if it will recognize my Pre/DAC. Currently in Roon my sample rate conversion is Max PCM Rate. I don’t have a power of two option. How do you designate an endpoint?

Thanks for all the help! This is harder than I thought it would be. So many options!

Bob, you already must have enabled your Mac Mini. Use the same procedure to enable a separate endpoint (assuming one is physically connected, available, and compatible). Once it is enabled you should be able to select it in your Roon controller (iPad, laptop, whatever).

When you first start Roon in the controller, you may be prompted to “select an audio zone”. Otherwise, the previously-selected endpoint should appear in the lower right of your application window (with whatever label you assigned it). Click on it, and a list of available “Zones” should show up for selection. Or, you can click on the little speaker icon and transfer whatever currently is playing to another Zone/endpoint by clicking on the transfer arrows.

The Aries Mini only interfaces to Roon via Airplay, right? If so, then you’d be restricted to Airplay’s data rates.

I’m currently don’t have the Aries Mini in the system. Was trying to do without an extra piece of gear. It Looks like my Emotiva Pre/DAC is not being recognized by Roon (Bummer). Would it be better to use the Aries as my Endpoint and run out of that to my pre-amp via USB?

The Aries interfaces with Roon via WiFi.

Yes, but isn’t Airplay the WiFi protocol it uses? If so, then it would be restricted to 44.1 kHz data rates. But that is CD quality (a standard developed with the limits of human hearing in mind). So if it works, and it sounds good, go with that until you’re ready to upgrade. Or …

If I’m understanding your set-up options correctly, it would be your Mac Mini that Roon recognizes, not the pre-amp/amp connected to the Mac Mini by USB or whatever. Right? So if you want higher data rates than the Aries Mini supports, go with that?

I know many people on this forum do advocate separating the Core platform (like your Mini, I think) from the endpoint and, ideally, from the listening room. I’ve tried both ways (with the Mac Mini as both endpoint and Core, or with a separate Roon-ready endpoint and the Mini in the same or a different room). Not sure I can hear any significant difference in sound quality.

My 2 cents. Your own ears ought to be the better judge. And excuse me if I’m misunderstanding your options. You’re right, there are many!

Hello @Bob_Collins,

Can you please share a screenshot of your AudioMidi Setup after clicking on the Emotiva zone? Further information on how to access the AudioMidi setup info can be found on Apple’s Site.

Also, please share a screenshot of the Device Setup tab for your Zone in Roon. You can access Device Setup by right-clicking the zone in the bottom right-hand corner (should say “Speaker” according to your screenshot) and then pressing Device Setup.