Roon --- MacMini --- Marantz NR1200 (via HDMI)

Details on your Core machine (OS, Hardware specs, Roon build)
MacMini late 2012, 8GB ram, Roon 1.8, build 814

Details on your Remote(s) (OS, Hardware specs, Roon build)
iPad, MacBookAir, iPhone

Networking details (especially what hardware you’re using, how everything is connected, and anything notable about how it’s all configured)
Linysys wifi router ---- MacMini via wifi — Marantz NR1200 via optical cable

Audio devices in use
Marantz NR1200 connected to Wharfedale speakers by speaker wire

Library details
No library, streaming Tidal only

Hi there,

Let me start by saying that Roon is the best thing to have happened to me music wise my entire life.
I’m 48 years old and this is the first music system I’ve ever owned since my Sony Walkman days, 25 years ago, so please bear with my lack of knowledge.

I know that most people advocate a Roon Nucleus or a NAS, but I got the MacMini at no cost so I went that route. Set the MacMini up as below:
Linysys wifi router ---- MacMini (via wifi) — Marantz NR1200 (via optical cable)
I have fast wifi and so the music is coming through fine.

The Signal Path is here:

I’ve been trying to hook a HDMI cable up from the MacMini to the Marantz, but whenever I do so, theres no sound at all. The Optical cable setup works great, I want to do the HDMI as many posts here seem to indicate that the sound quality will be better via HDMI as vs the Optical.

I read many posts online, the ones below seemed especially similar to my issue.

Roon stopped playing on HDMI system output to Marantz AVR, scrolls through tracks and plays nothing
I tried the RAATserver backup solution on the MacMini and it didn’t help.

I’ve spent 4-5 days here looking at a bunch of other posts. Can’t figure out what to try next. Any advice appreciated.

Thanks so much!

Hi @Amit_Gupta

Is this signal path when playing via Optical or HDMI?

When playing to HDMI it appears to work, and you don’t get any errors or anything, you just get no sound. Is that correct?

Hi @dylan,
Thank you in advance :grinning:
Yes, the signal path posted above is the Optical path
On HDMI there’s no errors. Just no sound out of the Marantz unit.

I’ve done some more reading:

  1. I’ll double check the “audio” in settings on the MacMini this evening.
  2. Also repeat the connection with a different HDMI cable
  3. Try on a different input port on the Marantz

I’ll report the results of these back to you my time this evening (in 10 hours approx) (got to go to work now)

Our time zones are likely very different so this might be a slow back and forth, appreciate your patience and support

It might be as there could be no video on the HDMI the AVR thinks nothing is there or are you indeed getting video to the TV when its on?

@wizardofoz I think I see where you’re going with this thought - this evening I’ll connect the HDMI to the AVR and NOT connect any monitor to the MacMini

I connect as below currently:

  1. Computer monitor to the MacMini via the Thunderbolt port
  2. MacMini to Marantz via HDMI wire
  3. Marantz is connected to the TV via HDMI-ARC
    Both 1 & 2 are connected at the same time.

What happens is that the computer monitor resolution changes. But there is no image from the MacMini on the TV.

Thank you so much

Those images look like display port to VGA is that for the monitor? You might need to enable display mirroring. My guess is the AVR might not like having a video input with NO video thus wont activate any audio.

1 Like

I tried all of these … no joy :frowning:

  1. I’ll double check the “audio” in settings on the MacMini this evening.
  2. Also repeat the connection with a different HDMI cable
  3. Try on a different input port on the Marantz

I also tried connecting the MacMini to the Marantz via the HDMI cable (no VGA connected). This didn’t output the MacMini screen on the TV nor did it play any sound.

Any ideas?

Perhaps something as obvious as some Mac setting?

I assume you have selected HDMi in both the Sound section of Preferences as well as in the Audio Midi utility?


I just did that now:

  1. In Settings—Sound | I have options of Digital output via the optical cable - this works fine
    | I also have the option of MarantzAVR - this also works now! And outputs
    video (the screen to the TV)

  2. In Midi Devices | Theres Built in output - digital
    | And theres HDMI - Marantz AVR
    The settings of the above 2 are identical (only names change when clicked on)

I’ve also figured out screen sharing from “MacMini—MacBookAir”, so the MacMini is no longer connected to a VGA monitor like before.

Now, the HDMI output doesnt seem to let me select anything above 32/96 (in Zone settings / Advanced)
Any ideas about that?
Much appreciated gents! :slight_smile:

Hdmi can be quite variable bitrate wise, but macs can also be a bit finicky with multichannel too on hdmi especially for music.

I’m out of my depth here but you may be dealing with the limitations of the Mac and/or HDMI.

1 Like

So the HDMI to Marantz problem is solved.
I’ll keep looking about as to how to increase the bitrate to the max possible.

Thanks a tonne all of you :grinning::grinning::grinning: