Shift-Click to select multiple tracks at once is broken :-/ [Solved]

  • Select first track
  • Shift-Click on the last one and…
  • … tracks in between are not selected :roll_eyes:

macOS 10.13.4, Roon 1.4-310
(was working with previous macOS/Roon versions)



@support looks a new found bug

Thanks for the feedback @pl_svn, @Andrew_Webb, @wizardofoz!

Confirming that I am seeing the same behavior on my end as well and will be passing this information over to our tech team for further analysis.


1 Like

Thanks for you reports, @wizardofoz, @pl_svn, @Andrew_Webb! We can reproduce this behavior, as Eric stated above, and I put a ticket for our developers. Hope, we’ll get it fixed soon,



Hi all,

As far as I remember I used to be able to select ALL the tracks between where I right-clicked for the first time and then clicked again while holding SHIFT on my MacBook keyboard when looking at a playlist or an album in ROON.

Now only the tracks get selected that I directly clicked on. Am I doing something wrong?

Thanks for any help.

Is it the same issue described in this post

Ah ok! Thanks for your input

Any updates? It has been 3 weeks since the bug was first reported.

Its still not working correctly on my roon version. This is hugely annoying I must say. Any updates please, dear Roon team?

Thanks a bunch and have a good weekend.

1 Like

yup: it has not been fixed yet :disappointed_relieved:

All — Thank you for the feedback and bringing this to our attention.

This behavior you are noticing when using shift+click to select multiple items in Roon, where is this being noticed (i.e “album browser”, “track browser”, “album details”)?


Track browser
(there’s a screenshot in my OP :wink: )

but… thought there already was a ticket in for this :neutral_face:

Thank you for confirming that for me @pl_svn, the insight is appreciated.

We do indeed have a ticket open however, our techs have had varying results during their investigation/testing of this behavior. So besides thanking everyone in this thread for letting us know that this is still occurring, I wanted to re-confirm exactly where this is being seen to ensure the team has all the necessary information to make this reproducible in house.


1 Like

Sorry to be a pain in the behind, but has there been any progress? This is making my Roon experience quite exhausting atm.

Eric, any updates?

As of 6-17, I can confirm it is definitely in the “Playlist View”, e.g. select a playlist, and view list of tracks, Shift or Ctrl click functions not working for me. Not sure about other cases at the moment.

Thank you everyone for your continued feedback and more importantly, thank you for your patience.

I understand and agree that this situation is frustrating, but please rest assured that the team is on it. I have recorded everyone’s feedback from this thread into an ticket which has been with our QA team who have been conducting the investigation into this behavior. As soon as I am given an update as to where the team is in their testing/analysis I will be certain to update this thread accordingly.

Again, thank you for your patience and understanding during this process!

It still doesnt work… Has been 27 days since the last message.


This doesnt work in album view too. I really need this for the export feature. I have to select thousands of albums by hand now…

1 Like