Skips Songs / goes quiet [Resolved - Other applications prevented Roon from fully updating]

Skips Songs in the middle of a song.

Secondly the Audio goes quiet for no apparent reason.

Have to start the song over

Hi @Michael_Eugenio — Thank you for the report and sharing your feedback. Both are appreciated!

Based on the symptoms you’ve reported to us, it would appear that you are receiving audio dropouts. Our [knowledge base] (Loss of Sound after 5 seconds) has very good documentation on what can cause dropouts to occur and the best way for troubleshooting them. Can you give the article a read and let me know what you’ve tried so far?

Lastly, to help me better evaluate this behavior you’re reporting to us, may I kindly ask you to please provide the following:

  1. An expanded description of your current setup as seen here.

  2. Please outline your network configuration/topology as well as providing insight into any networking hardware you may be implementing. I want to have a clear understanding of how your devices are communicating and what tools are being used to make those connections possible.

  3. Can you provide some further insight into this behavior?

  • Does it occur with the same album/track(s) each time?

  • Do you find that file format and bit/sample rate have any influence on this issue?

  • Are you noticing this just with your personal collection or with TIDAL content as well?

  1. Do you have any active firewalls or antivirus applications currently running on your setup?


Hi Eric:

I would first like to thank you for your prompt response to my request for support. Related to what is going on at this time, I would be happy to articulate what you have requested as far as information about my system and what is exactly going on, however I would like to point out that this only started occurring after I installed the latest software update (1.3, build 223). Before I made this update to my system everything worked as it should.

That said, my system is as follows:
Mac Pro (early 2014 build) with 64 Gb RAM, 1 Tb SSD
Mac OS Serria, version 10.12.4
Roon is running “remote” to the system driving my Audio components

The system directly connected to my audio components is a Mac Mini running the same Mac OS, and it has 32 Gb of RAM, and 256 Gb of SSD storage. It also has Roon on that system and that is the “Master” which is where all configurations are made to the Roon system.

It does not matter which Roon software system I have running, I see the same symptoms. Again, the symptom is that when I pick an artist (in this case it was Maroon 5) and wish to listen to the whole album (picking Play Album) I choose the first track, and the audio starts as before, however now the audio will stop after approx 3-5 seconds, and Roon will move to the next track start playing it (in silence) for about the same amount of time and then move to the next track, at which point it stops choosing different tracks, however it plays the track it is on in silence, I get no sound out of the audio system speakers.

I have made no changes to any of my computer system hardware or software other than the OS updates I get from Apple, which I then install on all of my computers in my home network (I have a total of 3 desktops, and 2 laptops directly connected to my 10 Gb backbone. I only have Roon on the Mac Pro, and Mac Mini however.

Lastly, is there a way to revert back to the previous version that I had (which was version 1.3, and the build just before this one)? I look forward to your insight and support. If you wish to remote in to see in real time what is going on, I have no issue with that process.


Dr. Steve Nitenson

Hi @Steve_Nitenson ---- Thank you for touching base with me, the insight is very appreciated.

Moving forward, and apologies for any confusion on my part, but would you kindly clarify the following for me to ensure that I am conceptualizing the provided data correctly.

From my understanding, your Mac Mini (“The Master”) is currently hosting your Roon core and the Macbook Pro you mentioned is acting as a remote device, is this correct? Furthermore, how are your audio components communicating with the MacMini, my assumption is via USB, but please confirm.

Lastly, in regard to your request about rolling back to a previous version. This is not something we usually suggest, from a procedural stand point that is. If we were seeing wide spread reports of this behavior this would perhaps be an approach we would consider, but being as we have many user with similar configurations to yours running without issue my feeling is that something else could be having influence here. I am sure we can get to the bottom of it :microscope:

Looking forward to your feedback!

Hi Eric;

To clarify so that there is no misunderstanding regarding what the configuration I have is and what is currently the issue, please note:
• My Mac Mini is directly attached to my audio equipment (all seperates) via 802.3 using Cat 6 cable from my NP-30 (Premare separates) directly into my Mac Mini. As noted earlier, the Mac Mini is the system “Master”. And as also noted earlier, the Mac Mini has 32 Gb of RAM, and 256 Gb of SSD storage. The Mac Mini resides on my local LAN, which also has several other devices on the network that are not directly relivant to this matter.
• The Mac Pro (not MacBook Pro) is my “go to desktop” and has Roon loaded on it as a “remote” Roon device. It is easier to just leave Roon on the Mac Mini loaded and then make my selections from my desktop Mac Pro. It has the same configuration as the Mac Mini. NOTE – I am seeing the same symptoms on both computers. And as noted earlier, all sound equipment is running correctly, and the network is running as it should.
• All equipment (computer and sound system) was functioning within normal parameters until the most recent update that was made earlier this week. I upgraded both the Master and Remote (Slave). As noted earlier, I am running Mac OS Serria 10.12.4 on both computers that have Roon running.
• The specific symptoms are occurring on both computers. The symptom I am having is that when I load Roon (on the Slave) and choose Artist, and then choose a specific file, say Maroon 5, I then choose “play album” and choose Play. Then then I hear sound out of my speakers for about 3-5 seconds, after which time the audible sound that was coming from my speakers stops, however the trak will continue to play for another couple of seconds and then the Roon system moves to the next track, starts to play that (no audible sound however) track and then goes to the next track doing the same thing.
• If I choose a different artist, the same symptoms occur with the exception that when choosing the second artist, and starting to play that album, I do not get any audible sound, and the track plays through the whole song, just no sound.

The empirical position I have is that my problems have started since the new update. All was working as it should prior to this update. I am fine with attempting to resolve this matter without reverting to a previous version as you noted in your response to me, however I am at a loss as to how to even begin to trouble shoot what is going on.

As I offered, if you want to set up a remote session, you could actually see what I am describing above, however, if you are OK with my description above, I would like to move to the next phase of resolving this. I will do whatever you wish to assist in aiding you in assisting me. Please let me know how you wish to proceed.

All the best,

Hi @Steve_Nitenson ----- Thank you for the follow up and the clarification.

Moving forward, I would like to grab a set of logs/timestamps from you and will be contacting you via PM momentarily with instructions.

In the meantime, can you please verify the following for me:

  1. Does it occur with the same album/track(s) each time?

  2. Do you find that file format and bit/sample rate have any influence on this issue?

  3. Are you noticing this just with your personal collection or with TIDAL content as well?

  4. How is collection being stored? External HD? NAS? Internal HD?

  5. You’ve mentioned in your follow up that you are noticing this behavior on both devices (core and remote). To confirm, if you play content directly our of the internal speakers of the Mac Pro, you receive this skipping behavior?