Sonos - "Lost control of audio devices" ("Play:1") ("Playbar")

I am experiencing this issue as well. Core running latest version on QNAP NAS, playing to Sonos Play1’s. I think rebooting the Play1’s resolves the issue. I also tried playing music using the Sonos application and it DID work but after stopping Sonos playback, Roon clients (Windows/android latest versions) still receive the same transport error.

I have noticed that this issue happens sometime when clicking in the track spectrum to move forward/back in the song. Yesterday when I had the issue I tried again in about 4 hours and it did not receive the error.

Just “lost control” of Sonos Playbar while adjusting the EQ settings. Playbar was playing, made an eq adjustment from Windows 10 PC, playback stopped like it usually does after making an adjustment but playback didn’t start back up so I backed out of the EQ settings, clicked Play and received the “lost control” error.

Hi @Scott_Muckleroy ------ Thank you for the feedback and sharing these observations you’ve made with the mentioned Sonos based audio zones in your setup.

Moving forward, to help aide in our evaluation of this behavior may I very kindly ask you to please provide the following:

  • An expanded description of your current setup using this link as a guide.

  • Please describe how the “Play1s” and the “Playbar” are communicating with Roon/network. I want to have a clear understanding of how information is being passed long your network and all the devices involved with making these connections possible.

  • Are you noticing any other patterns in behavior besides those mentioned in the report?

  • If you have any other endpoints active in your setup how are they responding? Any troubles?


Core- v1.4 build 298, 64-bit running on Quad core QNAP TVS-882 NAS i5 6500, 16 gig RAM, 6 x 6TB, 4 x 512GB SSD’s Tiered storage, (3) teamed 1 gig connections to switch.
Clients- Latest android client and 1.4 (build 298) windows 64-bit clients. Surface Pro 3, High-end Desktop, Pixel 2’s, Galaxy Tab S.
Network- Ubiqtuiti AC AP’s (2), Ubiquiti USG FW/GW all running latest firmware. Netgear ProSafe Switch JGS516PE (Latest firmware. IGMP Snooping disabled, power save disabled, Flow control disabled). IGMP Snooping was causing clients to not connect to the core.

I HAVE received the transport error on ALL client devices when a Sonos is the playback device. I have NOT been able to duplicate the error on the desktop PC when the playback device is the Emotiva DC-1 DAC connected by an optical cable. Clicking in the graph of the track that is playing seems to be the most reliable way to produce the error.

Music (~ 6,000 tracks) is stored on the QNAP where Core is running.

Thanks for touching base with me and providing the requested feedback @Scott_Muckleroy, very appreciated!

In terms of the issue being experienced with the mentioned Sonos endpoints, at what frequency would you say they are occurring? Is this behavior readily reproducible?


Daily. It happened this morning again so I switched back to the Sonos app. It almost always happens when clicking next track or clicking in the song graph to move forward or backward in the song.

I forgot to mention that if I start some music and don’t skip songs or seek forward/backwards, Roon will stream overnight and still be working the next day. I don’t know if I mentioned it earlier, but if I get disconnected in the application and then open it back up a couple of hours later it will be working again. I have to say that I’m loving Roon (aside from these issues) and don’t regret buying a Lifetime license. However these issues will have to be resolved before I would ever consider having the wife just using Roon. Long story short, there is very little WAF at the moment.

Thanks for the insight @Scott_Muckleroy, very appreciated!

Being as this behavior seems to be reliable reproducible I would like to enable diagnostics on your account so our team can have a closer look into this behavior as this action will automatically generate/upload a diagnostics report containing a set of your Roon logs directly to our servers. But before I do that may I very kindly ask you to please perform the following:

  • Please reboot your core machine.

  • Once your Roon core is back online please reproduce the issue and note the time when the error is observed.

    " It almost always happens when clicking next track or clicking in the song graph to move forward or backward in the song."

  • Also note what was playing at the time when the above was performed.


I just tried to get the error for about an hour and and am very surprised that I couldn’t get it produce the “lost control” error. However, at 11:59am the Sonos Group “Kitchen and living room” locked up and now I can’t play, pause, skip or anything. And then around 12:03pm the master bedroom locked up. I tried to transfer the zone to my Pixel 2 and just get the “transferring” Roon hour glass. I will let you know when I get the “control” error again. Have there been any updates pushed out to Core? I think I am running on 298?

Eric- It happened this morning between 7:09am and 7:30am. At 7:30 I noticed that music stopped playing so I opened the app on my Pixel 2, clicked Play and received the error. I also tried to click Play in the app on my Surface Pro 3 and received the same error. I just checked UniFi and all of the Sonos devices have 99% signal strength.

After the issue this morning I rebooted the Core and everything is working again.

Thanks for touching base with me @Scott_Muckleroy, the insight is appreciated!

Confirming that I have received the mentioned diagnostics report which is now attached to your ticket which I am preparing for our tech team review. If any additional information is need by the team I will let you know and if not, once the team has completed their evaluation I will be sure to share their thoughts/findings with you ASAP.

Your patience is very appreciated during this process!

Eric- I just received the “Lost control” error while skipping tracks on Tidal. Time was about 8:46am Pacific.

Hi @Scott_Muckleroy ---- Thank you for your patience and my apologies for the slow response.

To offer a quick update, this issue has been with our tech team who have been vigorously trying to reproduce this issue in our QA lab so we can have a better understanding of what could potentially be causing this behavior to occur. This has been quite the challenge for the team as our attempts to reproduce the problem in house have had mixed/varying results. As you are aware, in order for us to address the issue we must first be able to replicate it.

Part of the challenges we are facing stem from the fact that everyone has a different network configuration with a varying amount of devices being implemented (routers, switches, powerline adaptors, etc). So pinpointing the variable(s) that could be influencing the performance of our Sonos integration has been quite arduous. Our plan is to set up some field testing in an environment where the issue can easily be replicated.


This happened to me out of the blue last night, tried to play a track from Roon on my iPad and got the message * Transport Roon lost control of the audio device *

Tried from my iMac and got the same message.
Rebooted everything this morning and still Roon will not play through Sonos play3.

Happens to me daily if I’m using the app on Android/Windows frequently to skip tracks.

A post was split to a new topic: (B334) Pause causes Roon to lose control of Sonos device

Hey Scott – Build 334 is live, and we are hoping things will be more stable for you now.

I added Dylan here as well – please let us know how things are with Build 334 on your Core.

We’ve also added some additional diagnostic and troubleshooting tools in the latest builds, which we can adjust via your Account settings in the cloud. If you’re still seeing instability, we can try some additional tuning and Dylan can help with that.

Appreciate your patience and feedback here Scott. Thank you!

This is great news and I upgraded everything to the latest version the morning it was announced. So far I have NOT received the disconnect error message. :slight_smile: Chromecast support is also huge. Thanks again and I will let you know if I have any more issues.