Spinning Roon of Death

2017 Imac running 10.13.2

Have installed and uninstalled five times.

Credentials work fine on website.

Spinning Roon of Death no matter what I try with the App.

The credentials are fine, the Mac is fine. This is a software problem.

Fix it or give me my money back please.

1 Like

Hi @Jonathan_Lovvorn,

Since experiencing this issue have you tried rebooting your Core machine?

Was this working for you previously? If so was there any change to your setup, either networking or on your Core machine?

If you disable any antivirus or firewall on the Core are you able to log in?

Thanks for getting back to me.
Was working for months on previous IMac.
IMac died. Installed backup on this iMac. All other apps working and internet.
Multiple reboots, multiple installs and uninstalls of Roon. Multiple download of Roon disk image. Firewall off. Internet working for Qobuz and Tidal directly, can login to apps and play.
Tried changing Roon password. Still nothing but spin.
The fact that I can post here means Room is accepting my credentials over the internet.
Just not via the app.

Lol @ “Spinning Roon of death.” Quite the catchy phrase.

I was trying to think of something that might stand out in the sea of threads :slight_smile:

1 Like


Just created new trial account under Russ Lovvorn, and it fired right up and logged in perfectly.

The problem is I paid for the year on my other email address so it needs to be fixed or migrated to to the new account in the next 14 days, or I will be in $240 into this quagmire, rather than $120.

How did you restore the Roon database backup? If you just used Time Machine it might mean Roon hangs trying to figure out the database. To test this, create a new test user on OSX and seeing if Roon runs there.

So at the moment I am only using Roon to manage Tidal and Qobuz. I have not imported any hard files. So I don’t think there was anything to restore. But if I understand you, if I can find that database and delete it, it might stop hanging. That’s a pretty good idea!

Changed email in primary account, still nothing.

Went back to secondary and works fine.


Hopefully the Roon people can help. Flagged accounts for you.

If you’ve installed Roon from a TimeMachine backup, then this might be the problem.

Maybe with the steps described in those threads you can solve the issue.

BTW I think Roon should not give one troubles when a TimeMachine backup is involved.

Hi @Jonathan_Lovvorn,

It sounds like there might be an issue with your primary account or with the method in which you restored your iMac from the backup (as mentioned Time Machine backups can cause similar issues).

@accounts has already been flagged here, and they can take a look at the account status when this flag reaches their queue. I have also unlisted this thread since they may need to provide a more individualized response for you.

In the meantime you can try to set the old database aside to see if it will help. To do so, you will need to perform the following steps:

  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder

Can you give those steps a try and let me know if that helps with this issue? If not, then it would be best that we wait for the accounts team to verify the account status.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.