Stable release 2018/09/01 (160)


(Harry ten Berge) #1

Hi,

A little bit earlier then I originally planned, but here’s a new update. This update fixes the annoying issue of the 1GB on the Pi 3B+ that some of you are having (resulting in ticks and pops on USB audio).

Furthermore I switched to a different architecture for communicating between the different components. This results in the display being able to support non-latin characters on the display for one, but the response time to button clicks as also increased dramatically. This also lays the groundwork for remote controls: I already have an RF-based one working over here, so that will land soon.

And by far the biggest change in this release is switching to RoPieee’s own mirror infrastructure for the OS related part. Being based on ArchLinux has it’s advantages (“always being up to date with the latest”), but it also has it’s challenges (“always being up to date with the latest”) :wink:

What does it mean in real life? That we won’t be bitten anymore by sudden OS updates that impact RoPieee’s software components as well. This had lead to a few moments the last year where all of a sudden stuff stops working outside my control. Those days are over (fingers crossed).

So what’s not in that I promised? Different LED mode’s. That will need to wait for the next release.

Here’s the changelog for completeness:

  • FIX: force ethernet to 100MB on Pi 3B+
  • IMPROV: display supports non-latin characters
  • IMPROV: switch to RoPieee’s own ArchLinux mirror
  • IMPROV: bump Linux Kernel to 4.14.66
  • NEW: native DSD support for iFi Audio Pro iDSD

Enjoy!


Noise during playback with SMS 200
(NachoGo) #2

Hi Harry, I´m new to Ropieee. Two weeks and working perfectly. This is the first update in my case. To update Ropieee just reboot and the update will be trigger, wait some minutes till the process ends -led slow blinking- and that´s it, isn´t it?

Thanks a lot


(Harry ten Berge) #3

Hi,

Welcome on board!
Basically you don’t need to do anything indeed. After a reboot the update is being pulled in automatically, in the background. So no need to wait for anything, you can use RoPieee as you normally do.

Regards Harry


(NachoGo) #4

A pleasure! Looks like a great, easy, transparent and convenient update system, I just reboot and yes, the new version number is there, in the web admin, and the RPI-Ropieee is working ok so far.

Awesome. Many thanks.


(John Aiello) #5

Harry, rebooted twice this morning but never saw the update. Still running 153. Strange.


(Harry ten Berge) #6

can you send me feedback? then I can have a look


(John Aiello) #7

Done. Identifier 72f7a3d73. Just tried my third reboot. No joy.


(Harry ten Berge) #8

Ok. I found out what the issue is. Just not sure how to fix this unfortunately. There has been a (small) damage on your SD card, and the thing is that’s exactly the part that needs to take care of pulling in the update.

Are you familiar with SSH? Putty for example? Then I can instruct you what to do.

Regards H


(John Aiello) #9

Yes I am familiar with SSH but I use a MAC so Putty doesn’t work for me. I use Terminal. Instruct away Obi-Wan.


(Nathan Wilkes) #10

Harry, for those of us using the beta channel (with the issues with ROCK), do you advise switching to stable or staying on beta?

Thanks, as always.

Nathan


(Harry ten Berge) #11

Login with username: root and password: root

Run the following commands:

rm -rf /boot/RoPieee/ropieee-rescue
pacman -Syu pacman-contrib
reboot

Good luck!


(John Aiello) #12

Harry do I just copy the three commands and run them or do I do one at a time?


(NachoGo) #13

Hi Harry, as I told before, Ropieee updated ok, looks like, and is working with no problem, but in the Web Admin page there is an inconsistency in the versions: in two places, up and very bottom, shows version 153, but in the middle detail list shows the 159-1 and the right date (20180901). Is that normal?

Thanks in advance


(John Aiello) #14

Harry it worked great. I figured it was one command at a time so that’s how I proceeded. It worked great and now I am at 160. Thanks for the help.


(Harry ten Berge) #15

yeah that’s just a caching issue. next time after a reboot it will be fine


(NachoGo) #16

Great, thanks!


(Sean) #17

Hey Harry @spockfish

Spoke to dad and he said with v160 he’s seeing flashing of the progress bar, on RopIeee Touchscreen.

The tracking time is still progressing correctly but the blue progress bar continuously flashes.

Is that normal with this update?


(Sean) #18

@spockfish he’s sent feedback c989b7960099d7d5


(Malo6008) #19

Touch display doesn’t show any info anymore :frowning_face:

Just sent c36f1185e38c1da8.
Since this night’s update I’ve got a Connection Failure and I had to re-enable the Remote Extension. Failure has gone now. But Touch display doesn’t show any info anymore and is unusable except for the power button. Functionality is OK (ropieee is streaming to my DAC).

I’ve restarted ropieee several times and also the Roon server…


(Harry ten Berge) #20

Can you restart the unit?