Storage folder on NAS cannot be detected! [Resolved]

Because of a complete system remaking of my Linux server, I had to scan my entire music library on NAS from scratch.
I pointed at the network drive. Initially, I could not see the Music folder. Then, after restarting the NAS (as explained in 1.3 Mac: NAS folder empty [fixed by restarting the NAS]), folder was detected and scan begun.
About half way through the library I had to restart my PC, thinking that Roon Server would resume its scan. However, now the library is back to zero (no music scanned) and it cannot find Music folder on NAS anymore.
I tried to restart NAS with no change.
I tried to stop e restart Roon Server, no change.
Although path to my NAS is enabled (I tried to cancel it and restore it too), Music folder and other folders in that path cannot be detected!

I do not know if it is related to some form of cache.

Incidentally (I do not know if it related), in my RealTime status I see this line:
75 115 /opt/RoonServer/Mono/bin/RoonAppliance --debug --gc=sgen --server RoonAppliance.exe -watchdogport=45663

Please help.

Has the IP address of the nas changed after the reboot?

No, it hasn’t, I checked.

Hi @bibo01 ---- Thank you for the report and sorry to hear of the troubles.

Moving forward, may I very kindly ask you to please expand on your setup description, using this link as a guide. Furthermore, can you please use the instructions found here and upload us a set of your logs, so we can have a closer look into what is going on here.

Looking forward to your feedback!

Thanks Eric for your reply.
It seems that the problem was due to a kernel update. By reinstalling kernel update and then restarting NAS, Roon Server began scanning the library again.
It’s fine now.

1 Like