Stuck adding music to library, some tracks still lack to be identified [Solved]

I’m stuck on “adding Music to Libray” , spinning circle, but no progress …

Local issue or roonlabs server issue ?

1 Like

How to know which tracks are causing the infinite spinning circle behaviour ?
Any help welcome

Hey @volpone,

Would you mind to share your logs with us ? I’ll PM you shortly.


Your welcome @vova

I’m getting this too, identifying albums, which were already in the roon library, stuck spinning circle icon, constant scanning with a lot of hard drive activity, never seen this before. just started today.

I’m waiting for a Roon return on this issue based on logs analysis.

Hello @Blaine_Arnold,

Is it still spinning ? Have you tried to restart RoonServer ?


Check your PM, please.

Thank you @vova.

I fixed it using a backup.
Probably something wrong with the database during the migration from OSX to WIN10 as you stated.

Also (but not related) it is important to change the library path syntax after the database migration.
See: OSX to WIN10 migration issue: Truncated NAS library path? [SOLVED]?

yes still spinning, i left it over night, and continues spinning this morning. restarted computer, still happens

Hey Arnold,

I’ll contact you shortly to gather Roon logs.

Having an issue similar to this one, constantly spinning, some tracks not identified, I’m not expecting Roon to identify all but should the spinner stay spinning all the time? I tried removing unidentified albums/tracks but his didn’t help!

Any help appreciated.


I have the same problem.
A few days ago without adding anything “Of 15 track, 15 added, 0 identified”.
And nothing happens the whole day, reboot of PC didn’t change anything.
Server, Remote and local music all on the same PC.
Then I shuted down the PC and was on a business trip till today.
After being back, boot PC and starting starting roon, know I see “Of 549 track, 549 added, 534 identified”. This hadn’t change in the last hour.
What is happening here?

Add: Cleared cache and now I’m back to “Of 15 track, 15 added, 0 identified”
Add2: CPU load on roon and roon server is <1% on my i5

I have this issue too [Roon 1.2 Build 142] on Synology DS415+. As a result (I’m pretty sure) anything played to any zone or group summarily stops after several minutes.

@vova any news on this issue?
what can we do to stop it?

1 Like

Hey @AE67,

Sorry for slow response here. I’d like to look at your logs first, because @volpone and @Blaine_Arnold had different issues.

I’ll PM you shortly with more details.


Hi @vova,

thanks for your response. But it’s like toothache. If you are finally at the dentist, it didn’t hurt no more.
After spinning for a whole week (with daily reboot of the whole system) with always 15 tracks left, today
everything is back to normal.
Are the logs still interesting for you? I will send them to you, no problem.
Or should I wait, if the problem occurs again?

Best regards

Hi @vova
I now have this problem, stuck with
“Of 13 tracks, 13 added, 0 Identified”.
I have tried deleting the whole library and reimporting it
but the issue keeps returning.
Is there a generic solution for this? Or is it case-by-case …?

Weird after two restarts of Roon the issue has gone away, whereas yesterday restarting Roon and deleting/reimporting the library didn’t clear it …

doing the same thing again. had about 100 albums I edited the flac tags of, Roon re-scanning folder, stuck at 28 tracks ‘adding music to library’