Suddenly no connection to (running) Core

Dear everyone,

since you helped with connecting my PC DAC to Roon everything worked like a charm and brought me many joyful hours. Until this evening: When I came home, none of my remotes (PC via cable, iPhone/Android Blackberry via Wifi) would be able to connect to the core. They do see the core 1, but they are unable to connect.

There were no changes between this morning - when Roon played internet radio on a squeezebox - and tonight. To my knowledge no firewall, firmware or whatsoever was touched.

The core is running on a QNAP TS-251+ (8GB). The PC and the core are connect through a switch (trendnet TEG 582g). The switch is connected the router (Fritz!Box 7360) via a Fritz!Powerline 1000E. All other systems are just fine.

I already cleared the cache (deleted cache folder on QNAP), restarted every device a couple of times, even updated the QNAP firmware. The Roon-core itself does not complain

Do you have any suggestions?

Thank you in advance!


Hey @Alex,

I’m wondering if your firewall could still be the reason why you are not able to connect. Can you check to make sure that both Roon and RAATServer are listed as exceptions? We have previously seen issues with Powerline adapters so it would be a good test if you could temporarily connect your QNAP to the router instead of the powerline adapter.

We have also seen FritzOS cause some communications issues with router firmware updates that happen behind the scenes, do you by any chance have “Software Packet Acceleration” as an option on that box? I would recommend disabling it as per our Networking Best Practices. Please let me know if that helps!


Dear Noris,

thanks a lot for your answer.

I checked the following:

  1. The firewall still holds all exeptions as they were before (when it worked).
  2. I connected the QNAP to the router via cable, no effect.
  3. I checked the Fritz!Box. Surprisingly it is still on FRITZ!OS 06.30 with no way to update. I assume my provider controlls the firmware.
  4. I checked the ports, they are open as suggested (LAN to WAN firewall settings).

But still - it did work before.

I also tried to find a way to turn off the mentioned Software Packet Acceleration in FritzOS, which seemed to be the answer in a similar case (Android app can't connect to roon core since avm router update to FRITZ OS7), but I could not find any control alike. My guess is, that my old FritzOS and/or my provider does not want it be turned on/off.

Do you have any more ideas?

Thank you,

Hey @Alex,

I have gone ahead and enabled diagnostics mode for your account and what this action does is automatically upload a set of logs to our diagnostic server. I’m reviewing the diagnostics and noticed something here:

  • I am seeing a file on your HH-Q1 potentially causing some issues and causing your QNAP to be stuck:
    01/09 01:13:46 Trace: [analysis] analyzing trackid=2571314 url=/share/CACHEDEV1_DATA/.qpkg/RoonServer/roonmnt/Multimedia/Musik/Lossless/000 - Backup/Lyambiko/Muse/02 - I Went To Heaven_ADMIN_Jan-27-113424-2016_Conflict.aiff

Can I please ask you to move this file out of that folder and then reboot the server? Please do not delete the file just yet because if we narrow it down to the cause for this issue I’d like to get it over to QA to take a look.


Hey Noris,

it worked. I moved the file out of the monitored folder and after a reboot roon is up and running again.
I suppose you’d like to check the file?

Thank you very much!

Hey @Alex,

Glad to hear that it worked :slight_smile: .
Yes I would kindly request the file from you, I have just PM’d you instructions on how to get it over to us.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Hi @Alex,

We’ve recently released Roon 1.7 (Build 521) which includes changes that should improve this behavior. Please give it this a try and let us know how it goes!

You can read the full release notes here:

The Team at Roon Labs