System Output not working [SOLVED - updated Realtek drivers]

I just installed Roon for the first time in my life. At first glance I really like it, but I am having an issue with it.

In Roon, my primary AMD HD Audio Device is working just fine (connected via HDMI to a Marantz AV7005). I’m running WASAPI, in exclusive mode. The playback seems to be bit perfect: the way I like it.

However, I sometimes also like to use the default playback audio device. I connected a 3.5mm jack directly into the motherboard to a LG Speaker Dock.

The controller is the Realtek HD Audio (driver version I disabled all sound effects and applied no spatial sound format. The default format is 16 bit, 44100 Hz. I did not check exclusive mode options for this device. This device is the default audio device in Windows. When playing a song via JRiver, it all works. So the LG Speaker Dock works fine. When configuring the audio device in Windows, I can hear the test beeps while testing the speaker configurations.

In Roon, I pretty much tried all the Device Setup options for the “System Output”, but it isn’t working yet. I click a track to play, the playbar starts for just a blink and then immediately stops (though the AMD Audio device works just fine).

Please advice.

Set up:

  • Roon 1.3 build 247 stable (64 bit)
  • Windows 10 version 1703, build 15063.483
  • Processor AMD A6-3500
  • Ram 8 GB
  • Asus F1A75-M PRO motherboard
  • Music is stored on drive J, an internal hard drive
  • About 7500 tracks, 70 gb
  • 3.5 mm jack connected to a LG speaker dock (system output)
  • HDMI cable connected to a Marantz AV7005

Thanks for the all the details @Frans_van_Hofwegen - I’m sure we can figure this out.

Do you get the same results by selecting the Realtek device (without enabling Exclusive Mode) as you do when using System Output?

Can you also send us some logs as described here?


Hi @mike,

Yes, it doesn’t matter either way. Exclusive mode is off by default on this device. I only tried different settings because I thought it might have helped.

I have only set up the AMD HD device in exclusive mode.

Are you using AVAST by any chance?

Hi @Rugby, I am using ESET NOD32. I tried pausing the protection and try again, but it won’t work.

Hi @Frans_van_Hofwegen ----- Thank you for the report and the continued feedback. Both are appreciated and sorry for the troubles here.

Moving forward, I have received your logs and have placed them into our queue to be evaluated by a member of our tech team. Once my report has been updated and passed back I will be sure to update this thread promptly.

In the meantime, I see you have mentioned the use of the ESET NOD32 antivirus software and have tried testing with it disabled :thumbsup: Besides this application, do you have any active firewalls in place by chance? If you do, I would recommend re-conducting the test with both the firewalls and ESETNOD32 both disabled (temporarily of course), to see if this yields a change in behavior here.

Lastly, just to confirm, you are still seeing this behavior with the most recent build (248), correct?


Hi @Eric,

I’m using build 247. I re-downloaded the installer from the website, but it’s build 247. I have also just tried disabling ESET NOD32 and the firewall.

Please note that the AMD HD device continues to work flawlessly.


Hi, @Frans_van_Hofwegen, I took a look at your logs, looks like there is a problem with your Realtek Driver, your system says to Roon that 44.1 files are not supported. I suggest you to download new audio drivers from AMD web-page and see if it works for you. If that doesn’t help, remove all your audio drivers and let Windows to install them itself from scratch. Thanks for your patience!



Thanks! I will try that. As far as drivers are concerned, I don’t really keep track of them because updating them usually means trouble.

Hi everybody,

updating the Realtek drivers fixed the problem for me. Getting the updated version took a bit of time because Windows 10 listed the driver as being up-to-date. On the Asus website there isn’t a newer version available either.

So I had to go to the Realtek website and download the latest driver there. Confusingly, Realtek lists a different version number on their website than the Device Manager in Windows. I updated the Realtek driver from version to Realtek offers this update as driver version R2.82, released on July 26th 2017.

Thanks again.