Text being cut off

I haven’t had a chance to really dig deep into the software but it does feel snappier and that was an issue affecting me before this build, so this is a welcome update.

I noticed something I’ve never seen before, not sure if it’s a bug and/or if it’s something on my end. But there’s some text that is cut off in many areas of the software. Is anyone else experiencing this?:

Hi @Mac_Rebant,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Are you seeing this behavior on all remotes, or just a certain one? If only one remote, please be sure to include specifics about that device.

The jaggy letters seem to indicate a font scaling issue (Noto, especially Noto Sans, looks unsure about where the letters should get actually rendered and misses the line, somehow) .

Would really be interesting to know what OS and what display / font scaling settings you’ve on your client - most likely set outside of the Roon app, @Mac_Rebant

I’m also having this issue on my PC using Windows 10 Pro. Any help greatly appreciated, thanks!

I don’t know if this is relevant, but my “Make Everything Bigger” setting under the Ease of Access settings is 125%. This has never affected Roon before, but, maybe there are some under the hood changes that I’m not entirely familiar with at play here.

If there are any other relevant things I could take a look at which might help, I’d really appreciate someone letting me know. Thanks again!

Just to test: could you set it to 100% and check how things look in Roon (you’d probably need to restart the Roon app)?

1 Like

Thanks for the reply!

So, I have changed my settings to 100% and Roon is completely fine. Good news!
We found a resolution!

Unfortunately, my eyesight is simply not good enough to be able to leave my setting this way.
I work 8-12 hours a day on my computer, from home, and my eyes just aren’t good enough.

I love Roon, and I’m a devout cheerleader for their company, but, it’s not the main priority, I’m afraid.
I’ve reverted my setting back to 125% and will deal with the text as is.

Not sure. :wink:

I think there’s an option to disable scaling in HiDPI mode on a per application basis in windows. It should be available in the Compatibility tab of Roon(.exe) properties. I cannot test this myself but maybe you could try it?

1 Like

Thanks u_

I’m in the compatibility settings for the Roon.exe, but, I’m not sure what I’m looking at. Would you mind navigating?

EDIT: Sorry, you just said you could not test this, sorry. Coffee hasn’t kicked in yet!:grin:

There should be an option which reads something along this line:

Disable display scaling on high DPI settings

That should get enabled and Roon restarted … I don’t know how it will turn out but it’s worth a try. You can disable it again if things get worse.

1 Like

I think that has been re-worded in Windows 10, but, I changed a few settings here and experimented a little bit.

I’m usually loathe to change anything on my computer without a full understanding of what’s going on, however, in this case, I will fully admit that I just flipped a few toggles and open/closed the program a few times:rofl:


Well, if it worked - cool! :slight_smile:

Maybe you can post a screenshot so others can try the setting easily, like @Mac_Rebant who reported about it.

Hate to say it, but I rolled a few things back, left that setting on, and it’s back to looking like crap. Need to alter each setting in isolation and find out which one is the key.

At least my issue of having multiple James Browns is finally fixed! LOL

OK, so…after a bit of experimentation, without having any clue whatsoever as to what I was doing, I have fixed this issue on my machine.

For anyone experiencing this, right-click on Roon, go to properties, and, as @anon47919701 has so helpfully mentioned, mosey on over to the “Compatibility” tab, then click on the “Change high DPI settings” button.

Once in that pop-up menu, make sure “Override high DPI scaling behavior” is checked, and you will see three options in the accompanying drop down menu. Select “System”, re-start Roon, and you should be good to go!

Please do let me know if this works for anyone else who is experiencing this issue, and huge thanks to @anon47919701 for pointing me in the right direction.



This resolved it for me, thank you.

I have a 4K monitor scaled to 175% (resolution is 3840 x 2160.

Sorry, I didn’t realize an admin made my comment from the feedback thread it’s own support post. After seeing Joe’s solution and following the instructions I’m happy to say this worked! Although all of the text in Roon now seems a tiny bit fuzzy. Better than cut off text though. Thanks for your hard work @Joe_Strain! And @anon47919701!

For those that ran into this problem, can you tell me more about the computers that exhibited these text rendering issues? I’d be most interested in: OS version, GPU manufacturer/model/driver version, screen resolution, and the specific scaling settings that caused this issue. It looks like some of you are using the scaling settings in Windows’ accessibility control panel. Do you have the same problems if you use scaling via the display settings control panel?

We fixed a very similar problem related to UI scaling in this release that was affecting iOS and Android devices. It’s possible that our fix inadvertently exposed a similar issue in Windows due to some subtle differences between how those platforms treat these settings (and Roon’s interactions with the GPU).

Hi, @allan, sure thing. Windows 10 pro 64-bit, Nvidia 860m Gpu, driver ver. 417.22 16Gb RAM.
No accessibility setting altered, to my knowledge. Main Win 10 Settings->System->Display->Scale and Layout set to 125% because of my eyesight. That has always been the case, and Roon did not exhibit this “cut-off text” behavior until the most recent update.

Resolution for said issue was stumbled upon, as described above, by changing a setting in the compatibility tab of the properties for the roon.exe, not the accessibility options.

Hope this helps. please advise if you need further information.

@Joe_Strain, what is your display/monitor resolution? Also, does this issue persist if you install the most recent Nvidia drivers? At this time, I think 425.31 is the most recent WHQL release.

@allan, my display monitor resolution is 1080p, however, I’m afraid someone else will have to pick up the baton from here in terms of updated drivers, as my thinking is a bit old-school in that regard. I find, from years of computer repairs, that updating graphics drivers can often be more trouble than it’s worth unless there’s a specific need (ie enhancements for a newer game). I take an “if it ain’t broke…” approach here.

Hi @allan,

The work around in post 15 worked for me also. A Windows 10 laptop set to the recommended settings of 125% scaling and 1920x1080. I find the laptop essentially unusable at any other setting. Graphics adapter is NVIDIA GeForce 940MX.


  1. The roon screens and text are now somehow less sharp, more fuzzy.

  2. I don’t know if this connection is being drawn by others but now my search problem that many have been reporting is much reduced. Screens are drawn much more quickly and everything seems much snappier again as it was before 1.6. Is it possible that the search and general slowness that many have been reporting is just slowness due to screen drawing?