Tidal MQA stuttering

Roon Core on QNAP NAS, SqueezeBox Touch endpoint with EDO mod to support 24/192, USB from SBT to PS Audio DS Sr. All of my library tracks play fine, as does Tidal CD quality.

Attempting to play Tidal MQA I get the same small pause for initial buffering as I get for CD quality, then it goes into stuttering hell as if it’s constantly hitting empty buffers. It does exactly the same thing with Tidal MQA 24/44.1 as with Tidal MQA 24/96. When I try to pause the stuttering playback I have to wait through more stuttering until the amount of audio actually played catches up to what would have been played if it hadn’t been stuttering.

My internet connection is pretty slow but should be fast enough for this. I have two load-balanced ~5Mbit DSL links.

Any suggestions for figuring out precisely why this is happening? What is the actual streaming data rate for Tidal MQA?

Hey @dvorak@support will be able to take a look at this for you.

Can you post a screenshot of your Signal Path when you’re having this issue? That will help us understand what’s going on here. Thanks!

A post was split to a new topic: Meridian devices issues when identified, ASIO working

I just double-checked my Internet speeds so you have something specific to go on. Both my modems show a DSL sync rate a little over 4500Kbps. I did a speedtest.net run in my browser and got over 3Mbps down (which would be obtained through just one of my load-balanced connections).

Playing Tidal CD quality FLAC works perfectly:

This Tidal 44.1kHz MQA starts stuttering from just 5 secs in:

I know my bandwidth is marginal and I could get local congestion at times, but even when I’m the only person home and no devices are doing anything else MQA just never works. With 3Mbps usable bandwidth per modem I feel like it should. Thanks for looking into it.

@support just want to make sure you saw that I’d followed up with screenshots as requested.

Hello @dvorak,

Yes, we’ve received your screenshots and have been investigating what could be causing this issue to occur given your playback setup.The tech team has requested a few more bits of information that would help them diagnose what’s going on here

  1. What are the specs of your Roon Core machine?
  2. Does MQA playback to a zone connected directly to the Core behave differently than the Squeezebox streaming?
  3. Can you confirm that when turning “Enable MQA Core Decoder” off in Device Setup for the Squeezebox zone that performance returns to how it was before the update?


Thanks John.

1: QNAP TVS-471, 3.5GHz i3-4150 CPU, 16GB RAM, 4x Western Digital 6TB Red NAS (WD60EFRX). CPU load is sub-10% even while decoding TIDAL MQA streams.

2: I don’t have any zones directly connected to the NAS. I can play 24/192 through the SqueezeBox on ethernet, and DXD successfully over Wi-Fi through my iPad to my DAC. When I play TIDAL MQA using my Mac or iPad or iPhone as Roon endpoints I get the error about “Tidal media is loading slowly” and then it skips to the next track rather than continue stuttering.

3: I tried turning off “Enable MQA Core Decoder”, changing the MQA device capabilities, turned off FLAC encoding… none of them make any reliable difference to the result, though today I am sometimes seeing a track play for up to 30 secs before it starts stuttering. It feels like I’m right on the borderline for minimum usable bandwidth for Roon’s current TIDAL implementation.

This stuttering is not a new thing in Roon 1.5 with MQA decoding. I’ve never been able to reliably stream MQA-encoded TIDAL content through Roon. I just never cared much before because I didn’t have an MQA decoder – now with Roon 1.5 I’d like to hear what that can do for me.

Please note that using the TIDAL desktop app on my Mac I can stream all their MQA content no problem (shows “MASTER” in the playback info). Using network monitoring tools on the Mac I see the TIDAL app open up a connection to a HTTP server and suck down the track data at around 440KiB per second – that’s as fast as my DSL link can support. TIDAL starts playing immediately and keeps downloading at full speed until the whole track is buffered. Something’s different about Roon, it seems.

Hello @dvorak,

I’m sorry to hear about the troubles you’re having with streaming MQA content in Roon. Let me explain some of the technical details of the situation and provide some tips that may improve the experience for you.

While I’m unsure of how Tidal handles their buffering, I can give you some further insight into how the Roon application handles Tidal streaming. The second you click play on a track from Tidal in Roon, Roon will attempt to buffer the track in its entirety as quickly as Tidal’s servers will upload to your computer, and if it’s able to buffer the entire track we will attempt to buffer the next track as well. While MQA content is smaller in size and thus requires less bandwidth than regular 24/96 high resolution content, it’s still not quite as compact as CD quality streaming, because of the increase in the bit depth from 16 bits to 24 bits.

If you’re interested in further troubleshooting, I’d recommend running your Roon Core instance on your Mac temporarily to see if you’re able to successfully stream in that case. Looking at the specs of your QNAP, I don’t see a solid state drive listed to use as your database and cache mount. This can impact the performance of Roon since it is designed to be run with it’s database on a solid state drive. Also, the NAS based Roon Server instances depending on the device may subject to permissions and caching limitations that are not present using the regular Mac/Windows/Linux installers.

We have had a few customers with Tidal streaming issues report success by changing their DNS servers to either a “” address (CloudFlare DNS) or (Google Public DNS).


Hi John

So I have finally managed to do the experiment you asked: running a Roon Core on a Mac to see if there’s an issue with the NAS’s computational performance. This machine is a quad-core 3.5GHz i7 iMac with 16GB RAM and a Fusion drive (so SSD performance for the recently-used data), and connected via ethernet.

I signed up for a new Roon trial just for this. Installed as a new Core, linked to Tidal. I get exactly the same problem I’ve been reporting earlier: Roon can stream non-MQA masters from Tidal no problem but stutters and skips with MQA content.

On this same machine I also installed Tidal itself and had no problem streaming the same MQA files which were stuttering in Roon.

I then installed a trial of Audirvana+ and linked it to my Tidal account and played the same MQA tracks. Again: no problem.

Note in the screenshot that Audirvana helpfully shows the status of its pre-buffering. My Internet connection is well sufficient to stream MQA but it offers less than 2x the necessary bandwidth. I have a feeling that Roon’s buffering algorithm tries to download two things (different segments of the track, or two copies of the track, or this track and the next track?) at the same time… which would mean that suddenly there’s not enough bandwidth to sustain the part that I actually want to play now.

Could you check with your dev team about that hypothesis please?


Hello @dvorak,

We’re going to discuss this with our dev team and see what might be happening with our buffer here. In the meantime, can you confirm whether this happens streaming to other outputs (like local output on your laptop connected over ethernet) – that will help us confirm this is related to upstream bandwidth and not something in your network or related to Squeezebox?


The inability of Roon to stream Tidal MQA on my network is totally consistent regardless of whether I’m outputting to Squeezebox Touch, direct to DAC over USB, to an iPad or iPhone as an endpoint, or using the iMac’s built-in speakers.

Just in case anybody’s still inclined to wonder if my local network is contributing to the problem…

The playback of local files from Roon on my NAS work perfectly at all times, with Roon’s own UI confirming bit-perfect transport through the steps along the way. My DirectStream DAC shows incoming sample rate and bit depth, so I can confirm what’s happening at the final step of the transport chain. I have zero problems with high bandwidth local transport:

  1. 1x DoP and 24/192 PCM via Ethernet to SqueezeBox Touch (USB to DAC)
  2. DXD (32-bit 352.8kHz PCM) via Wi-Fi to Roon iPad endpoint (USB to DAC)

I have the much the same hardware and exactly the same issue. Everything is roses until I try to listen to MQA via Roon - and each of my endpoints is connected via ethernet. If I want to listen to MQA now, I use Tidal desktop app and usb to whichever dac I’m using. Thanks for bringing this up and following through on it - I’ll be watching to see the outcome!

How fast is your internet connection, Mark? As per speedtest.net etc

Just tested from my iPhone at 94.5 mbps. Usually faster when I test from my computer.

I found a thread in PS Audio site suggesting that the DSD and DSD Jr settings in Roon need be be on docoder only. That does seem to have helped.

With your internet speed I think it’s very unlikely you’re having the same problem I’m having. If you play Tidal MQA using Roon on a computer’s built in speakers, or on your iPhone’s built in speaker, does it play reliably without stuttering?

I imagine your answer will be “yes”, whereas for me that doesn’t work either. It’s got nothing to do with the NAS or the DAC in my case because it’s still a problem when I take both of them out of the picture.

Hello @dvorak,

I just wanted to chime in and let you know we’re still working on this. Obviously, Tidal buffering strategies are something that effects a large portion of our user base, so any changes need to be very carefully considered. I will be sure to let you know when I have further information to share on the behavior here.


1 Like

Have you been able to determine whether my hypothesis is on the right track? Is your code trying to download two things at once?

I believe that this is plenty fast enough and I also believe that it is not internet speed that is the problem. I have a 400MB download speed and this also happens to me with MQA and HiFi.

The only way I can get Tidal to work though is to have no type of activity on my network going on at all. That means that no one is surfing on their phone or tablet. No streaming of Netflix, Hulu or You Tube. No network backups of any devices or PCs. Nothing.

The moment any of these activities start, then Tidal will studder in Roon and will not function. Tried the DNS settings. This seems to help a little but in the end will not work.

Roon will always work with local files and the Tidal Desktop app will always work, just not through Roon.