Tidal - Too Many Failures, Stopping Playback! Help Please!

Roon Core Machine

Roon 1.8 Legacy Software
MacPro 12 Core (Mid 2010) with 1TB SSD + 128Gb RAM and RX580 8G Graphics Card
macOS Mojave.
I’m unable to upgrade to a higher OS.

Networking Gear & Setup Details

1,000MB FTTH (Fibre to the Home) Broadband with 100MB Download.
Ethernet using the attached DNS settings.

Connected Audio Devices

I have three Bluesound devices…

  1. One directly attached to my MacPro (using an optical connection) is a Bluesound Node 2i and onto that I have a pair of Audio Engine A5+ speakers.
  2. Also in my office is a Bluesound PowerNode 2i, with an ethernet connection connected to a pair of B&W 603 S2 Speakers.
  3. In my livingroon is new Bluesound Powernode also connected via the ethernet port connected to a pair of B&W 603 S2 40th Anniversary Speakers.

Number of Tracks in Library

59,843 in TIDAL.

Description of Issue

I’ve been using Roon now for a good few years… I have had this issue raise it’s head from time to time… but now it’s every day it happens.

I have logged out and logged back in again, no change.
If I play the same music using the native TIDAL app, no issues… same with the BlueOS app.

Another things that happens often now is also if I want to play a tracks from an album… it will try and play the first and then keep skipping until it finds one it can play. I have to manually keep telling it to play my specific track from where I want it to play and sometimes that works… other times I have to attempt this manual override multiple times. All very strange and very frustrating.

The issue seems to be with my Roon app only.

Any help or assistance please…?


I have done a hard reset, back to factory settings on my router and so far there seems to be an improvement in performance… but I will keep an eye on this… as those TIDAL errors do happy from time to time… but they just became far more regular over the past week or so.


Same thing just started happening again… was working great… and now I tried to play the first track off a new album I wanted to listen to and it skipped about 4 tracks and brought up those TIDAL playback error messages all over again… sooo annoying… that’s my ISP router 100% rebooted, factory reset… what more can be done… my router and my MacPro are about 6ft away and connected via 1GB Ethernet with 1,000MB Speeds. This is crazy.

I don’t have a solution but I’m wondering if this is related to the issue many of us have been having since early December where Qobuz and Tidal are no longer gapless and/or there are long delays between tracks?
It seems to be more of an issue with Qobuz but I’ve seen it reported on Tidal too.
Roon have acknowledged this and are working on a fix.

Are you using any DSP?
I used to run my core on a Mojave limited Mac and although my processing speeds seemed high enough (roughly 2X) I would sometimes get the issue you are describing. It didn’t happen with DSP off.

I’ve also seen users resolve this issue by disabling ipV6.
I don’t know much about networking but I think I’m seeing ipV6 addresses in your DNS?

1 Like

Hey Jeff… first off… thank you sooo much for taking time out of your busy day to send me your detailed reply. I wasn’t aware that TIDAL wasn’t gapless anymore… are you sure of that… as I’m a big dance music fan and I have been playing some continuous mix albums recently and it all played seamlessly and gapless… no issues… playing tracks on ROON using TIDAL for me has always had a slight lag, probably as I have three Bluesound devices (QTY 2 x Powernodes + QTY 1 x Node 2i) in my ROON Audio Zone setup… but this recent issue results in trying to play track one of a new album I want to listen to… and it will start to skip to the next and next track and bring up TIDAL playback errors and claiming network issues… yet I have 1000MB Broadband and all devices are attached using ethernet. Plus, if I go back to the native TIDAL app for macOS it’s plays the album tracks from the start without any issues.

I don’t, and never have had DSP applied to my Audio Zone setup. See screenshot attached.

I’m wondering can someone from ROON Support chime in on this issue and review some Roon App log files to see what’s exactly going on. I have been having other software bug issues before Xmas also… so all this is RUINING my ROON listening experience if you pardon the pun… lol

Thanks again Jeff for your input :slight_smile:


1 Like

This issue is pretty now non stop… with everything I try and play. Same album, same tracks play instantly on the native TIDAL app.

HELP PLAESE!! :slight_smile:

I have done my Router hard reset, all my Wifi Extenders hard reset, rebooted all my Bluesound devices using the Diagnostics feature in the BluOS app. I have logged out and back in again many times before… but not since all this hard resetting and rebooting of devices… I have logged out and logged back in again and the first new album I selected played… let’s see if it stays that way. I have my doubts… :frowning:

Same thing happening all over again… just swapped over to a new album… and skipping track after track after track… it just won’t play from where I select or what I select. Completely useless software now… please assist… I love ROON and this is just so frustrating.


Sorry Anthony, I should have been more clear about gapless playback: Some users (including me) have been experiencing loss of gapless playback when using Roon.
For those affected Qobuz and Tidal are still gapless when using other apps.
I realize you have a different issue but as it’s turned up around the same time I was just wondering if perhaps it’s related?

I had your issue at times when I was using DSP
but that’s not the case here.

Someone from support will chime in soon.
They’ve been busier than usual lately so it might take a few days.

“Ruining Roon” - Nice one

1 Like

“Ruining Roon” - Nice one lol… had to get that in for sure… :slight_smile:

Thanks again for all your help and assistance.


1 Like

Hi @Anthony_McCarthy

Can you please give us some more details about your local network?
It doesn’t matter so much how much data is coming in through your ISP from the outside.
Much more decisive is how much throughput your local network can achieve, while your 1000MB Download internet is the underlying technology that enables its connectivity.
So, how is your core machine connected?
If not hardwired to the router or an unmanaged switch via ethernet cable, but via cable with a wifi extender, that could explain the problems. Hardwired to a wifi extender or access point is still wifi.
Another option, have you tested your cables, could it be that one of them is broken?


Hello Axel and thank you for coming to the rescue of my call for help. Remember… all was working perfectly before with the exact same setup. Nothing has changed.

My MacPro is connected directly to the internet via Ethernet to the back of my broadband providers Router. It’s a MacPro from 2010 and it support Gigabit Ethernet. Extenders are elsewhere in my house and they join the main router via Wifi, but I have one of my Bluesound devices connected to one of them via Ethernet also. My two other Bluesound devices are also Ethernet connected… the Node 2i which is the main device in my Audio Zone is directly attached via Ethernet to the main Router in my office. My other Office PowerNode 2i is also Ethernet connected via a TP Link Powerline Adapter. Again, my setup has been the same for over three years, this is all a recent issue of the past few weeks. I have had out of sync playing issues in the past with ROON… but never this continuous Failures to Playback errors.

I have three Bluesound devices in my Roon Audio Zone:

  1. Bluesound Node 2i (Directly connected to the main router via Ethernet) in my Office
  2. Bluesound PowerNode 2i (Directly connected to the TP Link PowerLine Adpater via Ethernet), also located in my Office.
  3. Bluesound POWERNODE (Directly connected to the TP WiFi 6 Extender via Ethernet), located in my Livingroom.

Just to clarify… I have a 1,000MB (FTTH) Connection, not 100MB.

I also have other network setups, like AppleTV 4Ks in multiple rooms… all work and perform fine using the existing network setup.

Playing TIDAL on on my TV using my AppleTV is perfect and I have a surround sound setup for that used wifi connected speakers… no issues. When none of these are on… the issues remain with my ROON setup. All music on my MacPro plays effortlessly when using their native Spotify and TIDAL apps. ROOn is the only app not working… but it did before. All soooo strange.

Is there any log file or diagnostics file that can be exported from my ROON app so you can analyze what’s going on… ? to get to the route of it… if you pardon the pun…?

Let me know if you require any additional info.


Can you try how it works if you enable in Roon audio settings “default output” for your MacPro core and playback through it?

1 Like

What is the wi fi doing , clearly 1000 Mbs isn’t the issue, I run Tidal and Netflix 4K quite happily on 20 Mbs , which measures more like 13 Mbs

Am I right , the primary connection FROM the core to the primary router is WiFi ? If so that could well be the issue. Roon specifically recommends Ethernet for this connection

Skipping and stuttering says WiFi but you seem to be Ethernet .

I assume you have 2 Routers , one from the ISP then your own local one ?

Are your devices connected Ethernet to the second router

I am just listening your sample album “ And in the Darkness …” from Tidal , I am getting no skips etc

My system is 2 routers BUT everything is Ethernet , is there any way to run Core to Router in Ethernet even just to test ?

1 Like

Hi Mike… sorry… I’m poor at explaining myself clearly… apologies… my Roon 1.8 Legacy software runs on my MacPro which is directly connected to my router using an Ethernet Connection… and on my MacPro, if I do a speed test I get 930-940MB download, 96MB Upload.

From my MacPro… I have one Bluesound Node 2i connected to my MacPro via Optical and that Bluesound Node 2i is also connected directly to my main router using Ethernet. I then have two other Bluesound Powernode’s connected all with Ethernet but via a PowerLine Extender and Wifi Extender. All three Bluesound devices form my main Audio Zone on ROON.

I hope that sounds a little clearer.

Maybe the Powerline adapters are the issue. I have installed those things for someone before and nothing but trouble

1 Like

Hey @Anthony_McCarthy
Not a Mac user, so I’m not familiar with different MacOS and the requirements for Roon.
But I still remember that Roon 2.0 brought about a change in the minimum hardware requirements. I checked and I’ll link it here so you can see for yourself whether your machine still meets the requirements.

Hi Axcel… I’m not running ROON 2.0, I’m running ROON 1.8 which I think I mentioned in my original post, and that has been running fine for months and months, these playback issues are something brand new, about 1-2 weeks old tops. Thank you again for your input.


Has anything changed in your system , any network changes , massive increase in albums.

If its been fine previously something has changed . 1.8 Legacy hasn’t changed much from 1.8 ,

PowerLine extenders have had a few issues with Roon but I don’t recall anything specific

One of your systems seems all Ethernet other than WiFi for control apps am I right ? If so does that have the same issues, that would tend to single out the WiFi , if it still has issues then it eliminates the WiFi

PS does your core have an SSD for the OS & Roon db ?

My apologies. I overlooked it.

I understand your frustration.
However, it would help if you could try how it works if you enable in Roon audio settings “default output” for your MacPro core and playback through it.
If that works, then at least you know that it’s not database corruption and can proceed from there to the Bluesound devices.
If it doesn’t work, do you have a backup available?