Titles Skipping constantly [resolved - deselected the Package Accelerator in Fritz Box]

Hi @wklie,
Offical contract (vodafone) is about 1000Mbit/s download and 50Mbit/s upload.
vodafone speedtest (almost) always comes up with >1100Mbit/s Vodafone server to Router (Fritzbox 6591 cable); speedtest at the PC shows figures between 10 and 980; protocolls ping -t 8.8.8.8 are usually fine with no lost packages and ping times of about 7-30ms, exceptions up to 150 (very few during an 10h day).ookla speedtest usually states >120Mbit/s at the PC

I would say not at all.

And the frustrating thing is Router new, 1Gbit/s, Internet 1Gbit/s, Motherboard MSI B550 Mortar with 2,5Gbit/s Realtek controler, all drivers updated (except CPU driver which is from Mid March 21) - maybe I update this one first.
I deaktivated some backround processes under Win 10 but I still have these issues sometimes.
Yesterday and the day before was awesome but today it sucks and is horrible again :cry:.
Thanks.

These are massive bandwidths, mine is a nominal 20 Mbs it mostly measures 13_15 measured

I am connected Ethernet to the switch and streamer and never get a blip

Something else must be wrong , music shouldn’t need this bandwidth.

I get perfect Netflix too on this connection

Do you have another PC / laptop / NAS that you can move the Roon Core to, at least temporarily?

Also try adding another network switch in between the Fritzbox and the Roon Core, and connect your endpoints to the switch.

Hi @wklie, @Mike_O_Neill,
okay I made the BIOS-Update MSI B550 Motar MB 7c94v163 beta to 7c94v16
and I made LAN Driver Update from 1.0.0.62 to 1.0.0.64 for this motherboard.

It all seems like minor changes.

Windows 2,5 PCIe Family Controller Driver remains still the same.
Windows by the way always says everything is fine.

I’ve no clue what that means but at the MOMENT everything runs like hell (fast).

Speedtest WITH a running and playing roon always above 900Mbit/s between Router and PC/Roon core.

But maybe it’s just because of the sun, humidity, great temperature, smile in my face,… :smiley:

And yes, I know in general also the bad bandwiths are also not that bad but that’s the only relationship I can see.
Thanks for your support :+1: :+1: :+1:

Okay, talking about the devil - just got another skip (ran speed test shortly after with 1035 and 1007Mbit/s). Meassage “Tidal slow…”
:cry: :cry:

Set router DNS to 8.8.8.8

Contrary to popular belief, your internet bandwidth is not the cause of Tidal being slow in your area with your ISP.

I also have some worries about your on-board network adapter, that’s why I suggested moving the Roon Core elsewhere temporarily.

???

What shall I do? Do you have an explanation?

I meant in the Fritz box. Alternatively, this should be easier: set manual DNS to 8.8.8.8 in your Windows running Roon Core.

Guys, I did deselect the Package Accelerator in the Fritz Box and can confirm: the issue of skipping titles is gone.
But: As a result, the general Speed has decreased substantially: from 55Mbit/s to 12Mbit/s. Any comment on this?

(For the record, where to find this option in the Fritz Box: in the lower left corner click “extend / erweitert”, then “content / Inhalt” then FritzBox Support in the lower left corner. Then scroll down, there are all the options you need: Deselect Hardware, Layer 2 and Package, Activate and don’t restart your Box, otherwise all is back on again.)

Hi @Ole_Johannsen1,
I created a support ticket at the AVM Fritzbox and got the feedback from them that it only works in that sequence to deaktivate the Paket Acceleration.
If you reboot or restart the router it’s back and aktivated.
In example the Fritzbox 6591 cable with 7.21 FritzOS.

I would not use it. In fact if you search Roon forum about this brand, you’ll find multiple unresolved threads with it.

Anyway, if you find that a different network topology works, then just use that. Mostly I think the key point is to avoid direct connecting your Roon Core and Roon endpoints to the router. Only connect them to something else, which in turn connects to the router. This way, at least local music playback does not have to go through the router, which screws up the network timing by default.

Sorry, but are you warning people away from using AVM (Fritz!Box) products? My personal datapoint would be to say I have had positive experience with their products for many years spanning two ISPs who use their routers. Currently I use a Fritz!Box router with their Mesh products, and my network (including VOIP and IPTV) is solid.

got a Support reply from AVM and it worked for me: Update the Fritz Box to 7.26.
So no need to extract support data for AVM to dive into at this point.

The Package Accelerator is active, just as the Hardware Acceleration. Only Layer 2 is off.
Speed is back to normal with 50Mbit/s.
Will report, if things stay like this in a few days.

I assume the ability to turn this off comes with the firmware 7.26. What is this setting called? Or upgrading to this firmware automatically turns this non-configurable feature off?

The feature is off after the Update. The other two are active (Package and Hardware).

Please consider my statement to be retracted when the router firmware upgrade is proven to fix the issue in Roon playback without severely degrading expected routing throughput.

Hi @Ole_Johannsen1,
have you tried a restart? Is the Layer 2 Acceleration active still switched off afterwards?

For cable customers is no FritzOS 7.26 available so far - maybe only if you bought your own router.
There are 3 options in this area.
Main point is "Packet Acceleration " with two sub options “Layer 2” and “Hardware Acceleration”.
Deactivating Layer 2 makes no difference in the speed.
Deactivating Packet Acceleration and Hardware Acceleration makes no sence because the speed drops from 940Mbps to 10Mbps. Restart is not possible without reset and back to all options are activ.
At least AVM statet nothing about changing that issue. I’ll see what happens.
16:26 o’clock skipping happens again several times at my system (Imelda May, 11 Past the hour, MQA96 Quality).

Have Layer 2 switched off, no differences.
Severin skipps - startet at 16:30 o’clock. More or less almost no skipps before.
Internet speed live hell. Tidal speed???

I think that you two are having different problems. The crucial difference is that you don’t have local file playback problem. Ole has. So what worked for him does not apply to your case, unfortunately.

Hi @wklie, @Ole_Johannsen1
I got the feedback from AVM Fritzbox Support (29.04.21) that deactivating of all of these options (Packet Acceleration or sub options Layer-2 or Hardware Acceleration) is only for the used session!!
This is valid for Fritz OS 7.21 AND 7.26! Everything is back activated after a restart. AVM maybe want to take that in consideration for further Updates!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.