Tracks being skipped through during playback (ROCK)


After a certain period of time, 12 hours, 24, maybe more maybe less, when I start to play an album in Roon, it acts as if play is about to begin, but the counter and the music never starts. After 10-20 seconds it skips to the next track. If only playing one track it just stops. This occurs with both local music and music streamed from Tidal. Rebooting the core or the endpoint solves the issue temporarily. This issue started with the latest update. All software is up to date.

Roon core on ROCK, an NUC i5 (internal music storage) connected via Ethernet to a FiOS Quantum router. Endpoint is a RPi3 over WiFi (usb, not onboard), with an Allo DigiOne.

@Eric @support

Hi @fritzg ----- Thanks for touching base with me and providing the requested feedback. Very appreciated!

Moving forward, I have went ahead and moved your posts over to their own thread so we can address this behavior with you directly. During your troubleshooting of this behavior have you at any point been able to test with a audio device mounted directly to the NUC hosting ROCK? If so was the same observation(s) made?


I haven’t tried attaching an audio system to ROCK directly. I thought one of the main points of ROON and ROCK was to keep the server in another room.

Hi @fritzg ---- Yes, you are indeed correct. However, the thought process behind my question is merely to try to isolate some variables to see if any adjustments yield a change in behavior. Based on the results we can begin to pinpoint and advise where the issue may be coming from.


Ok. This is the first thing you want me to try? You want me to usb from ROCK directly to my DAC? If I do that it will wither be with a dragonfly or it will entail using a coax for ROCK to be on the network.

Ok. I have attached a DragonFly Black directly to ROCK. When this happens again, I will switch to the DragonFly and see if it continues. Do you want me to grab logs the next time it happens? If so, I need to know the current procedure.

@Eric @support

This just happened again. I was able to transfer to the zone directly connected to ROCK. When transferring back, the problem remained.

@fritzg — Thank you for the follow up. I greatly appreciate you giving the proposed test a go for me.

Moving forward, just to make sure I am understanding your latest post(s) correctly. You setup a test “zone” mounted directly to your NUC (DragonFly Black). When you noticed the issue occurring on your “main setup” you paused playback and transferred over to the “test” zone and the issue continued to occur, correct?

Furthermore, in light of your observations I have went ahead and enabled some diagnostics on your account so we can try to get a better sense as to what could be causing this behavior on your setup. What this action will do is generate/upload a diagnostics report directly to our servers which will contain a fresh set of Roon logs. Once the mentioned report has been received I will confirm that it has been downloaded and will pass over to our techs ASAP for analysis.


No. When I transferred to the zone on the core, tracks played. When I went back to the Main setup described above, the problem persisted. @Eric

@eric Also, I can reproduce this at will right now, so let me know when you would like me to do so.

@eric Another data point. I set up an AirPlay zone on the same Allo DigiOne, and it works. It is only the RoonBridge implementation that fails.

Again, this is all since the recent update.

Hi @fritzg ----- Thank you for touching base and clarifying that bit of information for me, my apologies for the confusion.

As mentioned in my previous, I have enabled diagnostics on your account. When your core machine comes online next this action will generate/upload a diagnostics report directly to our servers which will contain a fresh set of Roon logs.

Furthermore, by chance during your troubleshooting of this behavior, have you tried reinstalling RoonBridge on the mentioned RPi3 with the Allo DigiOne?


My core machine is never offline. Should I reboot it again?

No, I haven’t tried reinstalling RoonBridge. I can give that a go. @Eric

Hi @fritzg ---- No need to reboot if it is currently online :wink:


@Eric @support It just now happened at 7:52 p.m. 12/6. Restarting RoonBridge, which has been reinstalled.

Hey @fritzg – we discussed this yesterday but Eric was out today so I wanted to follow up quickly.

Just to be clear, it’s always like this:

Meaning, it never skips ahead immediately, or after just a few seconds – it’s always roughly a full 10-20 seconds per skipped track?

Also, just to give you a little more information, this can indicate an audio problem or a storage problem. It looks like you’ve already confirmed that when this is happening, other zones are working fine, which would lead me to think this is related to the audio device. And it looks like you’re already using internal storage, so I’m guessing this isn’t a storage problem (which usually occurs with a NAS).

Just to completely rule out storage, is there any way you can copy a few files to a USB flash drive, connect it to ROCK and watch it in Roon, and confirm this still happens the next time you experience this issue? That will help us hone in on the audio device, and we can do some additional testing on the DigiOne in that case.

Appreciate your patience here @fritzg!

@mike @eric To be clear, when this occurs (it has been about 36 hours now since the last issue) Roon acts like it is playing, but the play bar never move past 0:00, stays like this for 10-20 seconds, then skips to the next track and does the same thing. Restarting RoonBridge on the Pi/DigiOne corrects this. Music will play if I switch to an airplay zone on the same Pi/DigiOne and will play if I switch to the dragonfly directly connected to ROCK.

@mike @eric Are you asking me to put music on a flash drive and add it to ROCK? Will ROCK automatically recognize the flash drive?

ROCK should recognize the Flash Drive as a Drive. You would then need to go into Roon and add it as a storage location.

Same thing going on with my new Vita server every so often–