Tracks "play" in 1-2 seconds?

Hi there,

I’m new to Roon so I apologize in advance if this is a newbish question. I’ve set up Roon and have added my library and Tidal accounts, but Roon seems to play through each track in 1-2 seconds with no audio output. I found a thread that said the fix was to turn on Exclusive Mode for the device they were using, but I tried that to no avail.

I’m running Roon on a Windows 10 machine and audio devices are USB out to a pair of Klipsch R-15PM’s, as well as USB out to a FIIO E10K headphone amp. I’ve also tried the optical out to the Klipsches with the same results.

It also does the same thing whether I select local content or Tidal content.

Edit: Forgot to add, that after changing all devices to Exclusive mode I got a notice saying the device didn’t appear to support any stereo playback formats. Tried the “workaround driver” thing and still have that big red notice. I presume this is the problem, but I’m not sure how to fix it. The devices all work fine with Tidal and other audio players.

Hi, have you loaded drivers to your W10 machine?

Hi @Jason_Puckett ---- Thank you for the feedback and my apologies for the troubles here. Based on the symptoms you’re reporting to us it sounds like you might be getting audio dropouts. Our knowledge base contains good information on how to approaching troubleshooting audio dropouts and what can be causing them. May I kindly ask you to give the article a read and let me know what you have tried thus far?

Moving forward to help me better evaluate this issue, can you please provide me with the following:

  1. An expanded description of your current setup as seen here.

  2. Please describe your network configuration/topology as well as providing insight into any networking hardware you may be implementing. I want to have complete understanding of how your devices are communicating and what tools you’re using to make those connections.


Thanks for the replies, guys.

Henry, I have drivers for the audio devices, yes. As I mentioned they work fine with other playback software, including the Tidal desktop app.

Eric, I don’t think it’s audio drop outs as I never get audio. It’s a Windows 10 machine with an i5 3550 (or 3350), 16gb of RAM, 120gb Samsung SSD. Music is stored on a second drive, which is a platter drive 500gb, I think. (it performs the same with “streaming” music from Tidal though so doubt local storage is an issue). Network topology is onboard ethernet from my mobo (Asus P8Z77) to Comcast’s Arris MTA. Don’t have the exact model # of the Arris, but I can get it for you when I get home from work tonight if needed.

Hi @Jason_Puckett ---- Thank you for the follow up and taking the time to answer my questions. Both are appreciated!

Just to confirm the only networking devices you are using is the Arris device and that is connected directly to the Asus P8Z77 motherboard, correct? Having the exact model of the Arris device would be great, thanks!

Furthermore, if you play directly out of the internal speakers of the Win10 machine do you notice the same skipping behavior? How about through the TIDAL application?


Hi @Eric,

You’re welcome, thank you for helping me! You are correct, those are the only networking devices involved. I remembered that the Xfinity app has the device info in it, so the model number is TC8305C.

In regards to the internal speakers, the only internal speakers would be the mobo speaker and unless the “System” option in Roon is referring to that speaker, I’m not sure how to accomplish that. I was operating under the assumption that the “System” option was the default device set in Windows playback devices.

To clarify, the problem isn’t really dropouts, I never get audio from Roon. If I choose an album and tell it to play, the track names of the album flit across on the now playing bar, each song takes a second or two, and the whole album “finishes” in about 10 seconds. There is never any audio output.

Both the headphone amp and the Klipsch (via optical and USB) play back just fine using the Tidal application, foobar, games, browser, etc.

Hi @Jason_Puckett ----- Thank you for the follow up! I would kindly like to ask you to please try using the “system output” option in Roon to see if the behavior is the same.

Furthermore, if you have any active firewalls or antivirus applications currently running on this WIn10 device, could you please temporarily disable them and try playing back some content in Roon.

I would start with the “system output” first :sunglasses:


Hi @Eric, I have used the System output and it does behave the same. I was under the apparently mistaken impression that that just meant whatever the system default was set to. I did have Avira running, so will disable it and report back, but would that prevent the playback of locally stored songs?

I presume you have but just in case - have you power cycled the Win 10 machine?


I have, I came across a thread describing a similar issue with a Mac and they said it was fixed when they rebooted, so I tried it to no avail.

I did a short video showing the problem I’m having. It can be viewed here

Note there is no audio in the video, but I promise there was no audio playback either. Also, Avira was disabled during this test. The first album was a local file, then I played a Tidal playlist to show that the same thing happens with local and streamed music. As you can see at the bottom of the screen, each track only shows for 1-2 seconds and the local album “plays” through so fast I don’t even have time to get down to that area to bring attention to it with the mouse cursor. After changing the output to “System” I played a single track on repeat so you can see that it seems to play that song over and over again but each time for only a split second.

I went through the Audio Dropout troubleshooting, and none of that seems to help. I tried limiting Roon audio playback down to 96kHz, which is the highest Windows says the speakers are capable of via USB and got the same results. The headphone amp tests fine up to 192kHz in Windows, so I tried it with it limited to 192kHz and got the same results. I’m going to try to uninstall and reinstall Roon to see if that makes a difference and will report back once that’s done.

@Eric Any chance you’ve had a chance to look at the video and see if you have any ideas? I’m still not able to get audio playback after uninstalling and reinstalling.

@Eric or anyone else? There was another thread from someone with this same problem from yesterday, I think, and his problem was resolved by restarting his DAC’s, which I too have done multiple times and have even removed and reinstalled the headphone amp/DAC from Windows, and done a reset on the Klipsch speakers. Getting a bit frustrating. I’ll be getting a new Dragonfly DAC soon and would really like to be able to use Roon with it.

Edit: the other thread I was referring to: Cycling through songs without playing them [Resolved]

Hi @Jason_Puckett ---- Thank you for your patience and my sincere apologies for wait here.

We did indeed have a look at the video you posted (Thank you) highlighting the behavior you’re reporting us to get a sense of what is going on. Moving forward, may I very kindly ask you would like you to please try the following test:

  1. Close the application and remove any USB devices mounted to the Win10 machine.

  2. Right click on the volume icon at the bottom of the screen, select the built in sound card, making sure the “exclusive mode” boxes are checked as seen in the example below:

  1. Once reconfigured, please launch Roon and try the system output once more.