Tracks stuck in "Adding Music To Library" (due to file corruption issues) [Solved]

I am having issues with albums loading. The Files are copied for import and it says complete, but then they are not added to the library. They stay under “Adding Music to library” but are not added. If I shut down Roon and restart it will add about 100 tracks at a time.

1 Like

Hi @sandmanct, sorry to hear youre having problems here. Can you give us a little more information about your issue?

What OS are you running Roon on? Where are the files stored? What formats are your files? How exactly are you adding them to Roon?

Let us know and I’m sure we can get this fixed soon. Thanks for your patience!

Hi Mike,
I am running Windows 7 Ultimate. The files are on several external USB drives. The files are in various formats lossless WMA, MP3 and FLAC. I have tried adding it as a storage under settings and I have also tried dragging and dropping files into Roon. Besides this issue I am loving this software! I would also love to have Squeezebox support.

Hello @sandmanct, I also have several questions to ask:‘Adding music to Library’ section contains three numbers, are they all the same or not? Please, describe what do you see there.

Also, do you use Remote? Are these USB drives connected directly to your machine with Roon? Do organize/watched folders contain DRM protected files?

Among the file formats you’ve describe WMA was mentioned. Unfortunately, we aren’t supporting WMA (more details here).

Thank you in advance.

The second and third numbers "added and “identified” are the same but the first number of tracks is much higher. I am not using Remote yet. All the drives are attached via USB to the core machine. I did not choose to organize the files and they aren’t DRM protected.
Only a small percentage of the files are WMA, most are MP3. I will convert the WMA to FLAC.

About 100 or so tracks are added every time I restart Roon. Any progress on this problem?

1 Like

Hi @sandmanct – sorry to hear you’re still having issues here.

We’re going to follow up via PM to get some more information from you via PM.

I disconnected one of my USB drives and Roon started to load a lot more tracks, but it crashed in the middle of it. Now when I restarted all of the text is unreadable and looks like little blocks. Should I uninstall and reinstall?

Any word on this problem?

I installed on another PC. It hasn’t crashed yet and all the letters are legible, but my other problem is still present. I am still having issues with albums loading. The Files are copied for import and it says complete, but then they are not added to the library. They stay under “Adding Music to library” but are not added. If I shut down Roon and restart it will add a few more tracks tracks each time.

Hi @sandmanct – sorry for the delay here. The information you sent us is with our developers, and I’m going to try and get an update for you tomorrow.

Apologies again for the delay!

I am facing the exact same issue, can you please let me know how did you resolve your case?

1 Like

I found a few tracks that had errors and were causing problems with Roon and loading would stop at them. I deleted those tracks. Then it would load a few more tracks and stop. Then I cut down the number of tracks I put into Roon. Then Roon worked.

Thanks for the response…curious though, how did you find out which tracks were causing this? It is interesting that you had to lower the number of tracks in order for this problem to resolve. I would be disappointed if Roon had this issue, can’t imagine getting to a point where my library would not load in a media management tool such as Roon, it would kill it for me.

How many tracks do you have?

Hey @thijazi – I’m going to follow up via PM and get some logs from you. Usually we can figure out whether this is caused by a corrupt file, or some other issue, so stand by!

I have having this issue as well. It did not happen when i was running Roon on a laptop but has started when i disconnected/uninstalled all instances and switched to a new machine with Roon server the issue has appeared. I have ~10,800 tracks on the watched folder all files are mp3 FLAC and maybe some old itunes.

in the picture above i am stuck on Of 355 track, 355 added, 344 identified.

I am using two remotes, no USB drives connected to the machine running Roon Server, no DRM files. All files are MP3 or FLAC.

It looks like a known bug, which is already fixed for our next build. As workaround for now, try to restart the app.

Ok thanks, hopefully won’t be long.

In my attempt to fix it, I reconfigured the watched folders and roon re-imported my files, it is ok however the “date imported” order has been reset so I have all the albums showing up by alphabetic order instead of showing up by the order I imported them in the last few month…

Is there an easy way to restore the old sort order?

Hi @thijazi,

A backup of the database prior to the re-importing may preserve the old import time, but the current database will have the new import time.

You can, however, prefer file creation or modification date rather than the current import time to set import date. You do this in the Track Editor after selecting the Tracks you want affected (Ctrl-a will select all once you’ve focused on the relevant Tracks). Edit/Metadata Preference brings it up.

You can also edit in a particular import date/time for individually selected Tracks or groups of Tracks, or set a different metadata preference for those Tracks.

Thanks, that worked!