Tracks stuck in "Adding Music To Library" (due to file corruption issues) [Solved]

(Nick) #55

Thanks @vova

All looks good here.

(Edward Hartnett) #56

Looks good from my end, too.

Thanks for the quick response – especially over a holiday weekend.

Happy Thanksgiving!

(Chris Wimlett) #57

All looks good here - thanks for the rapid fix.

(Ricardo Dominguez) #58

After 2 or 3 attempts, finally the room server recognised the mounted NAS music folder. Now it looks that all the files are playable. Thanks!

(Richard Elen) #59

First-time user here, running Roon on a Mac Mini mid 2011, 16GB RAM, 2.3GHz i5, 10.10.5, 360GB of internal drive space available. Library is on an external FW800 RAID array.

Left the system ingesting overnight; today it tells me:
Of 80593 tracks, 66761 added, 66761 identified, circle is turning and it appears not to have added anything for hours.

The library is used by other playout applications (not currently running) such as LMS and MegaSeg and thus has no known faulty files: file types mainly mp3 and FLAC, no WMA, some ALAC, AAC. possibly the odd WAV or AIF. TIDAL is not configured.

How do I interrupt it safely?
How do I persuade it to ingest the rest?
How do I identify what (if anything) it is stuck on?

Thanks in advance!

(Richard Elen) #60

Well, I took the plunge and quit the application. On opening it again, it opened up fine, scanned the folder and found 13832 (additional) tracks (correct). Soon I got the spinning circle and even after waiting some time, once again we have:
Of 13832 tracks, 0 added, 0 identified.
So it’s stuck. How to I find out where and why?

–R

(vova) #61

Hello @RichardE, usually this happens when your library contains corrupted music files.I’ll contact you over PM and provide with instruction how to solve the issue. Stand by.

(Richard Elen) #62

From this now-solved issue we can garner a useful piece of information on locating corrupt files.

Even mp3 files are generally quite large. There shouldn’t be any “tiny” (ie under 10kB or so) mp3 files.

In my case, the problem with ingestion of my library was that some corrupt mp3 files were stalling the process. Probably they failed to copy from their original source and I was left with a tiny garbage file with the right name and extension.

If you are getting the ingestion process sticking, do a search for mp3 files of under 10kB in size. You can safely trash them as virtually no audio file will be that tiny.

With the help of Support I found the first two. Having determined what to look for, I found three more. Removing them allowed my library to be ingested successfully.

1 Like
(Nick) #63

Thanks for the follow up. That is really useful to note.

(Steve Miller) #64

I appear to be having the same problem (Jan 2), is there an issue with holidays?

(Steve Miller) #65

How do you scan for the small files? Mine are all .flac and there is aboutv20,000 of them.

(Junker) #66

Same problem here. Did clean clean install on fresh mac mini. Deleted my libraries and reinstalled Roon and reimported. 57k files are imported, but 0 identified. Rebooted computer and app, but still 0 identified. Using iTunes Media library and ALAC file format from Drobo 5N NAS which hasn’t given me this issue before. I should add that I was able to manually identity and album.

(Andrew Cox) #67

It looks very much like the Roon lookup server is down again. Others with the same issue are reporting in this thread.

I’ll close this thread down so we can have a central news location. I expect the server will be brought back up as soon as the holiday weekend allows.

Edit: Lookup servers are now up. Re-opening this thread for those who have file corruption issues.

1 Like
(Andrew Cox) closed #68
(Andrew Cox) opened #69
(Richard Elen) #70

I am on a Macintosh. If you have the library Finder window open you can hit Command-F to search and it will bring up a set of options at the top allowing you to add a whole bunch of criteria including file size and extension to search for.

If you’re running Windows or Linux I’m afraid I don’t know the answer off the top of my head but hopefully someone else will.

(Mike) split this topic #71

3 posts were split to a new topic: Adding Music stuck on Linux

No audio devices in core
split this topic #72

2 posts were split to a new topic: Albums not identified after Migrating Roon from the PC to the SonicTransporter

split this topic #75

A post was split to a new topic: Tracks stuck in “Adding Music To Library”

closed #76