Trouble connecting Nucleus Plus to Mark Levinson ML585

I recently purchased the Roon Nucleus + and have had NO success connecting Roon to my Mark Levinson 585 (i.e., these units are connected physically via USB to USB), but the ML is not recognizing any signal.

No I have an ml585 and connect directly by USB.
Roon settings:audio.
Should be seen as a Harman kardon USB class 2 audio device.

Or just fudge it as I do and select ml519 as device for identifying it and works perfectly :sunglasses:

1 Like

I have ordered an HDMI to USB - A to connect from the Nucleus+ to the ML585. Hopefully, that will render a recognizable device. USB A to USB A renders nothing.

Hi Ace,
What OS is your Roon Core running on, I’m wondering if this is related to ML585 requiring custom drivers?

1 Like

My core is an Antipodes Edge on latest build .
So it is a Linux based OS.
I was not aware the ML585 required anything special in the way of drivers?
Only for Windows I think.

The Nucleus like my Antipodes should just work without anything else required.

Thanks Ace, that rules out my theory then.

@Kenneth_West, do you have another USB cable to test with?

Unfortunately no, but I expect receipt of the HDMI to USB within two days.

I suspect you’ll really want to use the USB connection. I’d certainly try a different cable.

USB A to USB A is an odd connection. It’s typically USB A (the computer or controller) to USB B (the device the computer is talking to). You should have the USB cable plugged into “digital audio input 6” on the back of the device, not the other USB A port. That one is for thumb drives or USB drives with music on them.

The USB digital input in the back of the ML585 is a USB B port.
So they should be using a standard USB A to USB B cable.
Im not home so unsure but there MIGHT be a USB A port as well but if so that is purely for updates.
Could be using wrong cable into wrong port which would explain a lot!

Ah, OK, could be that too. I figured it was a USB drive connection.

Yep, I’ve indicated the connection on this photo of the back panel…

HDMI to USB might work but it’s not the way to go, for best SQ and interoperability use a USB A to USB B cable.

1 Like

I am unhappy to say that now with the USB A to USB B cable installed, selecting USB as the input source on the 585 still renders NO sound. What is suggested now?

When you connect it to the 585 via the USB B input you should now see a new audio zone that will need to be enabled in settings:audio.
Have you done that and then selected that as the audio zone to play too in Roon?

1 Like

Yes, but still no sound.

When you click play, does the progress bar in Roon move forwards and the time into the track increment?

If that’s happening then it suggests that Roon is outputting the audio signal to the DAC via USB, but for some reason the ML585 is not processing it.

When playing a track can you post a screenshot of Roon’s signal path, this may help in diagnosing the issue. A screen of the Device Setup page in Roon’s Setting–>Audio would also be handy.

Just as a test, do you have another USB DAC that you can connect to the Nucleus?

Also can you post a screenshot of the relevant settings:audio page showing the setup for the ML 585 dac and it’s advanced settings too please

I have no idea as to how to display the ML585’s settings, but I have attached a screenshot of the Roon settings/audio. Thank you for your help. Still no sound.

Yes, the progress bar moves forward when I press play, yet no sound. I do not have any other USB DAC, however. Attached is the device setup screenshot.

So the gear wheel icon should give you the device settings option to look at.
However I am concerned that your screenshot shows it as Alsa, that doesn’t seem correct.
Unfortunately I am not at home so cannot check exactly what mine shows as but I don’t think it’s that.
I will not be back at my system to check until later on Friday I’m afraid though.
But in the meantime see if you can screenshot the device setup as I mentioned earlier.

Looking at it again, can you try enabling the other USB high speed zones to see if they enable actual music.
Something just does not look right.

Don’t worry about naming them for this test , just enable and then select as your end zone to play too.

Edit…just noticed in your screenshot you have Revel selected as your end zone.
You need to click on that and choose the ML585 as your end zone.