Trouble with audio devices

I have experienced the same issue. I got two of my audio devices back by rebooting them and my ROCK. These devices are an oppo 203 and an aurilic Aries le. It took some extra work to get the aires back as I had to re-enable it. Roon can no longer find my squeezebox. It says it is searching for it and I must make certain that LMS is turned off (it is). Everything was working until suddenly it wasn’t. Also, it shows my appleTV as enable-able, but it wants the device password and I have no idea what password it is expecting.

Hi @Robert_Lesser

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Go to Settings > Airplay on the Apple TV and you can change this.

1 Like

Its not really important that I get roon to talk to the appletv, I am just curious about making it work. I have now looked at the airplay settings and under “allow access” it is set to “require password: off”. It seems like that should allow roon to access the appletv without a password.

For Airplay to work on the Apple TV you’ll want to require a passcode and set one. After that enter it into Roon and it should work.

For the Squeezebox, can you describe your networking setup for me?

My aural Aries le fell off the audio devices again. This is now quite annoying. I unplugged the auralic, plugged it back in and it did not come back. I hope I don’t have to reboot rock and my audio devices every time I want to listen to music.

I first sent this as a reply to your email, but the email bounced with a can’t find address.

More to follow.

This is now disturbing. Two of the audio devices that used to work, no longer work. This makes roon not so wonderful. The only thing I might have changed between the working and not working was updates to roon and rock. The network stetup did not change.

Is there a chance that you guys will solve this problem?

I tried taking the auralic Aries le from wired to wifi, that did not work. I changed its network connection and restarted roon on the rock. I then stopped roon not he rock and rebooted the rock, still no auralic.

I can get the auralic to work with other software, but then, what’s the point of roon?

Hi @Robert_Lesser, thanks for your patience over the long weekend. I enabled diagnostics on your Core and I’m not seeing any errors relating to these audio devices, they just don’t seem to be visible to the Core at all.

First, can you try disabling IPv6 on your router? Any change after doing so?

Let’s use the Auralic as an example here — What is the IP address of the device? Is it on the same IP range as the Core?

I sent roon user support an email about this problem due to the lack of response. squeezebox synology / ROCK / MyARIES

The AirPort Extreme does not have an ipv6 address, so I assume that means it isn’t turned on.

Hi @Robert_Lesser, do you have backups of your database? If so, can you try this:

  • Stop RoonServer from running in ROCK’s WebUI
  • Navigate to your ROCK’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Roon database folder
  • On the Roon Remotes, press “Use another Core” and connect to the new database

that didn’t work. now I have to connect to the music folders, which because it has been five or six years I don’t remember how. Is there any way this really slow help process can be sped up?

rock is building a new database of my music, which will take awhile as I have over 15000 tracks. why did you think your suggestion would work? What do you think the problem is? Is there a chance the problem will ever be solved? How long might it take?

Actually @dylan did ask you first if you had a backup of your database which would have meant that Rock would NOT have to be rebuilding your database again.

As to why , I don’t know the exact details why but this procedure has worked in several previous instances of similar problems.

Maybe a little more patience with people who are trying to help although I truly understand and feel your frustrations.
Been there and done that and yes it can be aggravating.

Everyone here is really just trying to help.

yes he did. I do have a backup of my database, but as he didn’t mention how to tell rock to use the backup and as I have never had to access the backup, I do not have that knowledge readily available.

As for patience, they have been helping me, unsuccessfully, for two weeks. I am very frustrated by the lack of information as to what they are doing or what they think the problem may be. I have sent several emails directly to support from the help page of the website and have had no response. I could very well be doing something, many things, wrong, but without responses or explanations, I can only be frustrated.

Hi @Robert_Lesser, just to be clear — with the new database, the audio devices didn’t show up at all? In looking at the logs I saw some errors that might be stemming from database issues, so I was hoping we could test with the new database.

You can restore a backup by using these instructions at any time. Since the new database didn’t help, though, I’m hoping you can first use the directions found here and send us over a set of logs using a shared Dropbox link (or any other file sharing service). I’ll take a look at the logs and follow up with our QA team.

only the oppo showed up after the new database was built. I don’t see any reason to restore the old database as it is pretty much identical to the new one. I’ll get to the logs this weekend.

I created an archive of the logs. I don’t use dropbox and don’t plan on learning how just to get you the files. On September 2 you wrote that you enabled diagnostics on my core which implies you have a way to login to my core, which is a bit disturbing, but if you can do that, can’t you look at the logs directly? why don’t you make your dropbox accessible to me and I can drop the file there?

Hey @Robert_Lesser,

Thanks for being willing to work with our team to get this sorted out. I am very sorry about the roadblocks.

Could you please upload the logs on our drive? You’ll be asked to enter your name, email and then you’ll be able to upload the zipped file.

1 Like

its been 16 days since I last responded. I did upload the log file as requested. Is anything happening?

1 Like