UDP-205 doesn’t accept “DSD native” from ROCK

Problem:Since I updated UDP-205 firmware to 0625 and its USB-DAC firmware 118, UDP-205 doesn’t run DSD output by “Native” now. DoP is stil available.
But before the update, it worked…

SETUP:ROCK(latest version On NUC7i7) connects by USB to UDP-205.

I assume USB-DAC firmware has an issue. Unfortunately I cannot downgrade to USB-DAC firmware 112, so no way to confirm the cause myself.
Is there anyone in same situation?

I’m experiencing the same issue with Sonore Ultrarendu.

I assume this caused by updates XMOS-DAC firmware by provided Oppo officially 0112 to 0118. Then it becomes out of XMOS-native-dsd support. So I need re-support software patch for ROCK or downgrade 0112 somehow.
I ask oppo about this issue.

Any word on this? When attempting to stream native DSD to my Oppo-205 over USB I only get white noise. However I can stream native DSD from the same device to a Marantz HD-DAC1 without issue.

I’m running Ubuntu minimal with Roonbridge on a Gigabyte Brix (similar to an intel NUC). DoP continues to work fine.

Hiya, my situation is still same as before. I’m asking oppo customer center.
By the way, your Oppo UDP-205 firmware version? Machine0625 and DAC0118?

I’m running the latest v60-0625 firmware. USB DAC firmware is the latest available 118

So perfectly same situation. I just think we need 0112 or someone update XMOS-native-DSD and included it in ROCK build.
If I could know it that MQA in the machine decode is limited in core decode, I didn’t do update DAC firmware.(;_:wink:

I have an XMOS-native-DSD enabled linux kernel (4.18 rc8) on my ubuntu box and that results in white noise when in native DSD mode.

I thought it could be a linux issue (and perhaps it still could be - but specific to the Oppo 205) as it streams native DSD without issue to a Marantz HD-DAC1.

Is anyone on here able to stream native DSD from any device to an Oppo 205 with the latest firmware?

Solved. I cannot distribute 0112 firmware, but it worked. We need to wait ROCK update.

[Solution, Just wait ROCK update]

Here is issue.

Due to XMOS-USBDAC firmware updates, ROCK OS don’t support DSD native output for Oppo UDP-205 with USB-DAC firmware ver.0115 and latest ver.0118. It work only at ver. 0112(I suppose this is vanilla ver. for customer).

Continuing the discussion from UDP-205 doesn’t accept “DSD native” from ROCK:

Hello @TaqNuc,

I merged your post back into this thread and converted it to a support thread so that we can keep track of this issue in a single place.

We are keeping our eyes on the situation, I know OPPO has already mentioned that there will be a follow up release to this firmware due to an issue with high-resolution playback over the XLR outputs. Typically we wait for the xmos-native-dsd project to update with support and fixes for devices, here’s the link to the project repository.


Hello @john

Thank you for handling the topic.

Sure, we waits the update then!

Still waiting for the update… :slight_smile:
Any news?
Thank you

I really miss playing my native DSD files. Any progress or status report?

You could ask Oppo support to send you the 0112 firmware while you’re wainting. :slight_smile:

1 Like

Having the same problem with my Oppo UDP-205. Have just installed rock on Nuc7i7bnh with UDP-205 directly connected to rock have to use DoP as native just makes white noise, firmware on player is 20X-AU-60-0625 usb is 018 firmware. When using DoP can only upsample to DSD256. I’ve got a Nuc7i3bnh setup for media server which has Roon remote installed on windows 10 if you use the asio driver and plug in UDP-205 will upsample to DSD512. When connected directly to rock get intermittent drop out just wondering if it could be be network switch.

Oppo support sent me the proper files and I reverted my DAC firmware back to 0112. Everything works again. I can get by without the MQA support that was in 0118 for now.

By the way, with 0118, when I played DSD256 files using DSD over DoP, I would get the regular pauses.

Any more news? I just contacted again Oppo to see if we can expect a fix by anytime soon.
It’s been one year since the 0119 was unofficial released.


I have the same problem using DAC FW 0118 and have asked OPPO to send me DAC FW 0112 or 0119. But unfortunately they denied.
Can anyone here step in in send me the FW?

Please use this contact. They are quite helpful.
‘OPPO Service’ service@oppodigital.com