Unable to start streaming. Check your Qobuz account and try again

Roon Nucleus+
Nucleus+ ROCK OS

For more than a month, Roon has been unable to play/stream any music from Qobuz. Previously, it worked flawlessly for well over a year.

I have tried re-booting the Nucleus+ machine to no avail. I have tried deleting and re-logging into my Qobuz account to no avail. Qobuz does work outside of Roon. I am showing that I’m logged into my Qobuz account through Roon. Albums, artwork, etc. all show up. But when i try to stream I get the subject error message. What needs to be done to fix this problem?

Music library is 1050 albums. I’m connected via ethernet to the Roon Nucleus+. Router is an Arris gateway connected to AT&T ISP. Nucleus+ is connected via USB to Pro-ject Box DAC.

  • Mike Harkins

Qobuz changed its policy recently. You need to use the email that Qobuz knows you by, rather than your user name.

Don’t know if that’s your specific problem, tho.

Also, this -

This is not the solution to the problem. I am logged into Qobuz and I used my email address to login. I can even see all the Qobuz content. I just can’t stream it using Roon.

Reboot your roon core server

Did that several times. It did nothing.

3 posts were split to a new topic: Trouble connecting Nucleus Plus to Mark Levinson ML585

You could try clearing the cache since it appears nothing else is working. I had issues with Qobuz and clearing cache got me around that and going again.

1 Like

Hello All.
I am also having trouble logging in to Qobuz via Roon.
Running ROCK v 1.8 build 1021 (latest version) on Intel NUC.

I can log in to Qobuz from their Windows app - no problem. When I enter those credentials via Roon … nada. I was able to flawlessly log in to Qobuz via Roon as recently as two weeks ago. Apparently, something has changed somewhere upstream from me.

I saw somewhere on this forum that clearing cache involves deleting the cache folder from the Nucleus device. I was concerned that this might cause other side effects. If you are sure it won’t, I’ll try that. But I think I will move the cache folder to my desktop computer in case I need to restore it on the Nucleus.

Hereford, Welcome to the community. But the problem you are having is different because you can’t log in to Qobuz. I am not having that problem. I can log in, but I can’t stream. Hopefully, some very knowledgeable person from our community will have a good suggestion for you too.

Have you rebooted the roon server?

1 Like

Embarrassed to say, a reboot this morning allowed me to sign in to Qobuz via Roon. A reboot yesterday did nothing. Confused, but willing to go with the flow.

Hi @Michael_Harkins,

Clearing the cache is my recommended next course of action. Follow these steps:

Within Roon, go to Settings>Services, click edit next to Qobuz, and log out of Qobuz.
Exit Roon
Restart Nucleus
Launch Roon and log into Qobuz again

One more thing, are you by chance on a Qobuz trial at the moment?

Please let me know how things go. I’m monitoring our thread here and will be happy to assist further if help is still needed!


OK. I did as you said. I logged out of Roon and restarted the Nucleus+. I am getting the same results. However, you might be right about my Qobuz account. I think they unplugged me because now I’m only getting 30-second clips of music from them. I’ll contact Qobuz to find out what is wrong because I think it is probably on their end. I’ll get back on this thread if that is not the case, but that’s my guess at this point. Thanks for your help.

1 Like

Mike - thank you - but I am hearing no sound at all since acquiring the Roon Nucleus+. I will clear the cache and see if it does the trick.

The 30 second thing is definitely a qobuz issue.


I had the same issues. Music would not play using Qobuz through Roon. Quboz by itself worked fine.
I restarted Roon on my core (IMac), logged out of Qobuz and and logged in again.
Now everything works fine.

1 Like


Best wishes to you. I apologize for the slow response times but bear with me. I’m just getting started in supporting Roon after having moved from another department but trust I’ll respond when I can!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.