Unexpected Error Message

i keep getting the above message when I try and locate my naim uniticore. This was all working previously! I added a new network extender - all my other devices work and my Roon Core device shows up in Roon but I can’t locate the naim where my music is stored. I am currently on the trial period so will need this resolved if I am to progress to a subscription.

Sounds like the network extender has changed the network address. What is the IP address of the roon core and of the Naim?

Naim Unity Core -

Netgear Ext -

Roon Core -

Hi @Leo_Scott,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Since this behavior started occurring have you tried rebooting your Core and the Naim?

Can you share a screenshot of Settings > Storage?

Hi Dylan,

My set up is as follows-

Naim Uniti Core used as a NAS Ethernet connected to a Netgear Ex8000 WiFi extender

dcs Network Bridge used to access Naim via UpNp also connected to Netgear vai Ethernet.

Sonicorbiter computer used as Roon Core Ethernet connected to Netgear

All was working fine, I disconnected all the Ethernet cables to replace some with long ones due to repositioning equipment and now when I go to add Network Share I get the unexpected error message. All other devices work and I can access my music outside of Roon.


Leo Scott

I get this message even when the user name and password boxes are completed. And yes I have tried rebooting everything. My free trial ends soon, so I would like to get this sorted in order to have confidence to progress to a subscription

I also see this in storage, even those I removed the original folder in order to reinstall it as it wasn’t working

Hi @Leo_Scott,

Thanks for the additional info here.

Are you able to access the Naim network share over the network via Finder or File Explorer using the path specified above?

As mentioned in our Networking Guide, we generally recommend against using these types of WiFi extenders. Was this device in place before when this was working for you?

Yes I can find the Naim and files via file explorer and yes it was all working when I put the extender in place. This is not an over the mains device but a WiFi extender.

Thanks for confirming, @Leo_Scott.

Can you try using the IP address to connect to the Naim like this:


Make sure you include the Username and Password fields here as well.

No change still getting the “unexpected error “ message

If I try //
It searches then I get - could not connect to share: Host not found

I’ve read thru this thread a couple of times but am still fuzzy on the network topology. Is the EX8000 configured as an access point maybe? Are you double NAT-ing?

Even better, can you provide a basic line drawing of your network setup?

Sorry, but what is double NATing?
The Netgear EX8000 is connected wirelessly to my router all connections to the EX8000 are by Ethernet. It was all working, then I disconnected to install longer cables and then Roon stopped finding the
Naim Uniti Core and I got am getting the error messsges.

When I set up the EX8000 I did this by the wps button on the device and my router

That should be wps button!

Just an idea here, and not saying it makes sense but when it comes to networking strange :poop: can happen sometimes.

Anyway, now that you’ve got the proper length cables already in place, try running the EX8000 setup again (as if you’re doing it for the first time). Optionally, you can try another connection method (if available) instead of WPS.

Let us know what happens.

Edit: Here, I did some digging in case you need help:

Hi Ron, thanks for the help but i’m Not sure that is the issue. I can play tracks on Qobuz via Roon and I can play the tracks that are loaded onto my Roon Core. It is just that I can’t direct Roon to where the bulk of my music is stored which is on the Naim Uniti Core!!!

Hi @Leo_Scott,

If you do not add the .local does the same behavior occur here?

Moving forward with troubleshooting, there are a couple things I’d like to recommend next:

  1. Try changing the username and password on the Naim, reboot the Naim and the Core, and then try re-entering in the network share.
  2. If Step 1 doesn’t yield any changes, let’s try temporarily connecting these devices to the main router instead of the WiFi extender. Does the same behavior occur?

I plugged the naim directly into the router and typed address as suggested. It was excepted and files started loading. A couple of thousand files loaded & then all disappeared and a message that folder could not be found.