Volume change switch from 176k vs 352k sampling

I have my sample rate conversion setup to convert DSD to 176. Sounds fine. If I change the conversion to 352 I immediately hear a large, very noticeable reduction in volume. If I switch back to 176 I hear the volume go back up.
I have headroom adjustment set to “0”, so that shouldn’t be an issue. I also don’t have volume levelling activated. My device setup is set to “fixed volume”.

So what could be causing this?

Can you post screen shots of the audio path for each different rate of playback?

they are exactly the same, except one says 2.822MHz to 176.4kHz and the other says 2.822 to 352.8.
Same number of steps in path, and all other steps are identical.

A downstream component (e.g. your DAC) almost certainly is causing the volume change with the sample rate change. If the Roon signal path otherwise remains the same, Roon is unlikely to be the cause.


Are you using convolution?

No convolution.Wrote the DAC manufacturer and asked if it is a DAC setting.

Hello @danny2,

Thanks for contacting support, I would be happy to take a look over this issue with you. Can you please provide an overview of your setup using this thread as a guide?

Also can you please let me know, does this issue impact both PCM content and DSD content?


Hi Noris-
Thanks for your reply. Just checked - this happens with PCM also.

My setup:
Roon 1.5 v3.54 32bit
Roon Core is on Windows 10 Pro 64 with latest updates - which is server with anXeon board and i7 chip

Storage is on internal HD in Roon Core machine

playback is to Roon Ready Bricasti M5; ethernet connection, playback is to Kii Three system over USB or AES

Network router: linksys WCT1900ACS + TP Link Gigabit switch (everything is plugged into the switch, and the switch is plugged into the router).

Collection is about 25k tracks
I control Roon over wifi on a laptop or tablet

Hope this helps

If a Kii Three is in the playback chain, you can pick one sample rate for Roon and just stick with it – because the Kii Three is going to sample rate convert everything to 93.75 kHz anyway.


I’m aware of that and don’t want to do that.
Kii recommends best results are achieved by sending all playback at native sample rates. IME, that is correct.
So I only play with sample rates when I have DSD in a mixed format playlist.

Well, if the Kii Three sample rate conversion is what is producing different volume levels for different sample rates, that does not exactly support the quality of its implementation. Anyway, if you want a consistent volume level, you certainly can accomplish that by configuring Roon to output just one sample rate to the Kii Three.


Hello @danny2

I have tested for this behavior with a few devices that we have in-house and am unable to reproduce your findings. The volume difference you are hearing is likely due to the device’s internal sample rate conversion and as @WiWavelength mentioned, you can set Roon to output a specific Sample Rate to the Kii Three in the DSP Engine settings.