Windows firewall issue

Core Machine (Operating system/System info/Roon build number) Win10/i5, 16gb/Roon 1.8 build 756 64bit
Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet) UNIFI USG 3P router, 3 wifi AP’s Audio Devices
Windows 10 Core as endpoint, multiple wifi endpoints (hifiberry, Chromecast, iOS) Description Of Issue:
**Roon does not start or starts without UI. When clicking the Roon icon a white rectangle with red diagonals is displayed briefly. **
This issue is solved by removing all Roon and Raat instances from the windows firewall/restart/allow Roon and RAAT through firewall/another restart. **
However this happens too often now: 2 or 3 times last week only. I know the drill now, but why does this happen? is there a solution?
I have another support thread opened where I raised this but 6 days have passed without a solution; I also raised this in another thread in early March but that thread is now closed.

HI Dan,

A White Square with a Red X usually means that there is a graphics Issue. This usually is resolved by downloading and installing the latest graphics driver from the GPU manufacaturer.

Thank you, but according to windows I have the latest graphics

… and this issue is solved as I described - by removing Roon and RAAT from the firewall. Also, if there’s a graphics issue how come that sometimes it just works without this issue?

by the way, I am also getting this annoying thing on the Roon Core computer - the Roon window becomes a square instead of full screen and it cannot be made into fullscreen unless I restart Roon. This also happens only sometimes… can’t corelate it to other things yet

Are you using McAfee Real Time Scanning, by any chance?

No (in at least ten characters)

Hey @DanMtsn,

This has taken us longer than we had hoped, even if things are looking up when it comes to response times. Thank you for your incredible patience!

Sorry about the thread being closed back in march - an automated setting (that has since been disabled) closed threads without a reply in 14 days :pleading_face:

I’ve moved your thread into our technical team’s queue, so they can take a closer look at your specific case.


I see this takes incredibly long and it is still popping up every now and then - last night it happened twice in a row.
Really can there be no solution?

@beka @danny
Is anyone there? Does Roon even have a support service anymore?
This is not solved, it happens all the time! I opened this months ago (my first thread on this matter was opened in early March).

I notice from your earlier screenshot of using Windows Device Manager to check on driver updates that you appear to have two graphics hardware adaptors in your system. The Intel HD Graphics, and something else (which is obscured in your screenshot by the Update Drivers window).

The fact that the Roon Core PC also will occasionally not display the Roon window fullscreen also points to a graphics driver issue.

It would be helpful in diagnosis if you could give full details of the hardware and software environment on your Windows PCs.

And, yes, the Support queue is long at the moment - there are a number of high-priority issues being dealt with at the moment. Sorry about that.

Try getting the latest drivers from the graphics card manufacturer’s website rather than Windows update, for both the display adapters you seem to have installed.

OK… how can it be the graphics driver if removing Raat and Roon from the firewall solves the problem?

Could you please have a look at my initial post where I provided all the details. kindly let me know what you think is missing?

  • Build of Windows 10 used on your Windows 10 PCs
  • Details of your graphics hardware used on your Windows 10 PCs

Windows 10 Build 19041.985
I have intel on-board graphics

[moderator note: removed the image showing a user’s email address]

Sorry, but as I said, your Device Manager screenshot is showing that you have two graphics hardware adaptors fitted to that particular PC. One is the built-in Intel HD graphics - what’s the other one?

The other one is Remote Display Adapter. I suppose it’s for remode desktop connections
I updated the drivers anyway, will see if this solves it or not.

Yes, that’s for Remote Desktop sessions - have you accessed that PC in this way?

I’ve just installed Roon on a Windows 10 PC that I access via Remote Desktop, and am not seeing the issue you have reported - Roon runs normally.

Nevertheless, I still feel that this is a graphics driver software issue. I believe that you have only tried updating the Intel Graphics driver via Windows Update. If so, can you try installing Intel’s own driver update software here, and see if that will resolve the issue?

I installed the Intel update using the Intel app that identifies the hardware and the required driver.
To be clear, my problem did not occur when accessing this computer remotely, it occurs randomly.

Hey @DanMtsn,

Thanks for following up on your post and for working with @Geoff_Coupe in the meantime. Thanks @Geoff_Coupe for your insightful interventions :pray:

I’ve bumped this up in our technical team’s queue, @DanMtsn. You should hear back from them as soon as possible.

Hi @DanMtsn

Apologies for the delayed response here — We discussed this with the QA team during our weekly meeting and they’re actively looking into this. I don’t have any specific updates I can provide at this time, but we’ll be sure to keep everyone updated.

Just to confirm, the firewall you’re needing to re-allow it through is the standard Windows Defender firewall, correct? Do you have any other firewall or antivirus apps running?