After the upgrade to 1.8, all my clients do crash at startup [Resolved - Manually update to Build 806]

After the upgrade to 1.8, all my clients do crash at startup. I have this issue on my iPad, iPhone as well as on my iMac.
When I switch the Roon server off (via the web browser), and I startup the Roon app on my devices, it doesn’t crash and is waiting to select a Roon core. As soon as I start the Roon Core (on my NUC) then the app on my devices crashes again.
Please advice what I need to do to remediate.


Your topic has been moved to the support section of the forum.

In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

This was happening when I 1st installed 1.8. I rebooted my Mac desktop and iPhone and it finished the install and loaded. Without daily mixes albeit but that’s another story.


Thanks for your insight, @Randy_Harbin. Our team is actively working on fixing Daily Mixes. Please, sit tight :pray:

Thanks @Carl for your help! We do need a bit more information to help @Vic_Dewulf. Hoping to hear from you soon :nerd_face:

Same issue as OP. iPad and two iPhone clients immediately crash upon start after the update. Rebooting the client devices does nothing to improve the situation.

Roon server 1.8 build 806 on Qnap. 5/18/21 version. Stop the Roon server and clients will display “waiting for server,” start Roon server, and each client crashes.

I have the same issue too. The core itself is up and running fine - as seen from a direct login via IP address. However, the remotes (IoS and PC) crash upon start. I’d very much appreciate any advice you might provide on resolving this.

I am also running Version 1.8 (build 806), although via ROCK on an Intel Nuc.

Same here. Both iPad and iPhone clients crash by start. In essence, Roon is now useless.

Ditto. iPad and iPhone both crash on startup after update. I have rebooted everything and still crashes each time I attempt to open the apps.

Something to try - loaded 64bit Roon client on windows device and client was stable. Picked Roon core and selected audio device. Able to play music. Apple products now have working Roon clients.

-Good luck

I’m having the same problem. Nothing working. When I open the app, it freezes at the logo. This is on all devices: Dell XPS 15/Windows 10, Samsung A50 and Amazon Fire tablet.


Can you both uninstall the Roon Remote app from your iOS devices and then re-install it from the app store? I have a hunch that might do the trick, but let me know if you still run into trouble.

Hi, this worked for me. Thank you!

1 Like

It worked for me too.

1 Like

I’m having a similar issue.

  • If Roon server is running (Mac mini running big Sur), then on my macAir, Roon opens and immediately shuts down. Roon remote on my iPhone does not crash but just sits there “looking for Roon core”

  • If Ron server is not running, then Roon on my macAIR opens fine. But once I start Roon server, Roon crashes on my MacAIR

EDIT: all good now after reinstall of Roon and Roon remote

1 Like

I have the issue with the MacOS client, I’m running the Core on ROCK. The MacOS remote app (806) won’t load.
iPhone running 806 works, as does 1 iPad (have not tried the others yet).

On iPhone I had to force manually update to 806, then it works fine

1 Like

Thanks! That worked for me to.

1 Like

Try re-installing the macOS app from our downloads page.

Thanks @kevin, I have tried that, but behaviour is the same.

Hmm, would you mind using the directions found here and send us over a set of logs from the macOS client that won’t load? You can use a shared Dropbox link (or any other file sharing service).