Another case of Roon randomly stopping

I’ve had Roon for about a month and have been well pleased, until today. Now, it plays for 10-15 mins and then randomly stops. The stoppages are not linked to any activity or action in terms of using the computer or audio player.

My Roon Core is located on a MacBook Pro 2012. My server is microRendu. My system and internet connection are rock solid.

This is completely unacceptable - especially given the cost of the software.

Back to Audirvana. I’ll be looking for a refund shortly.

Agreed, tagging @support.

I appreciate you stepping in - thank you. I apologize to everyone offended by my apparently confrontational approach. I’m a little frustrated about buying a premium product that inexplicably stops working. And then there’s no one to talk to about it…except the community blog. This kind of thing bugs me, I have to admit.

It’s a pity 'cause I really like the way Roon sounds. I actually prefer its tone compared to, say, Audiavana - which probably puts me in the minority. I’d like to keep using it, at least until the end of the first year. I wasn’t expecting technical issues and if someone’s got some helpful advice, that would be wonderful.

Support folks (as well as forum members) here are helpful. Hopefully you can get on track soon. Good luck.

—Robert

@Jeremy_Jones

I know it’s a simple thing, but did System Preferences, Energy Savings settings get changed on your Mac? Either hard disks or sleep would cause this behaviour.

1 Like

I’ve edited out the discussion about other posts as this section of the Forum is intended to solve problems.

@Jeremy_Jones, apologies for the distraction from your issue. The important thing here is to assist Support in understanding the problem and fixing it.

Sometimes software up grades can alter power settings and Larry’s suggestion may assist.

The Support devs will see Carl’s flag and drop in shortly. They will probably gather some logs from you remotely, which should reveal why the stoppages are occurring. Hopefully you can be back on track very shortly.

Well I just unchecked the “put hard disks to sleep” boxes. Let’s see if that helps. Thanks for your suggestion.

2 Likes

@Jeremy_Jones is your mbp running an ssd or hdd? This too can have marked impact on the performance of the core…as the core is running there on the mbp.

It is generally recommended that an ssd is used for the core os/database drive.

And sleep or power saving options should be diabled…screen blanking is fine.

My MacBook has an SSD. It’s been working perfectly with Roon for a month. Then suddenly…

I’m thinking I should uninstall it and then re-install?..

Make sure you’ve saved a backup of your database (stores your favourites, edits, tags, playlists etc) then try reinstalling.

You are not the only one who is having these problems with Roon. I’m having exactly the same problem on Windows & Devialet. The streaming just stops randomly every few minutes. I have been using Roon for over two years and never had these problems before. Therefore I have a feeling that there might be a bug in the latest version of Roon.

Please keep us updated if you find any solution to this.

Yes, I think so too.

I have this happen as well.

I’ve turned off everything I can think of that might be triggering the player stopping. Nothing solves it so far. I’ve even deleted Roon from my computer and re-installed it. Nada - the problem remains. Not meaning to to rude or anything but I’m going to switch back to A+ and will wait to see if Roon can resolve this. Very disappointing.

This is happening to me as well. I have had several playlists where songs would stop playing after the 2nd or 3rd song. I have gotten an error saying “Roon has lost control of your audio device”. When I start the playlist over again, sometimes it stops again, sometimes it doesn’t. Strange.

Thankyou @Lonek, @cgw, @Petri, @John_Hill and @Jeremy_Jones,

The devs are currently working on a known issue associated with Devialet streaming, but how many of you are using Devialet gear ? It may be that there is a broader issue.

Good evening… I have an announcement to make, as well as an apology. After protracted testing today (it was a suitably rainy day here in NJ) I discovered that Roon is not the cause of my random stoppages. The problem stems from my microRendu. When I cut the mR out of the chain and connect my MBP with my Schiit Eitr, all is normal - except the SQ is significantly diminished by the absence of my streamer. So now I need to figure out how to cure my mR. I’ve done all the obvious rebooting and carefully re-installing. It hasn’t resolved the problem. I’ll have to continue the saga on CA with the Sonore people. Apologies once again for being a little rude about Roon.

If anything was changed in MR system, since your problem started, then Ronn is certainly “innocent” :slight_smile:

But despite nothing was changed in MR, problem suddenly appeared - and Roon was changed in the meantime…

Thank you Andrew. I am having these problems with Devialet. Apparently also @Al_Abuzeid and @mdconnelly are having the same problem with Devialet.