ARC not appearing in Android Auto

Roon Core Machine

Intel NUC 7i7BNH 16GB Windows 11
Roon v2.0 (build 1203) earlyaccess (64bit)

Networking Gear & Setup Details

FritxBox 7590

Connected Audio Devices

Meridian ID41 → Meridian 861v8

Number of Tracks in Library

60,559 tracks

Description of Issue

Roon ARC doesn’t appear in Android Auto
Roon ARC 1.0.5
Build 100081
Nokia 8.3 5G
Android Auto v8.6.625054
Android 12, Security update 1 December 2022

Your ARC app is badly outdated. If your Core is on earlyaccess, your ARC app (and all remotes) must be as well. The current version in earlyaccess is ARC 1.0.10 Build 100139.

Android Auto was first introduced in Build 116 but was only available as an APK:

And through the Play Store with Build 129:

If you installed ARC from the APK package, you can get the current one here:

Or consider uninstalling it and installing ARC (and earlyaccess Remote apps) from the Google Play Store, in which case you should get automatic updates (if you didn’t turn them off). Ensure that the Play Store recognizes that you should get Beta updates.

Alternatively, if you don’t want to use earlyaccess and return to production builds:

Your ARC app is still out of date. The one that brought Auto to regular production releases is 1.0.10 Build 138:

In this case, ensure that your Core runs production, as well as ARC and all remotes. To leave earlyaccess, see here.


Hey @rolski,

Ben with the support team here, I wanted to check in on this thread and see if @Suedkiez’s excellent response above was helpful?

I’ll be on standby for your reply. :+1:

Thanks for the message @benjamin
Unfortunately, I’ve not yet been able to check / test the solution.
All of my devices are now back on the same ‘release path’, but I need to find a car… :wink:

Hi @benjamin .
I’ve just tried it in a brand-new Lynk & Co from Sixt.
Roon ARC doesn’t appear in Android Auto - it’s also not on the ‘hidden’ list in the Launcher settings - it’s simply not present or selectable.
Qobuz is there, as is Plex & Tidal…and plenty of other Apps…

Core is on 2.0 (build 1218) earlyaccess
Roon Remote (Android) is on 2.0 (build 1218) earlyaccess
Roon ARC (Android) is on 1.0 (build 149) - downloaded from this page…

Hey @rolski,

Could you please update to build 150 and let me know if your issue persists?

@benjamin - where is build 150?
It’s not at this link or on the 1218 page.

Hey @rolski,

My apologies, Build 150 is the latest production build, you should be able to download/update it from your phone’s app store.

@benjamin - OK, so the ARC version you’re asking me to install / try (v150) is a Production Branch Version, but the previous instructions were that my whole system, end-to-end, should be on the same Branch e.g. ‘earlyaccess’.

Is that information no longer correct - because I’m on ‘earlyaccess’…?

A new earlyaccess was just released with ARC B155


Today (still not working):-

Android Auto version 8.9.630634-release
Version & Permission info / Packages: Roon ARC 1.0.34

Roon ARC App: Software Version RoonARC 1.0 (155)

So - is there an alignment / compatibility problem?
Is RoonARC ‘forcing’ the connection & updates / passing the correct information over to the Android OS correctly?

Hey @rolski,

Thank you for the update! Do you by chance have the timestamp of when you attempted to connect/ set up Andriod Auto?

If not, could you please reproduce the issue and take note of the date and time, and share that info here?


Do you mean when I connected to the Car?

  1. I tried on Sunday night about ~20:30 CET
  2. On Monday morning ~08:15 CET I tried - in the car - to see if Roon ARC was there.
  3. On Tuesday evening I deleted Android Auto & Roon ARC, restarted my phone, re-installed both Android Auto & Roon ARC, and re-connected to the same Car yesterday morning (Wednesday ~08:15 CET)

Does that help?

Hey @rolski,

Thank you for the information! We took a closer look into your arc diagnostics, but haven’t found anything pointing toward the issue yet. I should have more information to share after discussing it with the team tomorrow.

Thanks for your continued patience while we work through this issue. :pray:

Thanks @benjamin for the feedback.
I’ve tried again over the last couple of days, but no change.
And unfortunately I won’t be able to check again soon - but when I am able - it will probably be in a completely different vehicle - so that variable might be able to be ruled-out.
If there’s any more information I can provide, please let me know.

Hey @rolski,

Thanks for letting me know. As a next step (when you can test) I would take a look into the cars systems audio add on’s, and see if anything is enabled there.

I would also try removing and manually re-downloading ARC via the apk link here :

Today: new / different vehicle, latest version of Android Auto installed on 'phone, 'phone connected with USB & Bluetooth, Roon ARC not present on the car’s menu, force-started ARC @ ~19:30 CET on the connected 'phone, radio (Times Radio) switched to Roon ARC & music played for ~10 minutes before stopping, but App still not visible on the car’s screen.
Any ideas?


Thanks for the update. I can’t tell from your response if you manually downloaded Arc from the link I provide above?

Also, did you look into the cars systems audio add on’s, and see if anything is enabled there?


Hi @benjamin
Yes, I cleared the cache & memory, uninstalled the version I had, installed the version you’ve linked-to (ROON arc 1.0.33 Build 100150) and I’ll try it again tomorrow, just to be sure.

I will also check the Car’s system as you suggest - but I’ve not seen anything so far.

But the question remains, why doesn’t ARC appear in the Android Auto settings in the App on my phone - like every other enabled App does?

See photos.
Roon ARC doesn’t appear as a selectable App either in the car or on my 'phone.

As mentioned before, Roon ARC simply isn’t recognised as a compatible App - whereas TuneIn / Tidal / Soundcloud / Qobuz / Plex all are.

What could cause the situation where Roon ARC isn’t recognised?