“Are you online? Please check your internet connection and try again" [Solved Xfinity firewall]

Hey @David_Ohm,

Thanks for providing all the additional information above. After re-reading the thread, I wanted to circle back to your DNS of, which is very strange. Are you by any chance using Comcast Constant Guard specifically? I wonder if this Comcast firewall might be causing issues with Roon functioning properly.

Do you by chance have another router you might be able to test? We’ve seen users run into issues using Comcast hardware in the past.


Hi Benjamin, nice to hear from one of Roon staff.
I use the Xfinity router (Comcast launches Wi-Fi 6 gateway, makes xFi Advanced Cybersecurity free - The Verge). I don’t think I am using the specific gear you mentioned. I do not have another router to test.

I checked the screenshots I took long before when Roon started having this problem. The DNS was also So no changes. I’ve been using ROCK for about 8 to 9 months. During this duration, there were two major problems occurred, one of which was resolved by renaming Roon Server folder to Roon Server_old followed by rebooting the system and restoring a backup. This occurrence is the second incident after two to three months. I will try whatever you instructed me to do if you can walk me through, any troubleshooting. Many thanks!

Below screenshot was taken December last year (2021) when Roon was working flawlessly.

According to this article on the OpenDNS forum a DNS address of may be being set by Comcast’s Constant Guard, a piece of security software, so I think it would be worth investigating to see if you have this software. If so, you should be able to change your DNS server.

Alternatively, you could try changing the networking settings on your ROCK from DHCP (which gets the settings from your router) to Static IP. I don’t have any experience of using ROCK, but I suspect that all you need to do is change the DNS setting. In other words, input the following values after clicking the ‘Static IP’ button:

IP Address:
DNS Server:

You could also try for the DNS server (this is Cloudflare’s DNS, whereas is Google’s).

If you try the above and it doesn’t make any difference, you can easily revert back to using DHCP.

I can see why you would think that this isn’t an issue - it used to work, so should work now - but if is set to perform some sort of security checking by Comcast it’s possible that they have made some recent changes that have resulted in Roon’s oauth server being blocked, whereas previously it was allowed.

1 Like

@DaveN Thank you for the suggestion!
I was hoping that this solution could work out. I tried both Google’s and Cloudflare’s on Static IP, but the result was the same. Please see the screenshots. I feel like I am running out of options and don’t even know what’s causing this issue. However, I really do appreciate your help. Many thanks! @support @benjamin

Sorry that didn’t help. Did you check if you have Comcast Constant Guard installed?

I’ve been reading round on Comcast’s Xfinity and it seems like there are a lot of complaints regarding its over zealous security measures, i.e. it blocks access to legitimate sites. If you have the Xfinity app or visit the xFi website you may be able to turn off advanced security using the following article as a guide:

I have no idea if this will help, but it’s probably worth a try.


@DaveN Thank you. I was also trying to talk to Xfinity agent to find out about Constant Guard. I am still waiting on cue. Meanwhile, I checked the Xfinity security page and found out followings (see screenshots).

Fix is nothing new: restart the device, update your software and pause your device, which I have done already. However, interesting findings are the indicated threats or attacks were made exactly the same day my Roon stopped working/started having this problem. Kind of puzzled…

I think Xfinity is not using Constant Guard any longer but replaced it with Xfinity xFi Advanced Security. I will have to confirm it with Xfinity. Still waiting…



First I followed these steps as you instructed, hence now advanced security has been turned off.

Amazing! It is now working!! The problem fixed. I am able to long into Tidal and Qobuz and both accounts are synching now.

You are amazing! Thanks a million!!
Now I am wondering if I can put the advanced security back on.


Excellent news :slight_smile:

I would imagine there’s some way to whitelist specific sites or url’s, but if I were you I’d leave it turned off for now, at least until you’re sure that Roon is up and running again as expected.


Just amazing…!!! All of my Roon library, tags, and bookmarks are back!
I am so very much thankful for your help!!! @DaveN and for everyone who tried to help me and made comments @Robert_F @ged_hickman1 @Geoff_Coupe @benjamin


Just a small issue.

I am getting this warning message while everything else is working properly except lost about 1000 albums (from Tidal or Qobuz) in my library. First, it showed 8891 albums then continued reducing, and now stopped at 7598.

It should be related to this issue.

@David_Ohm start everything again and the metadata optimizer will work again

1 Like

Roon’s KB article on the topic suggests a reboot as the first step, as @Uwe_Albrecht suggested. If that doesn’t help, we’re back where we started, i.e. a networking problem that’s most likely caused by your router. Fingers crossed the reboot fixes it.

1 Like

@Uwe_Albrecht @DaveN Thank you both for your advice!

While everything else is up and running, I discovered some strange behaviours in Roon. These are the steps I followed:

  1. Rebooted ROCK
  2. Rstored a backup
  3. Log-in (successfully)
  4. Log-in Tidal (though Qobuz stayed logged in)
  5. Total number of albums showed 8891 (which is correct)
  6. Spotted Metadata improver error warning (again)
  7. The total number of albums dropping and stopped at 7597 (most likely from Tidal or Qobuz)

Comparing to the issue I was having, this is a small problem but I’d like to know what the problem is.
As I lost a chunk of my albums, many playlists are also missing relevant tracks… :frowning:

Also album artworks are missing too.

After restarted Roon server software, the Metadata improver warning has disappeared and showing this screen. It looks like Roon is recuperating but finally stopped at 7600. I will leave it for awhile and see if there is any change. Keep you posted.


There have been quite a few threads on syncing problems with Qobuz over the last 12 months or so, and some reports that leaving things for a while can resolve the problem. If I were you I’d leave it for an hour or so and see if there’s any change.

Alternatively, this post might help, i.e. how to force Qobuz to synchronise with Roon. I expect that you could do the same for Tidal.

1 Like

@DaveN @Uwe_Albrecht You are absolutely right. I followed the steps, first by logging off Qobuz. The total number of albums shows 7600. So Qubuz was missing all of the albums I favourited. I logged back on to Qobuz. Qobuz is synching. The number is up to 8800 now. I will leave it for a while and see if the missing albums are all recovered. Thanks again! I will report back.

Voilà! All of them are back!
Thank you so much again!!!


@David_Ohm The thanks goes back. We must also share joy!

I wish the joy and this success to all, but some of us must be more patient, because other solutions are needed. But without this community it definitely does not work. Sometimes anger and frustration and then again the great love and joy. The first should be a short storm, the last should stay longer. Only problems that continue for many months or years, make any love permanently broken.

1 Like

Many thanks, @Uwe_Albrecht for the help!
I realised the collective intelligence in this community is an invaluable resource.
To your storm analogy, “When you come out of the storm, you won’t be the same person who walked in. That’s what this storm’s all about.” – Haruki Murakami, (Kafka on the Shore)
I certainly feel that I am not the same person anymore before this storm. I learnt a lot from the support of this collective intelligence. All thanks to this community.

PS/ Roon is working all in order at my end.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.