[AT&T Fiber] Pace 5268AC Gateway, Port Forwarding Fails [Workaround - Manual Configuration]

So I have to call no joy due to my network configuration and provider (AT&T Fiber). I was able to install B996 on my 2019 MacBook Pro, went into TestFlight and installed ARC B25 on my iPhone 11, and started to work on configuring the network. This is where all my issues are.

I am on AT&T Fiber using their Pace 5268AC gateway. Based on the age of the gateway (which is required for our service) and their configuration options, I also run an ASUS AiMesh network for my home LAN for all connected devices. other than the fiber and phone. The AT&T gateway serves only to bring the fiber and phone service together, and then all other data traffic is managed within the ASUS network subnet. Unfortunately, this gateway does not support UPNP, and port forwarding and/or removing the gateway’s NAT function for a cascaded router network is not really configurable either.

I have spent the past two hours reviewing and testing configuration options between the AT&T gateway and my ASUS subnet, and do not see a path forward. I will keep looking into this, but for now, while the B996 and ARC app work in my home, I am unable to test it outside of my LAN.

Actually port forwarding after a fashion is available under “Firewall application, pinholes and DMZ”. Go to “allow individual application” and “Add a new user-defined application”. I don’t know if that would help…

Thanks Milton, I tried that but it wouldn’t pass the traffic from my ASUS router through the gateway. Will probably try more things over the weekend. I am definitely open to learning if this is possible and what steps I may be missing. Appreciate the guidance.

Hi @Robert_F,

I hope you don’t mind, I’ve moved this scenario over to the #arc-testing:port-forwarding-progress subcategory to add it to the queue for troubleshooting. Please stand by, and we’ll hopefully have this sorted out before the weekend or as soon as possible afterward.

Once we’ve got a permanent solution or a temporary workaround in place, we will crystalize port forwarding troubleshooting into Wikis in the #arc-testing:port-forwarding-solved section as signposts for other testers with the same ISP and router combination. That has proven helpful so far, given the ubiquity of certain setups.

A staff member should be back in this topic shortly to help out with this situation. Thanks for your patience.

1 Like

@connor, really appreciate the update and thank you for moving the post.

1 Like

@connor, I have the Pace 5268 as well. Only one router but using a Netgear switch. All I could do was to change to the third option in the LAN settings, DMZ Plus mode, and disable the firewall to the Nucleus. Then the auto-configure got through. I’m using my IPad and Android for ARC. Took a short trip and was able to stream a local ALAC file from Nucleus to my phone, then BlueTooth. Worked well. If only I could stop the alert interruptions. I’ve tried many times to make them stop. Thank you and to the team for bringing this app to us.


John, thanks for the update. When you configured DMZ Plus on the Pace gateway, did you have to reboot your Core? I read the instructions and it seems some devices need to be rebooted to grab a new address. However, in my case, it does not let me add DMZ Plus as an option as my only connected device is the primary ASUS router.

This post talked about that @John_Kaster outlined above

Oooo this looks good

The idea here is that you want to avoid a “double NAT” situation. It makes forwarding ports a real nightmare.

On your second router, the Netgear, you want to turn of DHCP server, or set it to a Access Point mode. Computers will connect to your WiFi, and ask the network what IP they should have. You want the Pace to answer and manage that.

Here’s asus Aimesh ap mode


@Otherford, thank you. I read through those before but they are becoming clearer now on what are my options.

My main issue is that AT&T’s DNS service, at least for me, is incredibly unstable and resulted in significant networking issues. By keeping my ASUS router as a router, and using it to control my DNS by forcing Google or Cloudflare, my network issues were eliminated. So my concern is that if I place my ASUS in AP mode, I lose control of DNS, and to a certain extent, firewall, network prioritization, and more granular control of my network.

So, your best bet there would be putting the Pace 5268AC in passthrough mode with that link I put above then.

Also: just because it’s ATT router, you should still get admin access to it. If you end up putting your Asus routers into AP mode, you should be able to get into the Pace interface and add your details there. You might be able to override their default DNS servers with your own, and add your port forwarding stuff.

This will all require some tinkering. Take notes as you go. Usually these changes are small, so if you have notes you can roll the changes back if things don’t go as planned.

Yes, I did have to reboot the core. And yes, all of my wired and wireless units are managed from there. Hope you can get the program configured.


Drew, SUCCESS! Don’t know why this worked today, I’ve been deep in the Pace settings since Thursday morning. Previously the gateway would not allow DMZ + to be saved, but today it did. I opened UPNP on my ASUS router, and now have access to Roon ARC remotely. Thank you for the assistance!


Thanks again to everyone here for their assistance. Double-NAT’d networks can be configured to support Roon ARC with an addtionally attached routed subnet.

For reference, I tested this both with enabling UPNP and with port forwarding, and both worked. I ended up disabling UPNP and am using port forwarding, but again either is an option.


I like it. Love these success stories. What I see here is:

  • you had double NAT (two routers routing)
  • you put one into DMZ pass through aka AP mode aka Bridge mode
  • both UPnP and manual port forwarding started working on non-DMZ router

Nicely done


@connor Have a problem here. I got ARC to configure properly using the DMZ pass through and tested it on a short trip to town. All worked well. When I came home I opened my iPad using the normal Roon app and all of my endpoints disappeared except for HDMI A and HDMI B on the Nucleus. Returned the Nucleus behind the firewall and the endpoints returned. Tried to create a “Roon ARC” program in the Firewall settings on the 5268AC with poor results. Streaming through ARC had serious skips and pauses and still had no endpoints on the normal Roon app. My only solution would be to use Roon ARC when I am away from my main system for a considerable length of time. Any help would be welcome. Thx. John

1 Like


I believe the DMZplus setting on the Pace gateway creates almost a separate network for those devices configured in this manner. When I created my DMZplus setting, it was for a second router that in effect handled all traffic on my network (I don’t connect anything, including WiFi, using the Pace except my router, which handles all of my home traffic through the Pace).

I’m guessing here, but I believe that with DMZplus assigned to your Core, your Pace gateway may expect most of the connections to/from it to be from the Internet and not locally (again, only a guess here). Your Core is exposed directly to the Internet with a public IP address, and not sure if it can be assigned a local IP/LAN IP address (you can see this from one of the tabs;) I turned off DMZplus yesterday when I stopped testing for awhile, but while DMZplus was active my ASUS router was showing a public IP address from AT&T directly instead of a 192.168.1.x.

Given that you have only the Pace gateway acting as your router, have you tried creating a port forwarding rule to open port 55000 on the Pace gateway? This should work and also would be more secure as I don’t believe any firewall is protecting your Core if that is the device assigned the DMZplus setting.

1 Like

@Robert_F Thanks and I agree about the vulnerability using the DMZ plus setting. I may make another try to create a “Roon ARC app” that will limit the incoming traffic.

Please post and we’ll see what all of us can do to help you. DMZplus was my only option due to additional router, but I was able to make a Port Forwarding rule that included a TCP rule and an identical UDP rule for Port 55000. It just didn’t work with using two routers.

1 Like

@Robert_F and @connor, So, I’ve written two rules for the firewall. One for TCP and one for UDP as you suggested, then closed the admin program. ARC then showed proper configuration on iPad and Android. Then I left to run some errands. ARC on my android phone has frequent, lengthy pauses when using only a cell signal. Even when using a five bar strength and 5G signal and playing at low quality I could not listen to a song from Qobuz or one stored on my Nucleus using ARC. My cell signal at the Nucleus location is not great, only one or two bars of 4G LTE but this should not be the problem since this is an internet issue.

When I returned home I still had all my Roon end-points and they worked fine on the Regular Roon App. This was very good news.

FYI: Turning on the wifi when at home allows ARC/Android to play at high quality without interruption. Still don’t know if using a different wifi (like at a McDonalds or RV Park) would have a good result. Of course, I can play all the files stored on my phone using USB Audio Player Pro which is OK. And Qobuz MP3 streams fine on only two bars. I would like for this to work but it’s getting to be alot of trouble. Thanks for any help. John


Hi everyone,

Sorry I’m late to the party here - thank you @Otherford for jumping in with suggestions and to @Robert_F for following through so helpfully after working through your own setup.

@John_Kaster, we’re going to look into the timestamp when you experienced playback issues in Core logs, it should help us pin down if it’s just an upstream speed issue or if there’s a LAN issue throwing off Roon.

Thank you again for the precision and diligence here, everyone.

1 Like