Can’t find Roon Core Server

Core Machine (Operating system/System info/Roon build number)

Lampizator / SuperKomputer (basically an audio enhanced Linux box)

Roon 1.7, Build 537

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

ATT Fiber, into a ubiquity network with controllers and three WAPs

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Ethernet to computer and then USB to DAC

Description Of Issue

I just moved into this house, so the network And ubiquity system is new to me. It worked perfectly for about 8 hours and now, when I try to play music via Roon, I get a “can’t find Roon core” message after hearing a couple of seconds of music > then, I reconnect to the core and try again and get the same result. Happens again and again. I have rebooted the computer and the switch and the DAC multiple times to no avail. Maybe Roon was updated during those 8 hours, or ATT updated the modem firmware or ubiquity updated the firmware somewhere in the system, but I have no idea why it would have worked initially and now won’t work at all.

Not sure if there’s a port I need to open or broadcast/multicast setting I need to flip or what (and I don’t know what those words mean - I’ve just read them multiple times in trying to figure this out).

Thanks in advance. About to pull out the little hair I have left over this.

Hi, @James_Harvey, sorry to hear about your troubles. Could you, please, follow these instructions and share log files from your Core machine with our support team? You can do it via Google Drive/Dropbox link or if that does not work for you, we can find are more convenient method.



A post was merged into an existing topic: Nucleus does not read the hd

A post was split to a new topic: When i attempt to open Roon i get a message that the Nucleus Server cannot be found

Hello @James_Harvey, just checking in to see if you’ve had a chance to capture the logs Ivan was requesting. If you need help doing this please let me know!

I deleted and reinstalled Roon and that appears to have eliminated the problem (fingers crossed). I had to reindex all of my stored music, but not a big deal in exchange for a working streamer.

Spoke too soon and Roon has gone to basically unusable for me. When I play a new song, roon will lose the server (which is a linux box). Unbelievably frustrating. Here are the logs:

Hello @James_Harvey, thanks for providing the logs, I’ve sent them over to the team for further analysis! Also, if you haven’t already, could you please update to 571 and see if this issue still occurs? Thanks.

Yes, I have updated to 571 and it is even worse. Now, Roon is basically not useable for me. I used to be able to reboot the core between songs and play at least one song. Now, it won’t even play a song. Please please help - I have no music from Roon, despite a lifetime subscription.

Hello @James_Harvey, I spoke to our QA team again about this issue and we have some items to try so we can narrow down this issue:

  1. Can you please change your DNS to google or cloudflare? Let me know if you need steps for this.
  2. When this issue occurs, are any other apps having issues connecting to the network?
  3. Provide me with a network map of how your devices are connected? This could be something drawn on paper if you like, our team would like to take a look. Thanks!

I will change the DNS and let you know what happens. I have isolated it further, and figured out that it never happens when I am playing files stored on the SSD, but happens practically all the time with larger files streamed via Qobuz (192). It happens most of the time when streaming files at 96 via qobuz and some of the time when streaming 44.1 via qobuz. So, it’s a network/Roon thing, but I have no idea exactly what it is. I went into the ATT router and basically turned on and off every firewall setting I could find, but could not isolate it in that manner.

There are no other apps having issues connecting to the network. The network (ubiquity, with ATT fiber) is blazing fast and rock solid - EXCEPT for this issue.

The DNS change (to Google) did not help whatsoever. For specifics, Roon reboots EVERY time I try to play YoYo Ma > Not our first goat rodeo (HiRes file from Qobuz), but works perfectly with files from the SSD. It works pretty well, but sometimes reboots, when I try to play 44.1 files from Qobuz (e.g., Gillian Welch, Boots No. 2).

I have dumped the logs again and they can be found here:

Please advise. I have a world class system and the inability to stream hires files from Qobuz via roon is a real problem. Plus, my home wifi network (ubiquity) and internet provider (ATT) are pretty standard stuff - you will find both of those all over the US, so I suspect there’s an issue somewhere and you will have other users experience the same thing.

Thank you.

Folks at Roon - any update here? I have a totally standard implementation (ATT/Ubiquity), but can’t play hires streamed files. I’ve submitted two sets of logs. Is there anything else I can do to help you diagnose this problem? Just concerned as this makes Roon largely unusable.


Hello @James_Harvey, our QA team found some networking issues in the logs that led me to ask for the detail about your network setup, you can take a look below:

07/10 19:39:37 Warn: [broker/accounts] failed to refresh account info: Result[Status=NetworkError, ErrorText=Error: NameResolutionFailure]
07/10 19:39:42 Trace: [broker/accounts] refreshing account info for email='' userid=480091fc-a40a-4cae-8861-36a363c011a9
07/10 19:39:42 Trace: [fiveaccountserver] POST
07/10 19:39:42 Trace: [fiveaccountserver] BODY token=eb4dd346-82f7-4973-8b82-6165e3bbd081
07/10 19:39:42 Warn: Error in web request NetworkError (Error: NameResolutionFailure)
07/10 19:39:42 Warn: [broker/accounts] failed to refresh account info: Result[Status=NetworkError, ErrorText=Error: NameResolutionFailure]
07/10 19:39:42 Warn: [auth] EnsureAuthReady failed: Result[Status=NetworkError, ErrorText=Error: NameResolutionFailure]
07/10 19:39:42 Critical: [easyhttp] [1128] Get web exception without response: : System.Net.WebException: Error: NameResolutionFailure
  at System.Net.HttpWebRequest.EndGetResponse (System.IAsyncResult asyncResult) [0x00058] in <69f8661c94644655a06862d3e6b439f6>:0 
  at System.Threading.Tasks.TaskFactory`1[TResult].FromAsyncCoreLogic (System.IAsyncResult iar, System.Func`2[T,TResult] endFunction, System.Action`1[T] endAction, System.Threading.Tasks.Task`1[TResult] promise, System.Boolean requiresSynchronization) [0x0000f] in <cdba38a34a8b4bec95234c86d633b1ff>:0 
--- End of stack trace from previous location where exception was thrown ---
  at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () [0x0000c] in <cdba38a34a8b4bec95234c86d633b1ff>:0 
  at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) [0x0003e] in <cdba38a34a8b4bec95234c86d633b1ff>:0 
  at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) [0x00028] in <cdba38a34a8b4bec95234c86d633b1ff>:0 
  at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) [0x00008] in <cdba38a34a8b4bec95234c86d633b1ff>:0 
  at System.Runtime.CompilerServices.TaskAwaiter`1[TResult].GetResult () [0x00000] in <cdba38a34a8b4bec95234c86d633b1ff>:0 
  at Sooloos.EasyHttp+<QueryAsync>d__2.MoveNext () [0x00757] in <485401fcea794e2c92305b99d7430ec7>:0 
07/10 19:39:44 Info: [stats] 3703mb Virtual, 1497mb Physical, 466mb Managed, 0 Handles, 76 Threads
07/10 19:39:59 Info: [stats] 3703mb Virtual, 1497mb Physical, 466mb Managed, 0 Handles, 76 Threads
07/10 19:40:14 Info: [stats] 3703mb Virtual, 1497mb Physical, 466mb Managed, 0 Handles, 76 Threads 

I’d be happy to get a network map over to our team. Also, have you spoken with Lampizator about this issue yet?

Yes, I have been on the phone for hours with Lampizator about this. They believe that it does not have to do with the Lampi SuperKomputer and suggested I talk to you guys. I will forward this to them and see if it changes anything.

On the network map, what exactly do you mean and how do I capture it? I’m glad to do so, but just need to know what it is you are seeking.

I will forward this to Lampi and see if they can make some progress. Thanks.

And, apologies, but I can’t make heads or tails out of those logs. this is why I have Roon - so I don’t have to mess with these sorts of things!

1 Like

The only piece of Network Hardware not mentioned above is the Ubiquity UAP-AC-Pro, of which I have three (they are wifi access points).

The internet service is ATT Fiber, the fastest package I could buy in this area (right now, it shows as 999 Mbps down and 967 Mbps up), so it’s fast.

Please advise. I couldn’t even stream 44.1 files from Qobuz yesterday.

So, I didn’t know what you were asking for with a Network Map, but hope that this is it. If not, please just let me know and I will provide that information so long as it doesn’t compromise my network security.

Note also that the connection to the Lampi is via wired ethernet, NOT via wifi.