Can't connect to Roon ARC

Roon Core Machine

Roon core is on a Sonictransporter i9 updated to roon2
Mac OS Montery, M1

Networking Gear & Setup Details

ASUS AX88U
I’ve tried it with the VPN on and off

I’ve enabled port forwarding under the OPEN NAT setting. As far as I can tell, there’s nothing about UPn

Connected Audio Devices

PS Audio Directstream DAC
various sonos components
iPad
Audiquest Cobolt

Number of Tracks in Library

I have 138296 tracks (wow, that’s a lot isn’t it)

Description of Issue

Here’s the error message I get

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xxx.xx.xxx.xxx”,“router_external_ip”:“xxx.xx.xxx.xxx”},
“status”: “status”: MultipleNatFound
,
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“xxx.xx.xxx.xxx”,“found_upnp”:true}
}

2 Likes

Hi @soyka0120,

Thank you for posting and bringing your port forwarding issue to our attention. The 504 error in your diagnostic messages suggests that there’s a double-NAT layer at play here. You can read more about what that means in our Help Center article here.

If you don’t mind, can you provide the following details about your network setup to help expedite troubleshooting?

  1. Who is your internet service provider?

  2. Please list the make and model of your modem and router?

  3. Do you have any additional network hardware, like additional routers or managed switches?

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

  5. What machine are you using as a Roon Core, and how is it connected to the internet?

Internet provider: Century Link
modem/router ASUS AX88U
I don’t think I have additional network hardware, I do have networked switches to connect various audio system devices, such as the amp for speakers throughout house, according to the router app, I have 14 clients on the network

I have VPN tuned off for now

Machine: sonic transporter i9 connected with ethernet

Have to say though I’m semi-computer literate, I don’t get the double-Nat layer instructions.

Thanks for the quick response

A post was merged into an existing topic: ARC on Android Can’t Find Roon Core

A post was split to a new topic: Port Forwarding Timeouts with Asus RT-AC68U Router

Hi @soyka0120,

Do the settings within your ASUS web GUI resemble the following? These have worked for the team during testing, although with a different ISP:


Note for the port forwarding list in screenshot 3, internal testers were able to get things working without designating the internal IP.

1 Like

Everything is set up the way you have it here. I tried both the internal port shown in third screenshot 43043 as well as the one Roon keeps telling me to try 55002. It won’t let me leave the internal IP address blank, so I assume it’s the one for the router, not what you have in the screenshot. Still no connection, alas.

And this is the error message I get (not sure if it’s any different from the first one, but it is the latest)

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“71.51.182.115”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.50.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}
}

I have the same issue, massively excited to see mobile availability but of course I’m having teething difficulty…

{
“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“151.210.175.35”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“192.168.50.1”,“found_upnp”:true,“error”:“doaction request return statuscode: UnknownError”}
}

I have an Asus RT-AX88U outer running Mesh with an Asus TUF-AX3000

Roon core on NUC10 Hard wired to the router
Asustor NAS on the other Mesh Router
2 Degrees network in New Zealand

Tried manual port forwarding, UPnP is enabled, normally can muddle my way through these things…

1 Like

had a static IP address assigned - ARC recognised the Core immediately!

Hey @soyka0120,

Thank you for the information, and for your patience. To confirm, have you set your router into bridge mode?

Can you confirm that the IP listed at https://canyouseeme.org/ is the same as what your router reports it is? If you supply the port number that is configured in Settings>Roon ARC on that page, can it see you?

If not, something on the network or the ISP may be blocking ARC’s communication. If it’s an ISP-provided modem you may have to change some settings there. ARC will work on any port between 10000 and 65000. I might suggest another port or consult with your ISP on what if any ports may be blocked.

What’s listed on the site is not the same as my router. I can access my files using Roon Arc within my home wi-fi and download to my phone, outside of the house it doesn’t work. I’m a little clueless about all these router settings, I’ve already had to reconfigure everything back to default settings because changed something I shouldn’t. I have no idea what bridge mode is. The ASUS router is not ISP provided.

Thanks