Chromecast Audio dropouts


(Will W) #1

I had a 10 day trial to try with Chromecast Audio. Trying it with the internal DAC in Chromecast Audio it worked fine without any dropouts. If I connected the Chromecast Audio to an external DAC via it’s optical connection anything above 24/48k would have dropouts. I tried it with a Cambridge DAC Magic and the DAC in my OPPO BDP-105 and it had the dropouts with both. Not sure if it has something to do with the optical connection or something else. @support

Thanks.


CCA (Chromecast Audio)
Core shutting down when idle, and sometimes losing CCA group
Chromecast Audio sound quality
(Andrew J Shepherd) #2

Yes, I have experienced the same. Chromecast second generation via HDMI works fine. But Chromecast Audio via TOSLINK drops out periodically with 96 kHz. I do think it is a Chromecast output issue, as I seem to recall the Roon music counter not pausing but continuing through the dropouts.

AJ


(Dylan Caudill) #4

Hey @waggy70,

Have you tried using a different optical cable? If you can, give that a try and let us know if you notice any difference.

Thanks,
Dylan


(Will W) #5

I didn’t, but it’s a new cable. But my trial is up so I can’t unless I subscribe.


#6

I had the same problem with my Chromecast Audio. Dropouts with 96 kHz. Then I mounted the UGREEN Ethernet Adapter for Chromecast, since then the reaction of the Chromecast is much faster and the problem with 96 kHz does not exist anymore.

UGREEN Ethernet Adapter for Chromecast

Signal path with 96 kHz 24 bit

Signal path with 192 kHz 24 bit


Chromecast Audio sound quality
(Will W) #7

Thanks StereJo, I’m not sure that wifi is my problem but the ethernet adapter might be worth a try. I have no problem if I use the Chromecast Audio’s DAC, the 96k and above work fine that way. The problem comes when I use the Optical cable to connect the Chromecast to an external DAC, but I’ll try to get the ethernet adapter before my trial extension runs out to try it. My plan is to eventually build the Nuc Roon ROCK and use it to stream my music to my external DAC by USB connection to the DAC and that should solve the problem, I hope. Meanwhile I’ll try whatever suggestions I can that might help for now.

I did have 2 other Optical cables that I have tried with both external DACs and they work the same as the original cable I was using, still have the dropouts.


#8

So do I. Just a simple optical cable from Amazon, connected to my DAC. May be WiFi is the problem since the ethernet adapter solved it (for me).

My plan is to eventually build the Nuc Roon ROCK and use it to stream my music to my external DAC by USB connection to the DAC and that should solve the problem

Thats a good idea for sure. I run my RoonServer also connected via USB-cable to my DAC, the sound is great and I never recogniced any problem.


(Will W) #9

Thanks, I will order it and try it.


(Raquillet) #10

I have the same dropout issue. I have the ethernet adapter installed, a van den hull high end optical cable connected to a DacMagic. With the Chord Poly+Mojo combo no dropout at least up to 192khz, I have not tested it above. Is the dropout a Google issue ? I hope Roon can have the problem fixed because this device is so useful.


#11

I think so. But dropouts occurred only with 96 kHz and WiFi. With 44,1 kHz I never had Problems, even with the WiFi connection.

I hope Roon can have the problem fixed because this device is so useful.

It is really a useful device. Even my old kitchen-ghettoblaster runs (thanks to chrome audio) on roon :wink:


(Will W) #12

The Ugreen Ethernet adapter didn’t solve the problem for me, still get the dropouts with it connected by Ethernet.


(Dylan Caudill) #13

Hey @waggy70,

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

Thanks,
Dylan


(Will W) #14

Hi Dylan,

I’ll have to try that a little later, but what I did last was put my notebook by my audio system, installed the Roon Server on it and connected it by usb to the OPPO’s usb connection and that works perfectly over WiFi… leads me to believe it has something to do with the optical connection on the Chromecast Audio. But I’ll reconnect the Chromecast Audio by optical a little later and let you know what time the dropout happens.

Thanks for trying to solve this.


(Will W) #15

Hey Dylan,

Ok, the Chromecast Audio was connected by Optical cable and had the first dropout at 2:02 pm CDT.


(Darko.Audio contributor) #16

I’m getting the same problem. Music plays fine for about two minutes then hangs. Much the same feel as when my aging Roon core can’t keep up with the upsampling I’ve set it and runs out of buffer (it can manage DSD 128 just about but not 256).

Hence me thinking it could be a core issue (ie not enough horsepower, not a Roon issue per se). I could well be wrong given what others are experiencing though.

My CCA is going optical into a Meridian F80. Sounds great when it’s working.

Phil

edit it works fine via its internal DAC


(Dylan Caudill) #17

Hey @waggy70,

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.

Thanks!
Dylan


(Pedro Sousa) #18

Greetings to all,

I am new to all this, but I can report I have the same problem.

I have Roon Rock running on a NUC7i7, wired to a UK BT router version 5, and then wireless to ChromeCast Audio (I have tried 2.4Mhz and now its on 5Mhz, cannot precieve any improvement). ChromeCast is linked to a TAG AV32R pre-amp by optical connection.
Both 96khz and 192khz (which Roon downsamples to 96khz as expected) ALAC files, show dropouts randomly when playing. Same song can play with or without dropouts. I have tried to reduce activity on the network as much as I can (turn iPhone and iPad to plane mode), but I still have events from time to time.

44.1khz works just fine, both with lossless ALAC and also some ACC compressed files.

I hope this helps.

Bests


(Will W) #19

Sounds exactly the same as my experiences with Chromecast Audio. Maybe Chromecast Audio is Roon Ready if you only use it’s internal DAC which works with the 96k files. Maybe it’s a problem with Chromecast Audio and it’s optical connection. At any rate it doesn’t seem solvable, I haven’t heard from the tech support tests that Roon did.


(Dylan Caudill) #20

Hey @waggy70,

The team is continuing to investigate this, and I was hoping to get some additional information to help out the team. First, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Just to verify, are you able to play the same content to these other DAC’s when not using the CCA without issue?

Thanks,
Dylan


(Will W) #21

I have Spectrum internet, Google WiFi router connected to CCA by wireless and the same content plays fine without the CCA in the mix going to my laptop as the roon server connected by usb to the OPPO BDP-105 USB DAC over WiFi.