Connecting to Auralic Aries

Core Machine (Operating system/System info/Roon build number)

Windows 10 Pro / Roon 1.6 build 416

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Wired network for all devices - Auss Router and netgear switches

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Auralic Aries
Auralic Aries Mini x 2

Description Of Issue

I have just install roon on my PC and it does not seem to find all of my Aries devices on my network (and the one it finds does not show the name just the fact that it is an Aries Mini). Any suggestions for a newbie.

ASUS Routers

We recommend enabling “Enable Multicast Routing” option in settings.

Are the Netgear switches unmanaged? They should be or that could also be a problem.
For starters, also temporarily turn off firewalls and other such software (e.g. bitdefender).

Thanks for the suggestions. The Auralic software manages to find all of the devices with out issue!!? I have disabled the firewalls and roon now finds the other Mini but still cannot find the Aries which I also have. The two Minis are working off the same switch so not sure why the firewall setting would have done anything but maybe it did… I’ll do a re-boot on the Aries and see how it goes… Roon is still building my library at the moment hopefully finished soon…

Have you found these problem/solutions for Auralic Aries?
I’m not familiar with the Aries, but it seems you need to set up RoonReady as a mode in the Lightning DS settings, and if using with a USB DAC, the DAC needs to be switched on. This seems to be a problematic area for several Auralic Aries users.
Note, I’m just a Roon User and Roon Technical people will help you with follow up and more comprehensive support.

Thanks for all the suggestions but none of them seem to be working. I have tried rebooting the Aries and still no luck. I also installed another Aries Mini on the same Network Switch as the Aries and that cannot be found either. I have just plugged in a Mini on the same switch as the PC running core and it still cannot be found (yes the roon setting is correct on the Mini)… I have also just unplugged the Mini and replaced one of the Minis that was working and still cannot find it… so it looks like it is something to do with the aries and third Mini rather than my network…Just tried one of the Minis that worked in the same switch as the one that doesn’t and no luck… so definitely looks like it is something to do with the Aries and third Mini…

Hi @Paul_Riordan,

If you connect both the Core and the Aires directly to the router, does it show up then? Sometimes managed switches can cause issues with Roon (not sure if you have a managed one or un-managed), but regardless I would like to temporarily remove the switches from the equation.

@noris Hi - I have both managed and unmanaged switches on my network - I had the Mini that roon does not find and the PC with roon running on it on the same switch and still had the issue but when I plugged in one of the Minis that seems to work I had no problem whereever on the network I put it. So I have two Auralic devices that work fine wherever they are and two that don’t (one mini and one Aries)… The switches in the chain are all unmanaged. I have router -> unmanaged switch -> unmanaged switch.

It may be worth trying to see if the Aries can be seen wirelessly as a way to ruling out the unmanaged switches as the issue?


Hello @Paul_Riordan,

Are you able to see the “missing” AURALiC devices under the Airplay tab in the Settings > Audio screen? If you are unable to discover them in the Airplay tab, your network is failing to pass multicast traffic your Roon Core.

The best way to troubleshoot issues like this is simplifying your setup and working outwards from there. I would start by removing all of the network switches from the equation and connecting your Roon Core to the same router as one of your AURALiC devices. Once you are able to get the Roon Core <-> Router <-> AURALiC setup stable, you can start adding in the switches and determining where this failure is occurring.

@Sloop_John_B’s suggestion that you try using the wireless connection for the AURALiC devices would also shed some light on where in your network this issue is occurring.


I’m assuming this is Asus router. You might need to switch on multicast.

I have switched on multcast and it makes no difference… Its is still odd that two of them work and two don’t no matter where they are on the network etc… I’ll try plugging the offending Mini and the core pc directly into the router later (not quite as simple as it sounds…)

Well I am not quite sure why but everything is now up and working. Everything was reset/switched off and then I re-installed and defaulted everything all all now seems to be working - thanks everyone for your input.

My wife was playing with Roon last night and loves it…


Well, what makes Roon “unique” in its class is its use of multicasting. I don’t know the specifics, but it’s basically a way for the host and clients to yodel at each other and come to understand who will be talking to who during subsequent data transfers.
It could be the case that when you first booted up you had problems with a firewall and/or improper multicasting. Some clients (Aries) had been found and some weren’t. Those that had been found remained identified as you moved them around, and those that hadn’t, weren’t subsequently found.
You may need to have a proper boot sequence with the firewall/multicasting properly employed such that when each client came on line it could yodel to the host and be recognized.
I don’t really know. But networking problems are particularly an issue with Roon because of these additional communication requirements. You may need to keep this in mind as you re-enable a firewall. If your switches are unmanaged and the router continues to use multicasting you should continue to be okay there.
Glad you are up and running. Enjoy the music and welcome to Roon!

Hi @Paul_Riordan,

Thanks for the update here and glad to hear you’re up and running! If there any additional issues do feel free to reach out to us again. Thanks!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.