Cover problems on remote


First my setup:
My Core machine is the sonicTransporter i7 which is connected via a switch to the modem/router Connectbox the Arris TG 2492LG and the Fritz!box 4040 router. The sT7i and Fritzbox are connected via the same switch and are set up to form a single network. Both devices have a router function and the Fritz! Box provides the WiFi.

Since a month my remotes on an iPad and iPhone have had problems with the covers. They are often invisible. It always changes. At startup all covers are sometimes missing or some covers are visible and others are not. The covers of Qobuz that appear in the recommendation list suffer the most from this. However, the covers of the hard disk files have also sometimes disappeared.
This is clearly visible in the three attached photos. I made them one after the other within 5 minutes with every time a restart of Roon Remote.

This first picture shows the screen after starting for the first time this day.

The next picture shows te screen after restart and choosing a file to play and looking back to the overview of albums. These albums are existing files on my harddisk.

The last picture shows the screen after a new restart:

I I have read other topics dealing with similar issues but I don’t see any solutions that work for me. Hopefully, there is someone who knows what’s going on here and can help solve this problem.

Thanks in advance, Bert.

Hi @Bert_Dijkstra,

Does this appear this way on all remotes or just or just th iOS devices (i.e. does this happen with a Windows or Mac remote)?

If you go to Settings > Setup there are some options related to image caching. First, try choosing Clear Image Cache. After this, try increasing the Memory for Photos/Artwork option.

Let us know if that helps!

Hello Dylan,
It does only happen on my iOS devices an iPad Pro 10 2018 and my iPhone SE. My Windows PC with LAN-connection and my Windows laptop with WiFi-connection doesn’t have those problems.

These actions doen’t have any result. I did try it several times.

Thanks for giving that a try, @Bert_Dijkstra.

When the album art is not showing next, can you go to to the Album Edit screen for one of these albums and share a picture of the artwork section?

Hello Dylan,

No cover from a music file from my drive in the overview, so I tried your suggestion.
This is a screenshot of the result:

No covers at all…

Just an other screenshot from a speedtest with my iPad:

Thanks, @Bert_Dijkstra.

I have enabled diagnostics on your account so our technical staff can get some more insight into what’s going on here. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers. I’ll be sure to follow up once we’ve analyzed the report and have further feedback.

Hello Dylan,

I’m not sure what you mean by this. My Core is installed on the sonicTransporter and it is always turned on. Is that what you mean with active or should it play music?

Hi @Bert_Dijkstra,

Since the Core is always active the diagnostics report has come through for the Core machine. I’ve also enabled them for the remotes but I haven’t seen them come in yet — When you have a chance can you try connecting your iOS devices experiencing this issue to your Core (just opening up the Roon app so it connects) and let me know when you’ve done so?


Hello Dylan,

I just opened my remote on the iPad. All covers are present now.

Succes with finding the problem, Bert

Hello Dylan,
Roon just lost connection with the Core. 20:34.

20:36 Restart Roon on my iPad and everything is OK, all covers are there.

Started Roon from 12:40 and no covers in overview on my iPad. After that I restarted it several times. The disappearance of covers is completely random. Even my profile picture disappear sometimes.

I had all the covers on my iPhone at 13:02. After a restart of my iPad I also have all covers there. What strikes me when the covers disappear is the following:

  1. I start the remote, Overview> Sorted by Artists, all covers
  2. I choose an album to play, next to the tracklist is the list
    recommendations, mostly Qobuz albums, but without
  3. I go back to Overview> Sorted by Artists and when I continue
    scroll the covers have largely or completely disappeared from the
    album I chose in step 2.
    This also happened on my iPhone. If I do not do step 2, the covers will remain visible and if I do then chances are that the covers have largely or completely disappeared.
    Perhaps this information will help solve the problem.
    I don’t know if it keeps going this way but today I can repeat this procedure over and over with the same result.
1 Like

Hi @Bert_Dijkstra,

I just wanted to reach out and confirm that the diagnostics report was received and I’ve scheduled a meeting with the QA team later this week to get their feedback on this. I’ll be sure to reach out as soon as I’ve met with them.

Thanks Dylan!

Has there been a clear finding on this issue? I am asking because I have a buddy having similar issues (Innuos ZEN, no covers visible on the iPad, all covers visible on the iPhone).

Hello Torsten,

We are not yet out. This topic now continues via a private topic, but I will definitely post the result here. So be patient.

Regards, Bert.

A post was split to a new topic: Covers not appearing on remote app

Hey Max,

I don’t know what’s going on, but I no longer get responses for support.
Unfortunately, the problems have not yet been resolved. The connection to the Core regularly drops and the covers are often disappeared when starting the remote on the iPad. What does help: always go to an overview page before closing, when you start up again the covers are usually all present. If you close on an album page and then start up, the covers are usually gone. Maybe this is an indication of the problem.
It would be nice if someone (Dylan?) from the support wants to get back to work with this problem.

Greetings, Bert Dijkstra.