Database Backup Again

Roon Server Machine

SonicTransporter i7

Networking Gear & Setup Details

Virgin Hub to Eero to SonicTransporter to eero to English Electric switch to Network Acoustics Ethernet filter system to Bricasti M21 DAC

Connected Audio Devices

Bricasti M21 streamer/DAC connected by Ethernet

Number of Tracks in Library

32047

Description of Issue

Was backing up database to Dropbox but have discontinued Dropbox as have free access to Box. Trying to backup to my Mac, to a HD attached to my Mac etc… All driving me crazy. Despite following instructions for file sharing permissions on my Mac, correct path, constantly being told I’m not authorized. Have no idea what to do other than give up. As many have said, if only you could make Google Drive, iCloud Drive or Box available - I have these three different backup locations, none of which can be used.

Did you follow these instructions

Alternatively you should be able to plug a USB hard drive into the server and backup to it.

I followed instructions scrupulously. I cannot use a USB drive on server, because my Library is on a USB drive attached to server which will support only one USB drive.

Maybe a small (cheap) usb-hub can help you out?

No, the SonicTransporter has four USB ports, and I can attach a second USB drive, but only one can be mounted at a time. I should say too that when I follow the shared network instructions to save to a folder on my Mac I get an Unexpected Error message every time. Which isn’t very helpful!

I would call and ask Small Green Computers, because, that doesn’t sound right. The computer should be able to access drives of any sort attached to any USB port unless they have done something unusual.

Anyway, while I’m not a Mac person, one step which is not there is to create a file backup folder first. You don’t want to choose and existing folder and it cannot be part of your music file location (remember this backup is for the database only NOT music files).

So, create a new folder on your Mac and call it Backups_Roon. All one word, no spaces.

Then proceed with the steps. Make sure that you have reviewed gotchas, like it has to be a local account on the Mac. also, any spaces in your username or password might cause issues. If you have these, then I suggest creating a new local account called “RoonBK” and giving it a password.

Thank you for the response. SGC actually specifies on its site that only one USB drive can be attached, so alas that route is closed. I have done as you say and continue to receive the message ‘There was an unexpected error’.

Can you post screen shots of the network location setup page and maybe the MacOS storage sharing settings page. BTW, I am a fellow user and Windows guy so my MacOS knowledge is a bit light.


Here the network setup. I’ve tried with and without name/password, have tried with just the computer address, with its name (Mac_Studio) instead, with and without ‘share’. The file sharing has been set up for the full chain down to a folder title RoonBK in my Music folder (I’ve also tried that full address in the location setup page even though it states the directory is unnecessary. I’m the only user of the computer, and am the administrator.

Yes, this is all correct except that I don’t have ‘roon’ for user but my name instead. Don’t know how I would get ‘roon’ for user.

Did you also check the original post?

You can create a new user called ‘roon ’, but check ‘sharing only’ (or similar). Doesn’t matter though, if you’re an admin, it should work with your username/password.

Yes, all as suggested, except I haven’t created a user named Roon - as I’m the admin and sole user.

I found that it would work for me if I allowed sharing (Cmnd+K etc) of the one folder - in your case just ‘share’ - and then your Network share location would be:

smb://192.168.4.99/share

It seems to know where to look.

Then use your machine’s account’s user name and password; if required.

Thank you Mark. Just tried that. Alas, no dice. Still get ‘unexpected error’

1 Like

I went through something similar until I got exactly the right match between the specific directory I was sharing and the one I used in that setup dialogue in Roon’s.

So what happens if you

  1. remove the share completely
  2. create a new hierarchy - outside ~/Music - just in case Roon is confused by the option to have that as your default watched directory: say ~/RoonBackup
  3. set that up as your only share
  4. in the Roon dialogue use:
  5. smb://RoonBackup

?

Thank you all for suggestions. It appears there’s a recognised problem with Mac Studio computers and their inaccessibility on a home network. I just have to hope that an update sorts this…

John,

Would you mind providing more details, please (by all means feel free to message me, if you prefer): I’m contemplating getting a Mac Studio as my next machine… currently I have a ‘Late 2017’ iMac Pro.

Thank you.

Hi @John_Wilkinson1,
Can you provide a screenshot of your sharing settings?

Thank you for the inquiry. Just a few days ago I succeeded in backing up to my SonicTransporter, a big sigh of relief… I suppose the trouble with that might be all my Roon eggs are in one basket? Anyway, here are settings for Mac Studio.