Did 2.0 break Discover?

Roon Core Machine

2.0 Server on Windows 10
i5 2.4Ghz

Networking Gear & Setup Details

CommScope CGM4331SHW TG4482 router/modem from ISP in Bridge mode
Archer AX55
Ethernet to core

Connected Audio Devices
Pi4 HifiBerry
MacBook Air MacOS 12.6
iPhone 13 iOS 16
Hiby New R6 Android 9
Samsung Tablet Android 12
2 Yamaha AirPlay receivers
2 Google Chromecast speakers.
I generally shut down controllers or endpoints not in use.

Number of Tracks in Library


Description of Issue

Discover no longer works.
I see the Roon icon pulsating infinitely
I switched from the full install to Server about a week ago and upgraded to 2.0 on launch day.
Discover was working previously but I hadn’t used it since changing to Roon Server.

The Roon icon pulsates but nothing else happens.
Is it working for anyone else?

Hi Jeff,

Discover is working for me! Have you tried rebooting the core and trying again?

Screen Pic below:

It’s working for me as well.

Unlikely I use Roon server and can still get Discover.

Perhaps post in support with full details of your system and see if you get some help there.

Yes, it doesn’t work for me anymore either.

Core: Rock, Ealyaccs 2.0, build1119
remote: Android Phone, Samsung Galaxy FlipZ 3, roon 2.0 production, build 1127 (“discover” doesn’t work")
remote android, Samsung Galaxy Tab 7 FE, roon 2.0 production, build 1127: (“discover” doesn’t work")
Windows 10, 64bit remote, roon 1.8 build 1021: (“discover” doesn’t work")

to be honest. the mess is irritating.

@Rudiger_Birkemeyer @Placebophile

Do you have Daily Mixes?
Does it work if you switch Profiles?

I had a similar issue some time back but I lost both discover and Daily mixes which is why I ask. Switching profiles worked for me but creating a new profile did not.

Yes. I have daily mixes.

I only had one profile.
I just tried making a new profile but, as you suggested, that didn’t help.

I only have a local library.
roon doesn’t give me the option of “daily mix”
(maybe because roon is only interested in streaming customers? ) :face_with_spiral_eyes:

I have two profiles, but switching doesn’t change anything. “Discover” still doesn’t work

Greetings @Support

I appreciate you’re very busy helping folks with bigger issues than mine and by all means, take care of them first.
But I’d really like to be able use Discover again at some point so I’m giving this thread a Simple bump so you Don’t Forget About Me. :sweat_smile:


1 Like

@support Any word on this? Thanks.

I also have this issue it seems

Hey @Placebophile,

Thank you for your continued patience here! And, you have my sincerest apologies for the long delay in following up. The team and I are digging into this more deeply, and I wanted to confirm: are you seeing this issue happen across all your roon devices? Or, only your Windows 10 core?

By chance, do you have another machine you might be able to test as another core to see if the issue occurs there as well?

With that, can you simplify your setup and only stream audio from the system output of your Windows core (disconnect all else) and let me know if this issue persists?

We’ll enable diagnostics in the meantime to take a look at your Roon logs and see if there is any evidence pointing to what might be causing this issue :+1:

No worries. I saw how wild things were getting here for a bit.

I only have the Win 10 machine the core is on and another Win 10 PC.
I do have a MacBook Air that will probably still run Roon (it used to be my core) however my music library is on an NTFS formatted USB drive.
So I don’t know if that will help us here.

Oh, yes, I have this issue on all my remotes.
MacOS, iOS, and Android.
The core is running Roon Server.
Although as mentioned above, it used to run the full Roon.

Hey @Placebophile,

Thank you for the info. As a next step, let’s start with refreshing your database.

  • Create a Backup of your current database
  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if the issue persists on a fresh database before restoring the backup

Let me know if your issue persists after the above :pray:

From a fresh database Discover works.
After restoring the backup Discover shows the infinitely pulsating Roon logo again.

Hey @Placebophile,

Thank you for giving that a try! It sounds like there may be some minor corruption happening on the specific database backup you’ve loaded up.

If possible, could you try using an older backup that may pre-date when you noticed this issue take place? If you’ve made any major changes to your database settings recently, you may need to take note of the changes and repeat any necessary changes to the older database after it’s been loaded.

I’ll be on standby for your reply :+1:

Thanks for your continued support.
I rolled back to my oldest 1.8 backup and my oldest post 2.0 backup.
Neither helped. :disappointed:
I realize correlation isn’t causation but this seemed to start right after updating to 2.0.
Is there anything else we can try as I’ve made 100s of edits going back years and it would crushing to lose that.


NUC with ROCK als Core.
Version 2.0 (build 1137) earlyaccess

NUC with ROCK, Streaming Client, USB → DAC,
Version 2.0 (build 1133) production

remote: Android Phone, Samsung Galaxy FlipZ 3,
Version 2.0 (build 1133) production (“discover” doesn’t work")
remote Android, Samsung Galaxy Tab 7 FE,
Version 2.0 (build 1133) production (“discover” doesn’t work")
remote Windows 10, 64bit,
Version 2.0 (build 1133) production (“discover” doesn’t work")