DSM7 - can't enable Audio device

I can not update the latest roon server RoonServer_Synology_DSM7_x86-64_20210727-beta.apk on my DS918+ with DSM7.0-41890.

I have specified all my “Shared Folders” with “read/write” permission to the RoonServer user, but still the same error. Any solution?

Thanks again!

Can you try to uninstall your currently installed version and perform the installation again?
The installation wizard should take care of the permissions. The infowindow is only relevant, if you need grant access to additional shared Folders.

Yes. I have backuped my roon library, uninstalled the older version, then try to install the new version. It still get the same error.

I have granted r/w pemission of ALL folders for RoonServer user, it didn’t work.

thx

Dear C.Rieke,

After following your instruction, I successfully made Roon Server running on DSM 7.0. However, all my audio devices are enabled but not selectable, whether it is wired or wirelss.

I have rebooted all devices: NAS/Router/Mac, and reinstalled Roon on MacOS.

Any suggestion?

thanks again!!

Hi @Yasmina_Lee,
I have not noticed this so far. I am currently unsure what might cause this behaviour.
Do you have a firewall in enabled?

Can you forward your log files to me if the issue persists?
(they can be found under / < YourDatabaseShare > /RoonOnNAS/RoonServer/logs )

Here is the log zip file.
Thank you!

– Link removed –

Hi @Yasmina_Lee,
I have downloaded your log files and removed the link from your post, so it Is no longer publicly available. I also shifted the conversation into its own topic.

According to your logfiles, It seems there is still an issue with privileges.
I was wondering, if you have enabled any special permission settings in your DSM. I am thinking about the “advanced Permission” tab of your Roon Server database shared folder.

(This is how it looks on my RoonServer database shared folder:)

Best
Chris

Hi Rieke,

I didn’t set anything in “advanced permission” tab.

The RoonServer folder is set to R/W for System Internal User “RoonServer”

By the way, I found that my iOS device works now.

But on my MacOS, if I enabled both “System Output” and “Apogee Duet USB”, Roon said “No audio devices found”. Then when I disabled “Duet USB”, “System Output” shows up and the music plays. But the track thumbnail, playbar and waveform will not change if I forward to next track.

All these information refreshes when I disable/enable “System Output” again.

best,
Yasmina

Hi Rieke,

I reinstalled RoonServer_Synology_DSM7_x86-64_20210727-beta.spk again.

After reinstall, Roon on MacOS can not connet to Roon Server on NAS.

I need to uninstall Roon on MacOS completely by using CleanMyMac, then download Roon Mac version, reinstall and it connects.

But the audio device problem is still the same.

And I also found that I can not backup my database.

Best,
Yasmina

Hi Rebeka,

Finally I decided to start from scratch, deleted my RoonServer directory, uninstalled both RoonServer and Roon on MacOS, and reinstalled everything.

Now it works.

Thanks,
Yasmina

I have a theory, what was happening on your DiskStation and wanted to send you a modified spk to verify. Do you still have the old database to check?

Hi Rieke,

Sorry I didn’t save the old database. The backup one seems broken. Nevermind and thx!

:sweat_smile:

Hi
I do have the exact same problem: audio devices enabled but none can be selected.
I have updated a DS918+ to DSM 7. Uninstalled old Roon package and installed beta version 20210727.
Any idea what I can try?
Thanks
Dirk

Update @crieke
I have a lot of such lines in the log file at RoonServer/RoonOnNas/RoonServer/Logs

08/02 18:18:19 Debug: NotifyCorruptZoneDatabases Exception LevelDb.Exception: IO error: /volume1/RoonServer/RoonOnNAS/RoonServer/Database/Core/34d652113a194d399c00aa17041d43e6/transport/zone_16010737d24f656a0ba48ee7021d4a11dc00.db/LOCK: Permission denied

I have, with Syno interface, removed the permissions for RoonServer account on RoonServer directory, applied it and set it again and re-applied. Roon was stopped during this, after launching I can now select 1 device, all others I still can’t.

Hi @Dirk_Daems,
Thanks for your report.
I assume this is caused by the owner and group of the RoonServer directory.
I already tried to add this to the installer, but apparently the installer does not allow the chown command. I am looking for a way to adjust the owner from root (which was the database owner in DSM6) to RoonServer (as it is now on DSM7).

You can try the following in the meantime:

  • Stop Roon Server in the Package Center
  • Open FileStation
  • Right-Click the “RoonOnNAS” folder and select “Properties”
  • Click on the “Permission” tab (You should see RoonServer with “Read & Write” Permission
  • Click on Create
  • Start typing “RoonServer” in the “User or group” field and select RoonServer from the filtered list
  • Leave Type on “Allow”, Apply to “All” and select all Permissions on the bottom window and click “Done”
  • Check the “Apply to this folder, sub-folders and files” checkbox and click “Save”.
  • Start Roon Server again.

Best
Chris

Hi @crieke ,

With your procedure everything is back to normal :smiley:

I’m also able to make again (obvious probably) a backup of the database.

Let me know if I can help any further with tests or others.

Thanks
Dirk

Thanks for the feedback, @Dirk_Daems,
Good to know it was acutually caused due to ownership of the previous DSM6 database.
I will check for other options to change ownership of pre-DSM7 databases during installation.

Same issue here, thks for the tips and procedure. Now it works fine.

I have found a solution to this issue.

As mentioned before, this happens because Roon Server has been running as root user on DSM6. The root user is actually allowed to do everything.
This has been limited on DSM7: App Packages have their own user now with limited capabilities. For Roon Server on DSM7 there is a new internal user called RoonServer.
I can give permission to read and write on a specific shared folder to this user, but I can’t delete or modify files by the user root. Because of that, I also can’t modify the ownership of the DSM6 Roon Server database.

As I have grouped all Roon Server related files in a parent directory called RoonOnNAS, I came up with the solution not to move the folders from Roon Server on DSM6 into the RoonOnNAS folder anymore. Instead I will copy them to the new RoonOnNAS directory. By doing that, the files are owned by RoonServer afterwards and everything should be fine.
The old directories from the DSM6 installation will be moved into a directory DSM6_RoonServer_Database_Backup. It will also contain an info file about this folder:

Will test some more and then release it.

1 Like

Hi
I am ready to upgrade my Synology NAS 718+ running DSN 6.3 to a new 918+ that will be running DSM 7
Is the new installer ready ?
Thanks

yes a new version (20210809) is available here: RoonOnNAS – Use your NAS as a Roon Core