Having trouble with ARC setup

And of course nothing works as it should :angry: Setting up ARC is impossible for not highly skilled network engineers. Getting my Intel NUC in a few days. Maybe that will help to install ARC.

Very happy with the new 2.0 feature and ARC. Hopefully I can use it some day…

Hi @RM_Kamphuis ,

I’ve split your post into a separate thread so the team and other users can assist you more directly. Typically, errors like the one you see can be caused by a misconfigured Port Forwarding setting, if you are not seeing Ready listed in Roon Settings -> Roon ARC, please look over this guide before proceeding.

If you have reviewed this guide and still have not resolved the issue, can you provide the following details about your network setup to help expedite troubleshooting?

  1. Who is your internet service provider?

  2. Please list the make and model of your modem and router?

  3. Do you have any additional network hardware, like additional routers or managed switches?

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

  5. What machine are you using as a Roon Core, and how is it connected to the internet?

Thanks!

I had to go into my Router and set up a VPN. I also am no network engineer, but I followed my nose…

Hi Notis, be advices that 99% of Swedish ISPs only offer CG NAT IP addresses which won’t work with the ARC solution as you can not control the port forwarding.

Thanks for the swift reply Noris! Much appreciated. I will come back to you after I installed my Intel NUC with ROCK (which I will receive in two days). After moving the core, I will try to use ARC again. For now it is too much to try out and I don’t know where to start. I presume the NUC will be much more transparent in this regard.

Kind regards,
René

1 Like

You can request a static, dedicated IP from your ISP provider usually, for an additional small fee. This way ARC can work, even with a CG NAT situation.

Having the NUC hardwired into the router may help, but if your router doesn’t support UPnP, you’ll need to configure this manually, even for the NUC Core.

Thanks, true for some ISPs and i hope this issue are deferred when IPv6 addresses are released from certain ISPs

A post was split to a new topic: Port Forwarding issue in the UK

As long as it is a non CG NAT public IP address you should be fine. Check your wan interface IP and do a “what’s my IP” google search and compare the two, are they the same all should be fine. As for the dynamic part it all comes down to lease time and how your port forwardings source IP imay be configured.

4 posts were split to a new topic: Port forwarding issue on Netgear R7000

A post was split to a new topic: Port Forward 504 Unknown Error

A post was split to a new topic: Fritzbox with QNAP Core Error

Maybe, after finishing the nuclear reactor in my backyard, I’m able to set up Arc and help you with it, having exactly the same error here…

5 Likes

With my current ISP architecture (in Thailand), I unfortunately cannot use the Roon ARC either. Anyway it’s a good feature and I’m looking forward to solutions the Roon dev team will bring about. I understand that you are working on the ipv6 support?

In the mean time, is it possible for Roon ARC app to have a setting for us to manually enter a domain name and port for connecting back to Roon Core ourself? The ISP let me configure this kind of dns/port forwarding on its web. And I’m using this mechanism to connect back to my home camera and also to my ebook library (Calibre) successfully.

Thanks.

1 Like

I know how you feel, it’s frustrating beyond all things. If you can find a computer literate friend, you won’t look back.

Been through all of the help and troubleshooting, and my findings are my ISP is using NAT IP, seems to be a common thread.

I work in IT and tracing all of the settings to get this far is not easy at all. Asking people to go to into their routers advanced config and having to ask ISP’s for a private IP to get your new feature to work is pretty poor form Roon. My ISP charges $10/month for a private IP, which is an additional $120/year on top of the cost of Roon, yeah nah bro.

I’d rather not have an option than one that makes my music life feel like I’m back at work. I hope you’ve hired an extra 5 support staff for all of the support tickets you’ll get from this.

Roon ARC app deleted, Tidal app working first try.

4 Likes

Dear Noris,
Roon is working on my Intel NUC. Still no connection with Roon ARC. Here are my details:

  1. ISP = XS4ALL (now KPN)
  2. Router = Fritz Box 7581
  3. Additional = MESH network Netgear Orbi RBR50 (one base, one satellite)
  4. No VPN, proxy server or other security
  5. Intel NUC8i5BEH, wired to Orbi Satellite
    Hopefully you can give me some advise on this…

Kind regards,
René

I have the same issue. All Roon need to do is have options to enter external address and port to access Roon from outside.

Saying this, I also use Plex built-in feature, which will auto detect my current IP address, sent this information via Plex to my mobile device app. I can access all my movies from anywhere easily.

So jealous of all the people enjoying their Roon ARC outside of their houses… :pleading_face:

Hmm, Orbi RBR50

Just curious, what’s your endpoint? And where is it plugged in.

I’m wondering (though it shouldn’t matter) if mesh networks using WiFi backhaul could be also a factor to some issues.

If your Nuc is in the satellite and endpoint in main unit can you try an Ethernet backhaul by temporarily moving them to the same room.

Have you tried having both Nuc and endpoint plugged into the main Orbi unit?