HiFiBerry Digi+ Pro - Recognized by Roon Core but doesn't play [Resolved - New Router]

Hi Roon support,

I am a newbie and I need some help to solve the issue I have with the HifiBerry in my system.

The Roon core is installed in my Samsung series 9 - Windows 10 - ie5 core - 8 GB ram - 64bit OS.
The PC is connected to my LAN in wifi
The HifiBerry (Roon Ready) is cable connected to the router
My library with more or less 4000 song is in SSD hardisk connected to my PC
I installed the Roon Remote in my mobile and is working well with the core

The HifiBerry is recognized by Roon core and the library as well but when I click “play” there is no output and after few seconds I receive the message: “Roon: an audio file is loading slowly. This may indicate a performance or hardware probem.”

I received the HifiBerry with the RPI3 as a kit with the microSD already flashed with the V. 1.0.4. I tried with another microSD flashed with the latest V. 1.3 but with the same result.

Below is a picture of the error message… thanks for your help in advance!

Best Regards,

Have you allowed the analysis to complete?

Hi Tony,

Thanks for your reply but I don’t understand… what you mean?

Can you – if only for the sake of debugging – hook up the PC with a network cable and see how things behave?

You are right, I didn’t think about… anyway, just hook up the pc to the router but the result is the same


Tony, thanks for the link.

The analysis it’s ongoing but is really slow even with “4 cores” setup.
As far i understand even if the analysis is not completed the file can be played?

I also noticed that the analysis is repeated from the first file as soon Roon is shutdown and restart. It’s that normal?

I noticed that because 2 times happen that the screen become “white” and I need to restart the application.
I don’t remember where I read, maybe in this forum, that someone have a similar problem… I will check

Yes. Analysis computes the waveform in the play bar (it will be absent if the file it not yet processed) as well as the Dynamic Range value. But sure – you can play all tracks while analysis is still going on.

The analysis process just picks up from where it was when Roon was shut down.

The first run (when Roon is analysing all of your files is quite intensive. You can turn it off temporarily if you want to play with Roon now (this will also give a clearer view of the problems you encounter with your Pi). Just turn it back on when you are not using the computer – or let it finish overnight (or over a few nights… ;-)).

Thanks Rene for your reply… good to know that I can stop it :slight_smile:

Unfortunately this doesn’t help to solve my problem…

I can use Roon with another dac through wasapy, not in the network but connected directly to the pc. Look like is a problem with the network connection?

When you tried attaching the server directly to the router, did you disable WLAN for your trials? I suppose the WLAN configuration on the Pi3 is also either unconfigured or disabled?
Agree that it seems like a networking issue…
Cheers /Mike

Hi @enrico_calzona ----- Thank you for the report and sharing your feedback with us. Both are appreciated!

May I kindly ask you to verify the following information for me:

  1. Please provide the details of your network configuration/topology, as well a providing insight into any networking hardware you are implementing. I want to have a clear understanding of what the chain of communication looks like across your network.

  2. Can you please confirm that you don’t have any active firewalls or antivirus applications running on your setup.


Also make sure JUMBO FRAMES is OFF - can’t say for sure thats the issue but its worth checking

Thanks to all your reply and supports… really appreciate!
I will check and reply tonight when I back home (I live in Korea and we have 7 hours difference with europe)

What I can say right now is that the WLAN is disabled and reading the link regarding the “JUMBO FRAMES” look like that should be a good solution to my issue…

Thanks again and Regards,

Hi Enrico,
I spent some months trying to fix a similar issue only to find out that the problem was in an HP switch (Can't play HiRes file on my network (Audio file loading slowly) [Solved]). My suggestion is to check well the compatibility of all your network devices with ROON.
Best regards,

Hi @Eric,

Thanks for your reply… regarding your questions:

  1. My LAN right now is very simple. I have one router (model KT_WLAN_B75A) with my PC and the HifiBerry wired to the router.

  2. the Windows firewall is OFF and I just disinstalled the Bitdefender

Best Regards,

Hi @wizardofoz,

Unfortunately the Jumbo Frame setup was already disabled. I tried to set at 9K (as I read in the thread you sent me) but doesn’t solve. As suggested I back disabled anyway

Best Regards,

Hi @Giulio_Salvioni

Thanks for your reply… unfortunately I don’t have the skill and knowledge to check the compatibility as you suggest.

I just hope that with your support I can finally enjoy the Roon :slight_smile:

Best Regards,

My first attempt would be to connect the PC to the LAN with an Ethernet cable.
Best regards,


The PC and the RPi are actually connected to the LAN with the Ethernet cables.
As I said above the LAN is quite simple, one router, the PC and the RPi connected with cables

You mentioned Bitdefender, can you try turning that off, as firewalls can interfere with Roon