Interaction Synology NAS and "roon system"

Roon Core Machine

Roon Nucleus (with up to date software)
connected via ethernet to LAN

Networking Gear & Setup Details

Synology NAS DS1812+
Connected via ethernet to LAN

Connected Audio Devices

Innuos Zen mini player/endpoint
Connected via ethernet with LAN

Number of Tracks in Library

150.000 tracks on Synology NAS

Description of Issue

Whenever the NAS is powered up the complete roon system goes down:

  • roon core (on nucleus) disappears
  • the Zenmini player is still visible in the roon/settings/audio and can be enabled HOWEVER it can NOT be selected als a player if I want to play music (using the roon app, on ios and on Mac: same problem)

HOWEVER the NAS as well as the internal disk of the Zenmin ARE still visible and accessible, so it seems to be a “sofware interaction between the NAS and the roon system”
I have powered down the nucleus and selected the Zenmini as the roon core. The roon core on the Zenmini can be “started” (apparently: roon login is asked and accepted) but then SAME problem as with the nucleus

When I power down the NAS, after some time (say, 30 min) it becomes again possible to play music (using Qobuz).
When I power the NAS up again: same problem as before.

Hey @Jan_Leysen,

Thank you very much for taking a moment to describe the behavior you’re experiencing. Also, a big thank you for your patience while we got a chance to reply after the holiday weekend.

I wonder, have you had a chance to reboot everything starting with your modem, router, audio devices to the Roon Core?

Does it help?

I did. It doesn’t help.

Is there any chance that somehow the NAS and Roon Core machine are being assigned the same IP address?

I checked. They are fixed and different addresses.

Suggestion: where do you assign fixed IP addresses: in the router or in the devices itself? You have to do it in the router.

I will try this this evening. Tx for the suggestion.

You have to set devices as DHCP client then (and therefore delete the fixed IP’s in the devices).

All devices are in DHCP now. After having powered up the synology (he was down for several days and roon worked fine) after a couple of minutes the “roon system” was again down.
Again: the nucleus remains accessible via the web interface.
However, the server software has REBOOTED (after I powered up the NAS):
Version 1.8 (build 831) stable
Running 13 minutes, 55 seconds.
NOT the operating system: has been running since I powered up the nucleus 3 hours ago
Version 1.0 (build 227) stable
Running 3 hours, 15 minutes, 4 seconds.

So what is happening IMHO: as soon as the NAS is powering up, the roon server software is CONTINUOUSLY rebooting.

I am sorry but I’am running out of ideas. :disappointed_relieved:

I installed another NAS (from WD) with only 28 tracks of music.
The SAME problem occurs after some time: server software on nucleus constantly rebooting.
I discovered - as you certainly know - that there are severeal threads of users experiencing the same problem.
However (so it seems to me) several of these threads were closed before their problem was solved.

I have read your posts over and over again thinking about what’s going on here. In several posts you wrote that the server software rebootts after powering on the NAS.

What exactly do yoy mean? Is the Nucleus rebooting or is only the Roon core restarting?

Only the server software on the nucleus. As has been reported by several other roon users on your forum.


So I am not the only user experiencing this problem.


I have removed the path to the (both the WD and the Synology) NAS (in Roon app/Settings/Storage) and now (at least since a couple of hours) teh problem does NOT occur anymore.

So the continuous reboot happens when the nucleus tries to acces the (both) NAS.

Hi Jan,

For clarity I am just a Roon user and not from Roon support. I understand you are frustrated but I can only try to help.

First I suggest that you send @beka a privat message on this board. That is more direct and probably helpfull for her.

Second I have read the links you posted. Did you follow the suggestions from @noris especcially in the second post?

Thanks, Alfred!
I thought I was talking to a roon service support technician…
I am not at home so will check again the noris posts when back.
Very kind regards,

Hi Alfred,
When the path to the music on the NAS is removed, the problem disappears.

Hi Jan,

It seems a network problem to me. The reboot occurs with a path in Roon to the Synology as well as to the WD (also connected via ethernet).

Perhaps there is a problem with your ethernet cable connected to the Nucleus? Is it possible to do a try with an other cable / switch. You can also try with the Nucleus+NAS directly connected to your router (without switches or other devices connected).

If that does not help I think it is an issue in the software. Probably you can try to install the nucleus software again but that is a lot of work. Be sure you have a proper and recent Roon backup then.

Best regards, Alfred

Thanks again, Alfred!

Hey @Jan_Leysen,

It’s so wonderful that, while we get a chance to chime in, Roon subscribers are so willing to help. Thank you @Alfred_van_Hoorn for being this great in offering help :white_check_mark:

If I understand correctly, without a storage location attached (a NAS or the WD) Roon on your Nucleus works fine. Whenever you add them, the Nucleus restarts constantly. Is that so?

Just like @Alfred_van_Hoorn, I’d advise reinstalling the Roon OS from the Nucleus Web Administration Interface. This will not remove your data (only the database reset does that).

Could you please give that a try?

Hey @Jan_Leysen,

You’ve just mentioned that reinstalling the OS did not help — I’m sorry.

I wonder, can you connect the WD drive and the NAS to a different device than the Nucleus (a laptop or a PC, for example) and access and play the music stored there?

1 Like