iPhone output device sometimes disappears when running on iPhone

Core Machine
Intel NUC i3 Gen 8 / 16GB RAM / Ubuntu 20.04
Connected to router by ethernet
OS and Roon database on SSD
Music files on USB3 drive
Tidal and Qobuz both connected
Version 1.7, Build 795

Network Details
Asus RT-AX56U router

Audio Devices
RPi 3 with Hifiberry Digi2 connected to router by ethernet running RoonBridge and ShairPort
RPi 4 connected by wifi running RoonBridge, out put to iFi iDSD micro via USB
Two Dynaudio AirPlay speakers

iPhone Xs / iOS 14.6

Library Size
60K tracks

Description of Issue
Sometimes when I run the Roon Remote app on the iPhone, the iPhone itself does not appear in the list of playback devices. Eventually it comes back. I haven’t been able yet to work out any pattern as to when it goes away or comes back, I thought it was happening when I change the iPhone output device (e.g. attach bluetooth headphones) but haven’t been able to reliably reproduce.

iOS devices are by default (in the roon settings on the device) in private mode and wont be seen by other control devices.

This is happening on the phone itself, not on another control device.

I’m using the app on the phone, I can’t play back to the phone while I’m using it.

Hi @matt

When this happens, does it come back if you close the app and re-open? What about rebooting?

Does this tend to happen when certain other apps are running in the background?

does it come back if you close the app and re-open?

No

What about rebooting

I haven’t tried

Does this tend to happen when certain other apps are running in the background?

No idea

@support It looks like this is happening after connecting to the TailScale VPN as described here. There is another report in that thread of the same problem.

In case it’s not completely clear: the iPhone is not appearing as an output on the iPhone itself, it’s disappeared from the list of available output devices in the settings in the app running on the iPhone

Hey @matt,

As the post you’ve linked shows VPN is not officially supported by Roon. If you completely disable the VPN, is your iPhone still disappearing as an audio zone?

It happens intermittently. I don’t have 100% proof but it does appear to be related to using the TailScale VPN.

Please, if you can, let us know if running it without the VPN brings stability.