Keeps skipping tracks, stopping mid track


Core: i7, 8gig ram, 64gig ssd, desktop, all non-essential apps removed, windows 10 64bit, core 1.4 64bit

Router: tp link ac1750, latest firmware

Endpoint: Allo usbridge with roon raat, Ethernet, bridge 1.0

Speedtest indicates 60Mbps consistently. Bubble upnp serves music no problem.

Tidal only, no local music.


“Tidal: tidal media is loading slowly. This may indicate a networking or connectivity problem”, track skips.

I can’t get through an album without interruption. It’s very frustrating and why I cancelled a year ago, but forgot before subscribing again last week.

I get the same thing. AirPlay streams Tidal flawlessly. Tidal app on iPhone X works. I really regret buying a Roon lifetime membership.

Thank you for the report at @Marshall_Hance, sorry to hear of the troubles and frustrations here.

From your report I see the only mentioned endpoint is the ALLO USBridge, what exactly is this device feeding into? Furthermore have you confirmed what the experience is like when streaming to another zone or perhaps attaching a DAC directly to the core machine?

Additionally, how do things behave outside of Roon when just using the TIDAL app either via the WebUI or the desktop application?


@David_Wagner — The feedback is appreciated, thank you. If you are having an issue I would be glad to try and help you get to the bottom of it. Have you raised this concern elsewhere?

The reason I ask is because I did a search of your posts on the community site and the last response you had sent me here (“Chord Poly, Roon, Tidal track not available”) was the following:


@David_Wagner @eric

From allo to gungnir mb, usb5.

No problems ever in any other circumstances that are available to me outside of Roon.

Reading other threads, I switched my DNS from Google’s to Cloudflare’s? and voila, problem solved. Seems like there must be a tidal login token issue as has been suggested in other threads.

This seems like a legitimate fix or better, a place to explore other solutions.

Btw, I wanted to try Roon again for the interface, since streaming from the phone killed the battery and wasn’t a clean setup generally. However, I don’t understand how much thicker and more detailed my music is running through Roon vs bubbleupnp. Beyond my understanding, but I’ll take it.


Problem remains, unfortunately.

Hi @Marshall_Hance ----- Thank you for the continued feedback and more importantly, thank you for your patience here. Sorry to hear of the continued troubles.

Continuing forward, can you verify for me if you are making use of any other networking hardware besides the mentioned router (tp link ac1750)? These items would include switches, additional routers, powrline adaptors , etc. I want to have a clear sense of what the chain of communication looks like in your network topology.


Core connects to router via tp link tl-sg105 switch, endpoint via a tp link powerline adapter.

I should say the problems previous to the dns change were consistent regardless of time, and after only happened last night, from 6:30 to 11:00 pm Eastern time, a timespan during which I’ve had problems with tidal before. I’ll see what happens tonight.

Hi @Marshall_Hance —— Thank you for the follow up and providing the requested information! Very appreciated!

I noticed that this thread had been closed, which is strange because I did not close it :thinking: Letting you know that it has been re-opened.

Continuing forward, I wanted to check in with you about the mentioned time frames in your previous post. Any observations to share? Secondly, I would also like to recommend trying to test the endpoint when the mentioned Tp link power line adaptor is temporarily bypassed as I have seen issue with these device in the past.


Same issue here… Seems like there is no workaround yet

Hi @Marcelo_Toledo ----- Thank you for chiming in and sharing your feedback with me, both are appreciated!

Moving forward, may I very kindly ask you to please provide me with the following information:

  • Please provide a brief but accurate description of your current setup using this link as a guide.

  • Please describe your network configuration/topology being sure to provide insight into any networking hardware you are currently implementing. I want to have a clear understanding as to how your devices are communicating and all the tools involved with making those connection possible.

  • When you notice this issue occurring is it strictly when playing back TIDAL content OR does local content exhibit the same behavior? Additionally, in either scenario is Roon generating any error message or warning?

  • Do you notice any patterns in behavior when the issue occurs? For example does this only happen when you stream to a specific endpoint?


I’m noticing this same Tidal error message tonight. I just upgraded to Roon 1.5 a couple days ago.

I have 3 Eero mesh routers, 150mbps down from Xfinity/Comcast. There is a single Roon endpoint, PS Audio DirectStream DAC with Bridge II card via ethernet to an Eero onboard port. Server side is an i5 NUC running the latest ROCK.

I logged out of Tidal within Roon, then back in, which has fixed this in the past. Tonight, that doesn’t seem to work. Streaming the same content directly via the Tidal app via mConnect to the PSA Dac works fine.

I’ve reluctantly (fear of throwing good money after bad) replaced the powerline Ethernet with a WiFi to Ethernet adapter and all seems well so far…

Nope. Not 100%. Still dropping out time to time.

Hi @Marshall_Hance ---- Thank you for the follow up and sharing what the observations you had made while using the mentioned Ethernet adapter. The feedback is greatly appreciated!

Moving forward, during your troubleshooting of this behavior have your tried (temporarily of course) disabling the BubbleUPnP just to confirm what the experience is like with this process inactive? Secondly, I know I had asked this previously, but have you been able tp verify what the experience is like with your DAC mounted directly to the core thus bypassing the Allo temporarily?


Basement system connected to the core does not skip. Main system upstairs skips. Bubbleupnp has been disconnected since trying to troubleshoot but never had problems. When playing a core local file to the allo upstairs I get this message:

Hi @Marshall_Hance ---- Thank you for touching base with me, the follow up is appreciated!

This certainly feel like an environmental issue to me and as such I would like to propose mounting the ALLO directly to your router and attaching it to your main system upstairs to confirm how it performs.

Additionally, are there any other device mounted to Allo besides the DAC?


I’m unable to position the router near the allo/stereo. I’m using the wifi wifi extender to deliver an Ethernet connection to where my stereo is. Nothing but a cable between the allo and the dac.