Lenovo Yoga Stuck in portrait

not as far as I know

Hi @danny , any luck?

Hi @danny, I thought I post an update of my frustration trying to get this sorted. Lenovo, speak to Android (Google).

Google, speak to Lenovo.

Neither can assist with rolling Android back to 5.1.

Any luck at your end?

Cheers, Geoff

Hi - Has there been any progress on this issue? I have just purchased a Lenovo Yoga 3 10.1 for Roon use and have the same problem.

I have made progress on this. The follwing link gives instructions for changing the android dpi without rooting the device.

How to change DPI in an android device

I am messing around with the DPI. 140 works but I’ll keep going until I find the cutoff point.

Cheers
Tom

2 Likes

cutoff point around 190 dpi

cheers
tom

:unamused: wished I’d found that out before upgrading the tablet…

What did you go for? It’s far from perfect as all apps have become less stable. I need to do some more testing!

Cheers
Tom

I stayed with the Lenovo yoga’s because I love the built in stand and the huge battery. I got the next model up - much higher spec’s and a built in projector! Very happy with it!

This works… set mine to 190 and it 's fine.
Thanks for that!

Ok, I got to the root of this… and it looks like the others got this right by messing with the DensityDPI setting.

The problem is that Android source code (I checked latest) has a mechanism of detecting phone mode, which is: smallest size * 160 / densitydpi – if that value is < 600, you are considered a phone, and Roon trusts the OS.

This device, being 10 inches diagonal and 1280x800, should have a DPI of ~150, as per https://www.sven.de/dpi/

The problem is it is reporting a densitydpi of 213 (TV). If they really wanted to stick to the Android steppings, it should be reporting 160 (MEDIUM).

If they did the right thing, Roon would want to run in tablet mode (landscape). But, because of this stupid setting, they are making your 1280x800 tablet feel much more like a 960x600 tablet :cry:

NOTE: I also speak to the technology in Android behind all this here:

https://community.roonlabs.com/t/where-is-alphabetical-navigation-in-android-client/13659/21

Hi
Do you know why lenovo would do this?

Cheers
Tom

A hardware team that area and a software team without a clue about product experience. Pretty much par for the course in the world of hardware manufacturers.

1 Like

Can an option not be added to Roon to force tablet and/or phone mode, with the default being that as currently determined by Roon?

and what, have it clip? have it render funny with overlapping text and ui elements?

I’m guessing only those that need it because their tablets report incorrectly will use it.

Yes, and then they will have a terrible experience, with critical functionality missing or broken, and our support team will have to debug these situations… ugh.

We don’t place these restrictions arbitrarily… we have to consider the full UX + support path.

I updated my post above, but I’ll repeat myself again.

I also speak to the technology in Android behind all this here:

https://community.roonlabs.com/t/where-is-alphabetical-navigation-in-android-client/13659/21?u=danny

I have just bought my Lenovo Yoga 3 to use with Roon and discovered the hard way the DPI problem which causes Roon to default to the portait orientation. I have followed the instrunctions and changed the DPI setting to 190 without root. This fixed my problem and makes Roon to use landscape orientation as desired but messes other apps such as the camera app which does not respond in landscape mode. Are there any plans to add a feature in Roon to address this issue?

Setting the dpi to 160 using this link (shared by Tom in July 2016 here above) also worked for me for the Lenovo Smart Tab M8 to bring it to tablet mode.

1 Like