Lots of things not working. [resolved: ipv6 stuff needs to be disabled (for now)]

Roon is unusable and the support is lacking. The multitude of issues I’m experiencing has made Roon impossible to use.

And now search is not working. This happens for every search term:

What am I paying for exactly if the software is constantly broken? I have received very little support previously other than “What is your hardware?” which is irrelevant imo, and simple things that I’ve already thought to try and didn’t work. (Restart, sign out and back in, etc.). The software is unusable, which means I’m paying to not listen to music via Roon. I am extremely frustrated at this point.

Additionally, it’s pretty obvious my cases are not isolated incidents; the support forum is so busy with similar issues that posts are going unanswered. I hope you understand that the optics on this are very bad. I help manage a community forum with thousands of daily active members. And up until recently I would recommend Roon as often as I could. But I cannot in good faith recommend the software now given the issues and lack of support.

The software was fantastic when it worked. Please make this right.

It does appear many are not suffering you woes, but all software can have hiccups. Roon so far for me has been faultless.

I’d allow tech support time to investigate. They will have to prioritise the greater faults first or will reply individually with help tips.

I’d first try a full reset (turn off/on) of your network. Core, endpoints etc.

Are you wired or WiFi. Might be a firewall issue.

Others will chip in with other helpful tips if you allow.

I checked your Roon logs, and you have many errors where the Qobuz API is returning nonsense.

Inside Roon > settings > services > qobuz, please try logging out and logging back in (of Qobuz).

I’ve done this once already and the issues persist. I will try it again.

Try to log out of Roon and back into Roon as well. I’m pretty sure this will fix everything.

I think you had a network hiccup that caused authentication stuff to fail, and things are snowballing. It’s in line with the errors you are seeing.

I’d do the Qobuz re-login AFTER you do the Roon re-login.

I’m trying to figure out how you got into this situation w/o just erroring out, but the above should get you into a good state.

I think it’s related to the fact that we allow some auth failures to occur because you may be “offline” – so now the app is confused on whether you are online or offline.

The login animation continues for a minute or so before returning a Network Error:


something is really strange…

you cant access our account servers, but you can get elsehwere…

08/02 16:29:25 Warn: Error in web request https://accounts5.roonlabs.com/accounts/3/login: NetworkError (The operation has timed out.)

you have an /etc/hosts or some firewall blocking or proxying or redirecting those requests?

I’d also look into any DNS caches or DNS issues…

Can you try to restart the RoonServer process?

@ALANMAN Do you have means to utilise another router with a firewall and disable pfSense. Just a thought.

Restarting the roonserver process via systemctl on ubuntu has no effect. I’ve also restarted the roon core PC.

I’ve cleared the DNS resolver cache in pfsense and also rebooted it.

I’m still not able to login to Roon.

I do not have another router available.

there is one big diff between the accountserver and the others… the accountserver is on ipv6 as well

anything on your end supporting ipv6?

IPv6 is fully supported afaik. I have both an IPv4 and IPv6 address assigned to my WAN port by my ISP.

ok, lets try something:

edit your /etc/hosts and add an entry for accounts5.roonlabs.com for

you cant live like that forever, but it’s a quick test.

actually, if you havent already, just try to login again… i removed the ipv6 from our dns for that hostname.

I had not added it yet, but sign in now works.

I am still seeing the odd behaviors as before.

now try the qobuz login/logout.

@danny could you please explain the possible cause of, and the solution in layman terms. My tech nerd days are long gone I’m afraid.

@ALANMAN – I’d also restart roonserver.

We have had a few reports from users having issues with accounts5.roonlabs.com – only @ALANMAN and stuck it out to help with information.

@ALANMAN – are you on comcast by any chance?

All the previous users were, and I’m fearing they are doing a rollout of IPV6 and something bad is going on somewhere along the path.

1 Like