.m4a file cannot be played

Core Machine (Operating system/System info/Roon build number)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
Suddenly I can’t play the songs I bought on iTunes, the file format is a .m4a file.
Until yesterday, it was able to play normally.

Please tell me how to deal with it.

Hi @Morihiko_Inamine,

In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

What trouble shooting steps have you tried, for example rebooting the Roon Core?

The environment is as follows

Roon core (Roon Server (build610)): Qnap-451 + (mem8GB)
Roon Bridge (build571): Windows PC (CPU: i7-4600U, Mem: 8GB)
USB-DAC-> Speaker
Roon Remote: Windows PC

The above is the environment
We have confirmed that .m4a file songs can be played on a media player on a Roon Bridge PC.

The network is a wired LAN that uses a LAN cable.
The network is the same segment

The confirmations made are as follows.
-Rebooting the Roon Server machine.
Result: .m4a file song cannot be played
・ Restart Roon Bridge PC
Result: .m4a file song cannot be played
-Reinstall Roon Bridge
Result: .m4a file song cannot be played
-Playing songs from .m4a files on a media player on RoonBridge PC
Result: The song could be played normally

thank you very much.

You can now play songs from .m4a files safely.

By uninstalling the Roon Server software and then installing it again, the songs can be played normally.

After all, it was no good.
It seems that the cause is the upgrade of QNAP’s firmware.
It has become strange after the version upgrade to 4.5.1.

Hi @Morihiko_Inamine,

Are you saying that since updating your QNAP version and reinstalling Roon the issue has been resolved? If so that is wonderful news, please let us know if there’s anything else we can assist you with!

After uninstalling Roon Server, I installed it again and immediately after that, I was able to play it without any problems.

After that, when the background audio analysis of the library was finished, the .m4a file could not be played again.

I fell asleep while waiting for background audio analysis and couldn’t play the next day.

Hi @Morihiko_Inamine,

What happens if you temporarily set the Roon Bridge PC to act as the Roon Core, does the same issue reproduce or only when the QNAP is the Core? To switch Cores:

  • Open Roon on the other PC you wish to try as the Core
  • Roon Settings -> General
  • Disconnect
  • On the “Choose your Core” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time but you are free to switch between them as often as you’d like.
  • Verify if the same behavior occurs on the different PC

When I installed Roon core (Roon Server) on my Windows PC and referred to Qnap’s network disk for music data, I was able to play .m4a files as well.

Apparently the problem is with Qnap’s firmware 4.5.1.
After this, also try the new Qnap firmware (QTS 4.5.1.1461 build 20210020).
Thank you for your advice.

I updated Qnap’s firmware and reinstalled Roon Server and tried it, but it didn’t work.
Settings-> Library-> Background Audio Analysis sometimes counts very quickly, so I think that DRM is applied. Is it interpreted that .m4a and .m4p are mistakenly applied and DRM is applied?

For the time being, Roon Server runs on a Windows PC.

1 Like

Hi @Morihiko_Inamine,

That is very strange, so the issue only occurs when the Core is the QNAP but not on Windows?

Can you please send me a private message (click my name here -> message) of a file that displays this issue via Dropbox / Google Drive?

I too have confirmed the issue. I’m running QNAP NAS 877 with latest firmware TS-X77_20201024-4.5.1.1465. Thought I was losing my mind as I have 3 endpoints that all exhibit the same issue iPhone 8, and 2 Windows 10 v2004 computers. No issue playing FLAC or MP3. Only M4A (AAC) will not play… no audio sometimes Roon says no file. I thought the issue was introduced with latest version of Roon but it appears its QNAP Firmware.

Same problem here. M4a files wont play, no error message. Same on all endpoints, win 10, Android and IPad. Roon Core on HS 453 DX, Firmware 4.5.1.1465.